Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

USB Flash drive won't work. External USB Hard disk works

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
I have a Celeron 2.13 GHz processor on VIA 845 based motherboard with 128 MB RAM. I have a Transcend JetFlash 256MB USB Pen Drive. The problem is that the drive does not work on my machine. Whenever I plug it in it gets detected properly, but if I try to copy anything from it, it refuses to workk. The LED on the drive flashes as it does when you are writing to the drive but nothing happens. Until you pull out the drive physically, it hangs up Windows Explorer. The drive works fine on almost every other machine I tested on. Also, I have an external USB Hard disk which woks just fine on the same machine. What could be the problem? I have tried all 4 USB ports on the machine with the same result.
  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP