Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

OS problems (Windows Installer)


  • Please log in to reply

#1
Achilarre

Achilarre

    Member

  • Member
  • PipPipPip
  • 112 posts
Hi,

For a long time I was having OS problems (could not see streaming media etc...) so I reinstalled Windows. Since then I have had many more problems. Now I cannot download any updates or install any programs. Also many of my old programs that I installed years ago no longer work.

I continually get the, "windows could not install" error.

Please help

Thanks so much
  • 0

Advertisements


#2
Guest_rushin1nd_*

Guest_rushin1nd_*
  • Guest
Do you get a message like this



Windows Installer

The Windows Installer Service could not be accessed.
This can occur if your running Windows in safe mode,
or if the Windows Installer is not correctly installled.
Contact your support personnel for assistance

try these


http://download.micr...1BD/msicuu2.exe



http://support.micro...spx?kbid=290301

Reboot and try the installation



what type of computer you got
  • 0

#3
Achilarre

Achilarre

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 112 posts
Hi,

That is the error message I am receiving.

I clicked on the first link and it said page cannot be displayed

then I tried to download the second link and I got the usualy error message.

Please help...thanks!
  • 0

#4
Guest_rushin1nd_*

Guest_rushin1nd_*
  • Guest
I guess your not in safe mode or do you know if you are.


What i found out about my problem is i had 2 windows installer and at some point they were in conflict with each other and gave me that message. In my ADD AND REMOVE PROGRAMS it show only one.


Now i got a ibm computer and this how i found out i had 2 Windows Installer.

I went to access ibm and at top of page Ckicked on system files and went to advance went to software clicked on installed software thats where i learned i had 2 of them. went back add n remove programs uninstall figured it going to work or i can download or update it it worked for me now im able to download from software and websites, also click refresh your pge at top of your icon bar if get cannot display this page. so my guess is look for something similar on your computer that will show you a list of all your installed software and if it aint that someone or moderater will help you out now im in canada and to have my windows xp repaired they wanted to charge me 25.00 dollars so i came here the geeks room for help .
  • 0

#5
Achilarre

Achilarre

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 112 posts
I have a Dell computer.

I am not running in Safe mode, but that is the error I am getting. I do not think I have conflicting installers.

What else can I do>?
  • 0

#6
Sintic

Sintic

    Member

  • Member
  • PipPip
  • 22 posts
Hi,
I'm presuming your running 32bit XP so try this...

Check that you have the msiexec.exe file in your windows/system32 folder (do a search for it)
then navigate to
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSIServer
via Start>Run>regedit. Once there check the 'ImagePath' key points to the location of the msiexec.exe
for example if your windows is installed on the C:\ drive it would be
C:\WINDOWS\System32\msiexec.exe /V
Next start your computer in safe mode (by pressing F8 before OS boot up) then
goto 'Start>Run and type:
msiexec /regserver

Restart computer into normal mode, then let us know if its still doing it.

thanks.
  • 0

#7
Guest_rushin1nd_*

Guest_rushin1nd_*
  • Guest
Some one will come along to help you. i was lucky to find my problem. This is a great room so be patient



GOOD LUCK
  • 0

#8
Achilarre

Achilarre

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 112 posts
Thanks

I searched for MSIEXEC....I have it in 5 diff places actually (not sure if that is good or not). I also have 1 MSIEXEX.PR

Then I did everything else you said...the image path was pointed in the right direction.

I rebooted in Safe Mode and did the msiexex /regserver.....it said "AN EVENT WAS UNABLE TO INVOKE ANY OF THE SUBSCRIBERS"

So it didnt work I guess....please advise

thanks
  • 0

#9
Sintic

Sintic

    Member

  • Member
  • PipPip
  • 22 posts
umm odd
what happens if you type
msiexec /regserver
without loading in safe mode?
  • 0

#10
Achilarre

Achilarre

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 112 posts
same error

it says WINDOWS INSTALLER up top

then the error
  • 0

#11
Sintic

Sintic

    Member

  • Member
  • PipPip
  • 22 posts
Anyway ...
can try re-installing windows installer
goto Start>Run and type 'cmd'
at the command prompt type:

attrib -r -s -h c:\windows\system32\dllcache

nav
then type in:

cd c:\windows\system32

ren msi.dll msi.old
ren msiexec.exe msiexec.old
ren msihnd.dll msihnd.old

pressing enter after every line!
type exit
install the latest windows installer (if you can)
http://www.microsoft...&displaylang=en

reboot.

Edited by Sintic, 22 April 2006 - 11:43 AM.

  • 0

#12
Achilarre

Achilarre

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 112 posts
ok i did everything you said..i think it all worked


then i went to download updates..the update i need downloaded is SP2

In the middle of the download I kept getting errors saying it "could not backup up registry key" over and over

what now?

am i making progress??

thanks so much for your help
  • 0

#13
Achilarre

Achilarre

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 112 posts
one more thing

the download stopped and said "access is denied"
  • 0

#14
Sintic

Sintic

    Member

  • Member
  • PipPip
  • 22 posts
ummm that is verrry strange :blink:
i hope somebody will be able to take off where i've left because i have to leave for work in 5 mins.
but first try loading up 'safe mode with networking' and try to get that installer again.

you can rename the files back to how they were by typing in cmd prompt:

cd c:\windows\system32

ren msi.old msi.dll
ren msiexec.old msiexec.exe
ren msihnd.old msihnd.dll

try downloading microsoft updates after you have renamed them back etc etc.
i'm afraid im pretty much stuck on this one :whistling: eeeek.

you could also try repairing windows or re-installing again. or even get hold of a SP2 cd.
thanks

Edited by Sintic, 22 April 2006 - 12:38 PM.

  • 0

#15
Achilarre

Achilarre

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 112 posts
thanks for your help

sorry to say same problem...cant download any updates...
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP