Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Cannot defragment drive Win XP


  • Please log in to reply

#1
ruffruff

ruffruff

    New Member

  • Member
  • Pip
  • 6 posts
I was running a defrag on a partition (y) when the power went out. After the power was turned on, I tried to defrag again and received a message that Chkdsk was scheduled to run. I ran chkdsk (chkdsk /f /r /y) (the volume was dirty) and rebooted. When I tried to run the defragmenter again, the same message popped up. I read that a drive that has been turned off during a read-write operation causes this...I am at a loss. Please help... :whistling: I need to defrag my hard drive.
  • 0

Advertisements


#2
wannabe1

wannabe1

    Tech Staff

  • Technician
  • 16,645 posts
Hi ruffruff...

Query the drive again...is it still dirty?

Click Start, then Run, type cmd, and click "Ok". In the command window that opens, type fsutil dirty query y: at the prompt and press "Enter".

wannabe1
  • 0

#3
ruffruff

ruffruff

    New Member

  • Topic Starter
  • Member
  • Pip
  • 6 posts
This is the message I see after restarting , "Warning! 1 parameter specified. Your drive may still be corrupt even after running CHKDSK. The volume is dirty. " I let the computer go through the 5 steps but the volume is still dirty and will not defrag. :whistling:
  • 0

#4
wannabe1

wannabe1

    Tech Staff

  • Technician
  • 16,645 posts
ruffruff...
  • If you have Spyware Doctor installed, uninstall it.
  • If you have ZoneAlarm installed, open it, click the "Overview" tab, then select "Preferences", and UNcheck the "Protect ZA Client" check box.
Click Start, then Run, type cmd in the Open box and click "Ok". At the prompt in the Command window, type the following commands, pressing "Enter" after each one: (Please note the spaces in the following commands.)
  • chkntfs /d ..... (This will reset autocheck options to default)
  • chkntfs /y Y: ..... (This will allow checking drive Y:)
  • fsutil dirty query y: ..... (This queries the drive and will most likely tell you that it is dirty)
  • chkntfs /x y: ..... (The x switch tells Windows to NOT check the specified drive on the next boot)
At this point, restart your computer, it will not do a chkdsk and will boot directly to Windows.

This next step is important as this is where the Dirty Bit will be unset.
Click Start, then Run, type cmd in the Open box and click "Ok". At the command prompt, type the following, pressing "Enter" after each one: (Again, note the spaces.)
  • chkdsk /f /r y: ..... (To manually run a full chkdsk operation)
  • Y ..... (To accept having it run on the next boot)
This should take you through 5 stages of the scan and will unset that Dirty Bit. Be patient...this is a very thorough check and will take quite a while.

Finally, when the chkdsk operation has completed, type fsutil dirty query y:, press "Enter", and Windows will confirm that the Dirty Bit is not set on that drive.

Now reboot again and see if you can defrag the drive.

wannabe1

Note: The commands in this reply are specifically for this member and will not be valid commands on other computers.

Edited by wannabe1, 10 May 2006 - 07:06 AM.

  • 0

#5
ruffruff

ruffruff

    New Member

  • Topic Starter
  • Member
  • Pip
  • 6 posts
Thanks for trying to help...I tried typing the commmands but when I tried "chkntfs /y Y:" I got an "invalid parameter" message. Any idea? :whistling:
  • 0

#6
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
y: refers to a y: volume, which I do not think you have, do you?

I think that was a typo or he means substitute your drive letter (c:) for y:
  • 0

#7
ruffruff

ruffruff

    New Member

  • Topic Starter
  • Member
  • Pip
  • 6 posts
The partition in question is named "Y"...I have a large hd that is partitioned into 3 parts. The y: volume is the one I cannot defrag :whistling:
  • 0

#8
wannabe1

wannabe1

    Tech Staff

  • Technician
  • 16,645 posts
Is it the "Y" partition that is coming back as "dirty" or is it the root drive (C:) that is flagged as dirty?

Have you queried the drive as I suggested in my first reply to the topic? If not, query the C: drive:

Click Start, then Run, type cmd, and click "Ok". In the command window that opens, type fsutil dirty query c: at the prompt and press "Enter".

Does this drive come back flagged as "dirty"?

Edited by wannabe1, 10 May 2006 - 03:53 PM.

  • 0

#9
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
ahh, read too quickly

valid parameters for chkntfs are

volume: [...] : Required. Specifies the drive letter (followed by a colon), mount point, or volume name.

/d : Restores all chkntfs default settings, except the countdown time for automatic file checking.

/t[:time] : Changes the Autochk.exe initiation countdown time to the specified amount of time entered in seconds.

/x volume: [...] : Excludes the specified volume from being checked when the computer starts, even if the volume is marked as requiring chkdsk.

/c volume: [...] : Schedules the specified volume to be checked when the computer starts.

There is no /y parameter

chkntfs y: will set it to check that volume
  • 0

#10
ruffruff

ruffruff

    New Member

  • Topic Starter
  • Member
  • Pip
  • 6 posts
I queried the "c" drive and it is not "dirty"
  • 0

#11
wannabe1

wannabe1

    Tech Staff

  • Technician
  • 16,645 posts
It would appear gerryf is correct about the typo...and I only had to read the whole thing three times to spot it... :whistling: I had included a y switch when there is no y switch it should have been a c switch to enable checking a specified volume...nice catch gerry, and sorry for the confusion. Modified instructions follow...

Click Start, then Run, type cmd in the Open box and click "Ok". At the prompt in the Command window, type the following commands, pressing "Enter" after each one: (Please note the spaces in the following commands.)
  • chkntfs /d ..... (This will reset autocheck options to default)
  • chkntfs /c Y: ..... (This will allow checking drive Y:)
  • fsutil dirty query y: ..... (This queries the drive and will most likely tell you that it is dirty)
  • chkntfs /x y: ..... (The x switch tells Windows to NOT check the specified drive on the next boot)
At this point, restart your computer, it will not do a chkdsk and will boot directly to Windows.

This next step is important as this is where the Dirty Bit will be unset.
Click Start, then Run, type cmd in the Open box and click "Ok". At the command prompt, type the following, pressing "Enter" after each one: (Again, note the spaces.)
  • chkdsk /f /r y: ..... (To manually run a full chkdsk operation)
  • Y ..... (To accept having it run on the next boot)
This should take you through 5 stages of the scan and will unset that Dirty Bit. Be patient...this is a very thorough check and will take quite a while.

Finally, when the chkdsk operation has completed, type fsutil dirty query y:, press "Enter", and Windows will confirm that the Dirty Bit is not set on that drive.

Now reboot again and see if you can defrag the drive.

Edited by wannabe1, 10 May 2006 - 05:10 PM.

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP