Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Sound issue

  • This topic is locked This topic is locked




  • Member
  • PipPip
  • 15 posts
I wasn't able to get audio when I would watch a video on the internet. But using iTunes or Windows Media Player, sound was fine. I had a friend who knows a little bit about computers try to fix the problem, but he ended doing more damage and now I have no sound whatsoever. I've re-installed SoundBlaster Live! but it has not helped any. I've also tried system restore but it has always come back "restoration incomplete." I appreciate any suggestions or ideas.

  • 0




    Retired Staff

  • Retired Staff
  • 11,365 posts
pretty sure we are working on this issue for you in at least one other thread.,,,if not, please contact me and we will re-open
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP