Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Problem setting up a Workgroup between 2 home computers


  • Please log in to reply

#31
Chris - Thecleancar

Chris - Thecleancar

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 244 posts

I have asked a Network Tech to look at this, dsenette is back in Monday and will also look at it then


Thanks very much for your time I do really appreciate it

Regards

Chris
  • 0

Advertisements


#32
Chris - Thecleancar

Chris - Thecleancar

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 244 posts
Hello - Thanks for helping me - I've had several PCs and different O/S over the years and have never been able to network them successfully. I begin to think it must be something very basic (or stupid) I'm not doing

On the Host computer, please goto Start --> Run --> type \\192.168.0.3 -- Press enter.. You should either connect to the Client, or recieve an error (give it a minute or two; there is often a delay). An even better idea would be to type in a full path to a file on the Client computer that you have shared.. So, share a file and then type in the full path name to it; ie: \\192.168.0.3\D\Shared_Folder\myFile -- eg: \\192.168.0.3\D\Music\someSong.mp3 -- what happens here?


I did as instructed with these results

Run> \\192.168.0.3 Host message "The network path was not found"
Client message from Zone Alarm "The firewall has blocked Internet access to your computer (NetBios session)from 217.42.74.41(TCP Port 1338)(TCP flags S)

Run> \\192.168.0.3\C\HJT\highjsckthis.log Host message "The network path was not found"
Client message from Zone Alarm as before except (TCP Port 1399)

Run> \\192.168.0.3\c\shared documents\shared music Host message as before
Didnt see a message from the Client

Also on the Host computer, please goto Start --> Run --> type \\net view COMPUTER_NAME where COMPUTER_NAME is the name of the Client computer.. Please post any errors that appear.

Run> \\net view systemax Host message as before
Didnt see a message from the client

If you could not connect to the Client using either of these methods, on both computers please goto Start --> Run --> type regedit and press OK --> Now, navigate to the following Key:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa
--> With the key Lsa selected/highlighted, in the right-pane, look for the value restrictanonymous (there is a value restictanonymoussam directly below; ensure that you do not select this value.) --> right click this value, select Modify and change the decimal value to 0 (zero) --> Close regedit and reboot the computer. After doing this on both computers, attempt to connect again; are you able to?

Modified the Registry entry on both PCs - unfortuneately still the same I can only see the Host in 'MY Network Places' on the Host
When I rebooted the Host I received a 'Windows security Alert' re Active Sync Communications Manager - I 'Unblocked' this

I notice that the Registry key has gone back to Base Hexadecimal is this correct ?

Thanks & Regards

Chris
  • 0

#33
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
Hi Chris,

Client message from Zone Alarm "The firewall has blocked Internet access to your computer (NetBios session)from 217.42.74.41(TCP Port 1338)(TCP flags S)

I can't stand Zone Alarm. Please add both computers to the trusted zone --
To add it to your ZA's trusted Zone --
  • Select Firewall.
  • Select Zones.
  • Click Add and then select IP Address.
  • Select Trusted from the Zones drop-down list.
  • On the Host computer, enter the Client's IP, and vice versa; eg: On the Host, type: 192.168.0.3 -- on the Client: 192.168.0.1
  • Enter a Description, eg: Host / Client.
Once done, restart both computers and then attempt to connect again. Does Zone Alarm still popup with a message? Are you able to connect?

(I know you've already done this before, but please do it again.) On both computers, please goto Start --> Run --> type CMD and press OK --> then type: IPCONFIG /ALL - please post the results here by right-clicking on the Command Prompt window, selecting 'Select All', pressing the Enter key, and then posting on this forum. Alternately, you can save your information to a text file by using the following command: IPCONFIG /ALL > C:\ipconfig.txt -- navigate to that text file, and copy/paste the information from it.
  • 0

#34
Chris - Thecleancar

Chris - Thecleancar

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 244 posts
Hello and thanks

Just to double check to see the other PC I go My network places > Entire network > Microsoft windows network > Mshome - Is that correct ( I'm getting paranoid here! )


I can't stand Zone Alarm. Please add both computers to the trusted zone --

I've amended Zone Alarm and can ping both PCs with the Firewall on (By the way your Malware guys recommend Zone Alarm !) The Windows Firewall is turned off (just for information)

Once done, restart both computers and then attempt to connect again. Does Zone Alarm still popup with a message? Are you able to connect?


Still the same cant see each other - I did not get any Z A Pop ups.

There is one other thing in 'Network connections' on the CLIENT PC there is a Dial up connection for my Broadband - when the Modem is connected to that PC - at present of course it shows as 'Disconnected' because I'm on the Host.

I ran ipconfig/all on both PCs here are the results

Regards
Chris

HOST PC

Windows IP Configuration



Host Name . . . . . . . . . . . . : dell

Primary Dns Suffix . . . . . . . :

Node Type . . . . . . . . . . . . : Unknown

IP Routing Enabled. . . . . . . . : Yes

WINS Proxy Enabled. . . . . . . . : No



Ethernet adapter Network Bridge:



Connection-specific DNS Suffix . :

Description . . . . . . . . . . . : MAC Bridge Miniport

Physical Address. . . . . . . . . : 02-03-0D-00-00-01

Dhcp Enabled. . . . . . . . . . . : No

IP Address. . . . . . . . . . . . : 192.168.0.1

Subnet Mask . . . . . . . . . . . : 255.255.255.0

Default Gateway . . . . . . . . . :



PPP adapter BTopenworld Broadband:



Connection-specific DNS Suffix . :

Description . . . . . . . . . . . : WAN (PPP/SLIP) Interface

Physical Address. . . . . . . . . : 00-53-45-00-00-00

Dhcp Enabled. . . . . . . . . . . : No

IP Address. . . . . . . . . . . . : 217.42.73.153

Subnet Mask . . . . . . . . . . . : 255.255.255.255

Default Gateway . . . . . . . . . : 217.42.73.153

DNS Servers . . . . . . . . . . . : 62.6.40.162

194.72.0.98

CLIENT PC

Windows IP Configuration



Host Name . . . . . . . . . . . . : systemax

Primary Dns Suffix . . . . . . . :

Node Type . . . . . . . . . . . . : Unknown

IP Routing Enabled. . . . . . . . : No

WINS Proxy Enabled. . . . . . . . : No



Ethernet adapter Local Area Connection:



Connection-specific DNS Suffix . :

Description . . . . . . . . . . . : TE100-PCBUSR 32-Bit Cardbus PC Card

Physical Address. . . . . . . . . : 00-ED-7C-8C-09-29

Dhcp Enabled. . . . . . . . . . . : No

IP Address. . . . . . . . . . . . : 192.168.0.3

Subnet Mask . . . . . . . . . . . : 255.255.255.0

Default Gateway . . . . . . . . . :

NetBIOS over Tcpip. . . . . . . . : Disabled



Tunnel adapter Teredo Tunneling Pseudo-Interface:



Connection-specific DNS Suffix . :

Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface

Physical Address. . . . . . . . . : FF-FF-FF-FF-FF-FF-FF-FF

Dhcp Enabled. . . . . . . . . . . : No

IP Address. . . . . . . . . . . . : fe80::5445:5245:444f%4

Default Gateway . . . . . . . . . :

NetBIOS over Tcpip. . . . . . . . : Disabled



Tunnel adapter Automatic Tunneling Pseudo-Interface:



Connection-specific DNS Suffix . :

Description . . . . . . . . . . . : Automatic Tunneling Pseudo-Interface

Physical Address. . . . . . . . . : C0-A8-00-03

Dhcp Enabled. . . . . . . . . . . : No

IP Address. . . . . . . . . . . . : fe80::5efe:192.168.0.3%2

Default Gateway . . . . . . . . . :

DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1

fec0:0:0:ffff::2%1

fec0:0:0:ffff::3%1

NetBIOS over Tcpip. . . . . . . . : Disabled
  • 0

#35
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
thanks keith and dan for stepping in here...sorry i was gone...

dan - i'm gonna sit and observe for a second...if i get any idea's i'll chime in..as usual
  • 0

#36
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
Hi Chris,

First of all, please restart both computers into Safe Mode with Networking, and then try to connect via both Network Neighborhood, and creating a 'brute' connection between the two computers.

How to restart into Safe Mode with Networking
Please restart your computer and as soon as it starts booting up again continuously tap F8. A menu should come up where you will be given the option to enter Safe Mode, Safe Mode with Command Prompt and Safe Mode with Networking (along with a few others). Please tap the down key until you reach Safe Mode with Networking, and then press the Enter key. Your computer should now boot into Safe Mode with Networking.

Just for your info, this is a 'brute' connection:

On the Host computer, please goto Start --> Run --> type \\192.168.0.3 -- Press enter.. You should either connect to the Client, or recieve an error (give it a minute or two; there is often a delay). An even better idea would be to type in a full path to a file on the Client computer that you have shared.. So, share a file and then type in the full path name to it; ie: \\192.168.0.3\D\Shared_Folder\myFile -- eg: \\192.168.0.3\D\Music\someSong.mp3 -- what happens here?

Also on the Host computer, please goto Start --> Run --> type \\net view COMPUTER_NAME where COMPUTER_NAME is the name of the Client computer.. Please post any errors that appear.

Has anything changed? If not, restart both computers back into normal mode and then continue..

On the Client computer, I see that you have the IPv6 protocol installed; is there any reason you need/want this protocol? If not, please remove it --

Goto Start --> Programs --> Accessories --> Communications --> Network Connections --> Right click on your Local Area Connection --> Select Properties --> Click on Microsoft TCP/IP version 6 once and press the Uninstall button. Allow it to uninstall, and then restart your computer. Could you then please repost the IPCONFIG /ALL's connected to your router, and also not connected.

I'm going to suggest a different method of setting up ICS; if it doesn't help, we can always go back to the other.

How to set up Internet Connection Sharing (Windows XP Computers)
(*Note: The 'Host' computer is the system that will be connecting to the Internet; 'Client' refers to any computer that is sharing the Internet connection, and is connecting to the Host computer.)

First, ensure that your LAN is setup properly for ICS:
On the HOST PC, please do the following:
  • Open up My Network Connections.
  • In the side panel, select 'Set up a home or small office network'.
  • Click Next until you reach the screen that asks 'Select a connection method'.
  • Choose the option that states 'This computer connects directly to the Internet. The other computers on my network connect through this computer.
  • Press 'Next'.
  • Select your Internet connection from the list.
  • Continue to press 'Next' until the setup is complete.
On the CLIENT PC(s), please do the following:
  • Open up My Network Connections.
  • In the side panel, select 'Set up a home or small office network'.
  • Click Next until you reach the screen that asks 'Select a connection method'.
  • Choose the option that states 'This computer connects to the Internet through a residential gateway or through another computer on my network'.
  • Now continue to press 'Next', filling in the correct details as you go along. Make sure the workgroup stays as the default.
Your LAN should now be configured properly; it is now time to setup ICS.
On the HOST PC, please do the following:
  • Open the Network Connections window. Here, you should have at least two connections listed: one for your Internet Connection, and one for the Ethernet adapter connected to your Local Area Network (LAN).
  • Right-click the connection icon corresponding to your Internet connection and select Properties.
  • Choose the Advanced tab, and turn on the "Allow other network users to connect through this computer's Internet connection" option. Click OK when you're done.
  • Verify that Internet Connection Sharing is enabled; it should say "Enabled, Shared" in the Network Connections Window.
Once done, on both computers right-click on My Network Places (on the desktop), select properties, double click on your Local Area Connection, and then select the Support tab. On the Host computer, the information should be:
IP Address: 192.168.0.1
Subnet Mask: 255.255.255.0
Default Gateway: 217.42.73.153

On the Client:
IP Address: 192.168.0.3
Subnet Mask: 255.255.255.0
Default Gateway: 192.168.0.1

dan - i'm gonna sit and observe for a second...if i get any idea's i'll chime in..as usual

As always, feel free to jump in at any time :whistling:
  • 0

#37
Chris - Thecleancar

Chris - Thecleancar

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 244 posts
Hello

On the Client computer, I see that you have the IPv6 protocol installed; is there any reason you need/want this protocol? If not, please remove it --

I'll uninstall this but I'm sorry I have no idea what IPv6 is or what I might be using it for - I notice its not enabled (no tick)
If I do in fact need it a presume it can be installed again

I'll now get on with the rest of the stuff

Thanks
Regards
Chris
  • 0

#38
Chris - Thecleancar

Chris - Thecleancar

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 244 posts
Hello

I re started both PCs in Safe mode with networking - they still cant see each other

Ran 'Brute force' connections - still cant see each other
Host message 'No network provider accepted the given path'
Client message 'Location cannot be reached'
Ran \\net view COMPUTER_NAME (using my PCs name) from the Host - Message 'Network path was not found'

On the Client computer, I see that you have the IPv6 protocol installed; is there any reason you need/want this protocol? If not, please remove it

I have uninstalled this from the Client

Could you then please repost the IPCONFIG /ALL's connected to your router, and also not connected.

ipconfig/all results for both PCs - I dont have a router its just a direct cable connection between two Ethernet cards
There is a 'Dial-up' connection on the Client PC which as I write this is 'disconnected' and is not listed in ipconfig/all for the Client
HOST COMPUTER
Microsoft Windows XP [Version 5.1.2600]
© Copyright 1985-2001 Microsoft Corp.

C:\>ipconfig/all

Windows IP Configuration

Host Name . . . . . . . . . . . . : dell
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : Yes
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Network Bridge:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : MAC Bridge Miniport
Physical Address. . . . . . . . . : 02-03-0D-00-00-01
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 192.168.0.1
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . :

PPP adapter BTopenworld Broadband:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : WAN (PPP/SLIP) Interface
Physical Address. . . . . . . . . : 00-53-45-00-00-00
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 86.139.224.51
Subnet Mask . . . . . . . . . . . : 255.255.255.255
Default Gateway . . . . . . . . . : 86.139.224.51
DNS Servers . . . . . . . . . . . : 62.6.40.162
194.72.0.98

CLIENT COMPUTER
Microsoft Windows XP [Version 5.1.2600]
© Copyright 1985-2001 Microsoft Corp.

C:\>ipconfig/all

Windows IP Configuration

Host Name . . . . . . . . . . . . : systemax
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : TE100-PCBUSR 32-Bit Cardbus PC Card
Physical Address. . . . . . . . . : 00-ED-7C-8C-09-29
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 192.168.0.3
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . :

I'm going to suggest a different method of setting up ICS; if it doesn't help, we can always go back to the other.

I'm trying to follow these instructions but they dont seem to quite tie in with what i'm seeing - am I right in thinking I should be opening Network Connections then New Connection Wizard ?

Thanks

Chris
  • 0

#39
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts

ipconfig/all results for both PCs - I dont have a router its just a direct cable connection between two Ethernet cards

Sorry, that was a canned speech that I simply copy/paste; ignore the router comment as I was supposed to remove it :whistling:

am I right in thinking I should be opening Network Connections then New Connection Wizard ?

Just goto Start --> Programs --> Accessories --> Communications --> Network Setup Wizard.. That's another method of getting to what I was talking about.
  • 0

#40
Chris - Thecleancar

Chris - Thecleancar

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 244 posts
Hello

I ran the Network connection wizard on both PCs everything seemed to be as you instructed except I did not see any screen saying "Set up a home or small office network"

On the Host I found in Network connections I had an Internet connection , a connection for the Ethernet card and also one called "Network Bridge"

I right clicked the Internet connection selected Properties selected Advanced and enabled the "Allow other network users to connect through this computer's Internet connection" option
The Internet connection now shows 'Connected, Shared'- the Ethernet card shows 'Connected, Bridged' and the Network Bridge shows 'Connected'

I turned off the Windows firewall on both PCs as this had changed to 'on' - 2 Firewalls is not a good thing acording to the Malware guys ?

I right clicked My network places selected Properties double clicked the Local arean connection (for the Ethernet card) selected the Support tab and got this information
Host
IP address:
Subnet mask:
Default gateway:
I confirm that these 3 settings are all blank

I looked at the Network Bridge and this shows
IP address: 192.168.0.1
Subnet mask: 255.255.255.0
Default gateway:

Client
IP address: 192.168.0.3
Subnet mask: 255.255.255.0
Default gateway:

The PCs still cant see each other - the Host can see itself in the workgroup

I can ping both PCs ok

Should I manually amend the settings in Local area connections>right click>General tab>Internet protocol(TCP/IP) for Host - Network Bridge and Client - Ethernet card ?

Hows your headache ?

Regards

Chris
  • 0

Advertisements


#41
Chris - Thecleancar

Chris - Thecleancar

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 244 posts
Hello Dan

Just a thought the problem is nothing to do with the fact that one PC is Win XP Pro and the other Win XP Home is it ?

Regards

Chris
  • 0

#42
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP

Just a thought the problem is nothing to do with the fact that one PC is Win XP Pro and the other Win XP Home is it ?

nope..that would have absolutely no bearing on this at all as the only pertinant restriction in home is that it can't join a domain...

in the beginning of the thread...an adsl modem/router was discussed...is that still on the table as an option? or no?
  • 0

#43
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
A router would most definitely make this process alot simpler (theoretically) :whistling: And you can get a decent router at a relatively low price nowadays. However, if you want to continue with this path, then we can keep on plugging along :blink:
  • 0

#44
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
dan...i'm not the best at home networking...but...in post #40...shouldn't the HOST section on the HOST compouter have an ip address and what not?
  • 0

#45
Chris - Thecleancar

Chris - Thecleancar

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 244 posts
Hello Dan G and dsennett

From what you have said in your last couple of posts am I right in thinking that the direct cable connection is a lost cause in my case? If you feel we are wasting our time continuing then I'll accept this.
Is this type of connection normally such a problem - from my non technical view point it would seem to be the easiest - what could my problem be?.

in the beginning of the thread...an adsl modem/router was discussed...is that still on the table as an option? or no?

I will be able to upgrade my Broadband connection to 8mg (max) in the not to distant future (weeks not months) and from reading what I have already received from my ISP I will require a modem/router to replace my Broadband modem
I think my upgrade will include a wireless modem/router is this the better way forward as opposed to an Ethernet wired modem/router.

A router would most definitely make this process alot simpler (theoretically)

That 'theoretically' is a bit worrying, can I assume that the setting up of a 2 PC network will be fairly straightforward
As I see it with a wireless set up I will have a modem/router (one box I guess) with a cable from it to my phone point, a USB 'Dongle' or even a PCI card in each PC which links to the router by (in effect) radio - Bluetooth .Any printers connect as they are now by cable to the PCs.
With this set up the PCs and any printers can all be networked also both PCs can connect to the web ?

Regards

Chris
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP