Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

USB Ports seem to be dead.


  • Please log in to reply

#1
djk1289

djk1289

    Member

  • Member
  • PipPip
  • 10 posts
I have a Toshiba SP10-804 running Windows XP with SP2. After a recent power failure my USB ports have stopped working, when ever I connect a device nothing happens. I have tried different devices and the only luck I have had is that the light on my MP3 player came on so there must be power coming from the ports. I have tried uninstalling my USB ports and letting windows detect and install them and I have tried reinstalling them using the system disk I got with the laptop and nothing has changed. I have searched for solutions but unfortunatley not found any. Can you please help I am very confused :whistling:
  • 0

Advertisements


#2
digikiwi

digikiwi

    Member

  • Member
  • PipPipPip
  • 259 posts
I am having a similar issue. You may have read this thread already:

http://www.geekstogo...9159&hl=working

If you haven't, try some of the fixes in there. That said I'm still searching for a solution, and will be sure to post it.

One immediate solution that gives you USB connectivity would be a PCMCIA USB 2.0 card if you have a free slot, but that does mean forking out some $.

The Geekstogo USB Guru, Jack123, is currently too busy with stuff to attend to this forum but search for some of his posts and you might find something that applies. Let's hope he finds some time for the forum again in the near future.

Good luck and post if you find a solution. :whistling:

Digikiwi
  • 0

#3
happyrock

happyrock

    Tech Moderator

  • Retired Staff
  • 9,285 posts
try this

Run regedit

Do you have this key and is the startup mode set to 3

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\USBSTOR

Do you have any devices listed under this key?

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USBSTOR

Run services.msc .....is the Plug and Play service present, started, and set to 'automatic' startup?

Open Folder Options ....View and ensure "show hidden files" is enabled. Navigate to C:\windows\INF

Do you have "usbstor.inf" there? Right click on it and select "install". There will be no prompts or confirmations.

Reboot and try attaching a USB storage device. Do you get any detection sound?
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP