Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

USB Devices not working.


  • Please log in to reply

#1
RjBass

RjBass

    Member

  • Member
  • PipPipPip
  • 225 posts
Ok so my printer which is hooked up to one of the back USB ports is just fine, however whenever I hook up a mass storage device to the front It cant be seen or used. When I check the device manager it shwos the device and says its working properly. I can even unplug the device and when I plug it in or take it out I hear the familiar tones.

I just cant see it in "my computer" and I cant move any data to the device or vice versa.

Im running Win XP pro SP2.

Any ideas?
  • 0

Advertisements


#2
RjBass

RjBass

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 225 posts
Ok nevermind, I figured it out, I had a network drive under E: so I re mapped it to Z: and now I can see the mass storage device.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP