Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Firefox doesn't like QuickTime...


  • Please log in to reply

#1
AniDanny

AniDanny

    Member

  • Member
  • PipPip
  • 92 posts
I've been using Firefox on this computer for nearly a year now, and never once has it let me use QuickTime. Whenever I try to open something that should use it (recently: VGMusic.com's midi files), it says:
"The QuickTime Plug-in requires the QuickTime System extension version 5 or later. QuickTime is available from [url="http://www.apple.com/quicktime/download/""]http://www.apple.com/quicktime/download/"[/url]
So I go to that site, make sure I have the latest QuickTime software, and then try again. It gives me the exact same message. My solution to the problem was to use IE, which has WMP as the default media player instead of QuickTime, and such things work perfectly. So my question is... is there a way to either make QuickTime work properly, or even better, make Firefox use WMP (or something else) as its default media player?
  • 0

Advertisements


#2
Major Payne

Major Payne

    Retired Staff

  • Retired Staff
  • 5,307 posts
Get all your Plugins for Firefox at Mozilla. Quicktime, WMP, RealPlayer, etc.

Ron

Edited by Major Payne, 04 July 2006 - 10:56 PM.

  • 0

#3
AniDanny

AniDanny

    Member

  • Topic Starter
  • Member
  • PipPip
  • 92 posts
I went to that site, downloaded WMP v10, tried a problem-site again, and it still gave me the quicktime error. So I went back, decided to try updating QuickTime since WMP obviously wouldn't fix it, and it redirected me to the same site that I get in the error message (which, as I've said, doesn't fix the problem). Is there any way to change the default media player from within firefox's options, or will I have to open up a media player and select "make this my default media player" from somewhere within that program?
  • 0

#4
Major Payne

Major Payne

    Retired Staff

  • Retired Staff
  • 5,307 posts
You have to install each PLUGIN for Firefox to work. If you have a Quicktime problem because of FF, then you need the Quicktime Plugin installed. WMP will not fix a problem with Quicktime as it is Apple's. If are having problems with these plugins installed in FF, then uninstall them, close FF, reopen FF and see if they will work. If you don't know what Plugins are installed, then type about:plugins into FF's Address Window and click either Go or hit Enter.

Ron
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP