Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Completely Network Computers


  • Please log in to reply

#1
MkLoe

MkLoe

    Visiting Staff

  • Member
  • PipPipPip
  • 650 posts
I would like to Completely network 2 computers in my house. They both have Windows XP Home Edition. We have a wired connection. I already ran through the XP connection setup using the floppy disk. It didn't seem to work that great. So if you don't mind I want to be able to access every file on both computers to the point where they are almost identical. Thanks in advance, Mike
  • 0

Advertisements


#2
SpaceCowboy706

SpaceCowboy706

    Trusted Tech

  • Member
  • PipPipPipPip
  • 1,175 posts
Hello MkLOe,

Please start with this tutorial and repost in this thread, any problems encountered during the setup.

Edited by SpaceCowboy706, 30 August 2006 - 03:37 PM.

  • 0

#3
MkLoe

MkLoe

    Visiting Staff

  • Topic Starter
  • Member
  • PipPipPip
  • 650 posts
I went through the wired OS connection part and then tried to do the file and print share setup but was unable to complete it. After step 7 I could not continue. When I click add it says "There are no drivers for this device" then a window pops up saying where I would like to install a driver for that.
  • 0

#4
SpaceCowboy706

SpaceCowboy706

    Trusted Tech

  • Member
  • PipPipPipPip
  • 1,175 posts

After step 7 I could not continue.


To make sure we are on the same step you attempted the following:


1. Close out all applications and running programs (including Third party Firewalls, Security Suites, and Virus Detectors)
2. Hold down the “Windows” key on the keyboard, and then press the “R” key on the keyboard. This opens the RUN Command.
3. Type in: ncpa.cpl :and press the OK button. This opens the Network Connections Window.
4. Locate your Connection Type (Ethernet) and right click on to select PROPERTIES.
5. Click on the GENERAL tab.
6. Click the INSTALL button. To launch the “Select Network Component Type” window.
7. Click the ADD button. To launch the “Select Network Service” window.


At step 7 you said you could not continue... This is were we are installing the "File and Print Share" protocols. You may not be able to install it because it is already in your TCP/IP stack.

Lets check and see
:

1. Hold down the “Windows” key on the keyboard, and then press the “R” key on the keyboard. This opens the RUN Command.
3. Type in: ncpa.cpl :and press the OK button. This opens the Network Connections Window.
4. Locate your Connection Type (Ethernet) and right click on to select PROPERTIES.
5. Click on the GENERAL tab.
6. Under "This connection uses the following Items:" verify if there is a service listed as "File and Printer Sharing" and that it also has a check in it
7. If the Sharing Protocol is not there then post back and let me know <Reply 1>
8. If the Sharing Protocol is there, then resume following the same tuturial at step 9.

  • 0

#5
MkLoe

MkLoe

    Visiting Staff

  • Topic Starter
  • Member
  • PipPipPip
  • 650 posts
I completed all the steps and "shared" the folders I wanted to, but when I got to the seccond computer and try to access the files it says "You do not have permission to access these files. Please contact your network adminstator..." what should I do?
  • 0

#6
SpaceCowboy706

SpaceCowboy706

    Trusted Tech

  • Member
  • PipPipPipPip
  • 1,175 posts
Did you also follow all the steps on the second computer ?

Please also check and perform the following ON BOTH PC's.


1. Click Start, click Control Panel, and then click Network and Internet Connections.
2. Click Network Connections.
3. Right-click Local Area Connection, and then click Properties.
4. Click Internet Protocol (TCP/IP), and then click Properties.
5. Click the General tab, and then click Advanced.
6. Click the WINS tab.
7. Under NetBIOS setting, click Enable NetBIOS over TCP/IP, and then click OK two times.
8. Click Close to close the Local Area Connection Properties dialog box.
9. Close the Network Connections window.
10. Click Start, right-click My Computer, and then click Manage.
11. Double-click Services and Applications.
12. Double-click Services.
13. In the right pane, right-click Computer Browser, and select properties
14. Make sure the Startup type is set to Automatic and then click Start.
15. Press the Apply and Ok Button.
16. In the right pane, right-click Windows Firewall/Internet connection Sharing (ICS) and select Properties
17. Make sure the Startup type is set to disabled and then press the Stop button
18. Press the Apply and Ok Button.
19. Close the Computer Management window.
20. Remove any other third party firewalls, virus protectors, or any other type of security service from
your startup list (Just temporarily to make sure they are not blocking (as is usually the case).
21. Restart Both Computers
22. Click Start, and then click Run.
23. In the Open box, type the UNC name of the file that you want to open, and then click OK (or Open).
..........UNC Name parameters:
................\\Computer name\Share name\Path\File name
................example as follows: \\Spacecowboy\Smith\Shared\Bills\AugustReport.xls
24. If you encounter an error message post back what it says word for word. <Reply 1>
25. If you can access the file then congratulations, from here it is just a matter of creating a shortcut for
the path
.


PS.... IS the second computer also windows XP?

Edited by SpaceCowboy706, 02 September 2006 - 10:04 PM.

  • 0

#7
MkLoe

MkLoe

    Visiting Staff

  • Topic Starter
  • Member
  • PipPipPip
  • 650 posts
On the main computer I could not find the Windows firewall/internet setting (pic below)
and now i can't even find my other computer. Both computer are XP

Attached Files


  • 0

#8
SpaceCowboy706

SpaceCowboy706

    Trusted Tech

  • Member
  • PipPipPipPip
  • 1,175 posts
Please visit this link (using internet explorer) and update both pc's to the latest version of Xp SP 2.

If you are 100 % sure that you already have XP SP 2 on both computers then we have some other serious problems:


You most likely have a missing or corrupted SharedAccess.reg file. To replace it:

Create a new registry entry for it using text document:


Windows Registry Editor Version 5.00
[-HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess]

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess]
"DependOnGroup"=hex(7):00,00
"DependOnService"=hex(7):4e,00,65,00,74,00,6d,00,61,00,6e,00,00,00,57,00,69,00,\
6e,00,4d,00,67,00,6d,00,74,00,00,00,00,00
"Description"="Provides network address translation, addressing, name resolution and/or intrusion prevention services for a home or small office network."
"DisplayName"="Windows Firewall/Internet Connection Sharing (ICS)"
"ErrorControl"=dword:00000001
"ImagePath"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,\
74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,73,\
00,76,00,63,00,68,00,6f,00,73,00,74,00,2e,00,65,00,78,00,65,00,20,00,2d,00,\
6b,00,20,00,6e,00,65,00,74,00,73,00,76,00,63,00,73,00,00,00
"ObjectName"="LocalSystem"
"Start"=dword:00000002
"Type"=dword:00000020

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Epoch]
"Epoch"=dword:00002cd0

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters]
"ServiceDll"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,\
00,74,00,25,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,\
69,00,70,00,6e,00,61,00,74,00,68,00,6c,00,70,00,2e,00,64,00,6c,00,6c,00,00,\
00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy]

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\DomainProfile]

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\DomainProfile\AuthorizedApplications]

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\DomainProfile\AuthorizedApplications\List]
"%windir%\\system32\\sessmgr.exe"="%windir%\\system32\\sessmgr.exe:*:enabled:@xpsp2res.dll,-22019"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\StandardProfile]

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\StandardProfile\AuthorizedApplications]

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\StandardProfile\AuthorizedApplications\List]
"%windir%\\system32\\sessmgr.exe"="%windir%\\system32\\sessmgr.exe:*:enabled:@xpsp2res.dll,-22019"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Setup]
"ServiceUpgrade"=dword:00000001

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Setup\InterfacesUnfirewalledAtUpdate]
"All"=dword:00000001

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Enum]
"0"="Root\\LEGACY_SHAREDACCESS\\0000"
"Count"=dword:00000001
"NextInstance"=dword:00000001


If you cant figure out how to complete the above registry merge then please see the disclaimer below and the following attachment:

WARNING*****
Altering your registry can cause serious problems to your computer if not done correctly, so please consult Microsoft support on how to alter it correctly as I do not want to be responsible for any malfunctions to you Operating system. If you wish to use the following attachment, please do so at your own risk as I am not liable for any problems that may occur from it's improper use.


After you have figured out how to merge the new entries please repeat steps 10 through 12 and then 16 through 25 from Post #6.

Edited by SpaceCowboy706, 03 September 2006 - 11:43 AM.

  • 0

#9
MkLoe

MkLoe

    Visiting Staff

  • Topic Starter
  • Member
  • PipPipPip
  • 650 posts
no updates were available for both of the computers
  • 0

#10
SpaceCowboy706

SpaceCowboy706

    Trusted Tech

  • Member
  • PipPipPipPip
  • 1,175 posts
Last post was edited please scroll up... G2G wont let me upload the file Mergreg, so you will have to figure that part out on your own... Please post back after completing it.
  • 0

Advertisements


#11
MkLoe

MkLoe

    Visiting Staff

  • Topic Starter
  • Member
  • PipPipPip
  • 650 posts
ok i got the service back on the main computer but i still can't access the files. Also, i am confused on how you say to get to it

22. Click Start, and then click Run.
23. In the Open box, type the UNC name of the file that you want to open, and then click OK (or Open).
..........UNC Name parameters:
................\\Computer name\Share name\Path\File name
................example as follows: \\Spacecowboy\Smith\Shared\Bills\AugustReport.xls


I still get this:Attached File  error.bmp   260.17KB   81 downloads

also iam trying to network my whole "Documnets and settings" so these computers are almost identical
  • 0

#12
SpaceCowboy706

SpaceCowboy706

    Trusted Tech

  • Member
  • PipPipPipPip
  • 1,175 posts
I am not sure if the Document and settings folder can be shared across a netrwork as I have never tried that... But I dont see why it wouldn't work since the Drive its located on... can be shared, which i have done (Example: Shared my c:\ drive from an older PC to my newer Pc).

Lets just get simple file sharing working for one shared folder and after that is working, then we can move on to the entire drive. I suspect that you may have OS problems but I am a man of fact, that likes to exhaust all possible solutions before saying, that is for sure the problem.

So lets continue with your confusion on how to access the shared folder from the run command:

..........UNC Name parameters:
..........\\Computer name\Share name\Path\File name
..........example as follows: \\Spacecowboy\Smith\Shared\Bills\AugustReport.xls

What we are trying to do is use one of the PC's (Main PC) to directly connect to the shared resource on a second pc (Secondary PC), by bypassing network neighborhood and the entire network search.

to access the shared folder from the Main pc, we must get the information needed From the Secondary PC:

Go to the Secondary PC and get the name of the computer which can be found by right-clicking on the MY Computer icon and selecting Properties --> then clicking on the Computer name tab --> the computers name is located to the right of Full computer name.

Hence: \\Spacecowboy

Next we need the workgroup name which can be found by right-clicking on the MY Computer icon and selecting Properties --> then clicking on the Computer name tab --> the workgroup name is located to the right of Workgroup.

Hence: \\Spacecowboy\Smith

Next we need the file path so right-click on the Start button and select Explore --> In the left side of the window pane navigate your way to the folder you are wanting share and then use the file path that is located in the address bar above.

Hence: \\Spacecowboy\Smith\C:\Documents and Settings\All Users\Documents\My Music

Now we go back the Main PC and simply click on the Start Button and select Run, when the Open box appears we just copy in the path and press OK.

This will either open a folder located on the Secondary PC, to be displayed on the Main PC, or it will give you an error message saying something to the effect of "Access Denied" or "You do not have suffeciuent proveleges..." or a slew of other error messages. These exact error messages are what we need as they can help in finding where the problem is.

I hope that better explains it... Please post the path you are using (so I can make sure your doing it right) and then any error message you get afterwards.
  • 0

#13
MkLoe

MkLoe

    Visiting Staff

  • Topic Starter
  • Member
  • PipPipPip
  • 650 posts
not to be mean but your not very clear. The spacecowboy doesn't really help. I try to do what you say but i don't think im doing it right. Instead of smithcowboy, could you just do \\computer name\work group

It is kinda a frustrating and this isn't really working

Also, I am trying to access my Main PC on my seccondary just to let you know

Edited by MkLoe, 05 September 2006 - 06:45 PM.

  • 0

#14
SpaceCowboy706

SpaceCowboy706

    Trusted Tech

  • Member
  • PipPipPipPip
  • 1,175 posts
Ok lets try it an easier way then.

Please perform these steps from the Main PC to view the secondary PC... and then from the Secondary PC to view the Main Pc. In your replies, also indicate what Pc you were sitting at.

I have not numbered these steps because I have already placed the <replies> where you should encounter the error messages. but still follow the steps in order from top to bottom.

If you get an Error Message during any part of these steps Please indicate after what step you obtained the error message (Example. "I got the error message at reply #2")

If you get an error message during any part of these steps Please copy the entire and exact error message (example: "Access denied, You do no have sufficient priveleges to access this shared resource. Please contact your system administrator")

Follow these steps:

Double click your My Computer Icon
In the left gray column, under Other Places, Click on My Network Places,
In the left gray column, under Network Tasks, Click on View Workgroup Computers
Post back if you get a Error Message now, OR <REPLY 1>
A second window is displayed containing the set of computers in your workgroup
Double-click the computer containing the shared folder,
Post back if you get a Error Message now, OR <REPLY 2>
Double-click the shared folder
Post back if you get a Error Message now. <REPLY 3>

Edited by SpaceCowboy706, 06 September 2006 - 09:06 AM.

  • 0

#15
MkLoe

MkLoe

    Visiting Staff

  • Topic Starter
  • Member
  • PipPipPip
  • 650 posts
ok now i can't even access the main computer from the second computer.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP