Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

emac troubles


  • Please log in to reply

#1
justthe2ofus50

justthe2ofus50

    New Member

  • Member
  • Pip
  • 1 posts
I have a 800mhrtz emac running 10.4.7 with 1gb ram.
It is running extremely slow!!!!! I get the "spinning colored ball of death" all the time!! Although I have cable internet access, I can only download at speeds of 50k-400k per second, when they should be 4meg-6meg per second. Pages sometimes take several minutes to load.
I have had trouble after trouble with the system doing crazy things that I've in twenty yrs. experience have never seen happen. The desktop flashing on and off, with all the desktop icons flashing on and off. I've used the disk utilities, and on numerous occasions the startup disk needed severe repairs. Booting from the software disks, they have been repaired only to happen again and again. I've ran the program Internet Connect to find any spyware, and it always comes up clean. Any suggestions? Thanks in advance!
  • 0

Advertisements







Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP