Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

BF2 - Some Big Problems


  • Please log in to reply

#1
BudweiserZero

BudweiserZero

    New Member

  • Member
  • Pip
  • 1 posts
Alright, ive looked all over the net, and im not sure what to do.

First of all, me and my friend both patched to patch 1.4. he gets like 4000 servers, while i barly get 70 of the same ones. So, i know something is wrong right there.

Also, whenever i connect to a server, it works fine for just a second and then says "There is a problem with your connection".

This seems to be only happening with patch 1.4, as i uninstalled, and reinstalled, and i could connect when it the the bare version of the game. But as soon as its 1.4, it wont work for me, and im not sure whats wrong.

I have disabled all firewalls, i dont have a router to open ports from, and it must be something with 1.4 as it worked without installing the latest patch. And i am using the Full 1.4 not incremental.

If anyone has had this problem, or knows any thing that can help me, i would be very thankfull.
  • 0

Advertisements


#2
Facedown98

Facedown98

    Trusted Tech

  • Technician
  • 2,989 posts
Hi. That's strange... You can't connect to ANY servers? Also, what filters do you have being used? You should at least be able to see them...
  • 0

#3
starjax

starjax

    Global Moderator

  • Global Moderator
  • 6,591 posts
there is a problem with the 1.4 patch. You will need to perform a manual uninstall (recommended) or just a normal uninstall.

click here for instructions on the manual uninstall

reboot the pc. then reinstall the game and then install the full 1.4 patch.
  • 0

#4
Facedown98

Facedown98

    Trusted Tech

  • Technician
  • 2,989 posts

... i uninstalled, and reinstalled, and i could connect when it the the bare version of the game. But as soon as its 1.4, it wont work for me...


It might have already been tried :whistling:
  • 0

#5
starjax

starjax

    Global Moderator

  • Global Moderator
  • 6,591 posts
install 1.3, don't go to 1.4

not much we can really do here except to redirect them to EA for additional support
  • 0

#6
Facedown98

Facedown98

    Trusted Tech

  • Technician
  • 2,989 posts
Agreed. We could easily put you on the 1.3 patch, but that won't do you much good online today... seeing as how they all have 1.4... When EA helps you, and you hopefully solve the issue, please let us know so we can look back on it.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP