Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Internet connection


  • Please log in to reply

#1
fothers

fothers

    Member

  • Member
  • PipPip
  • 24 posts
:whistling:
Hi

I installed Ubuntu today and everything seems to work except the internet. I can ping my Dlink Modem/Router and it seems to work. I can open the setup page thru firefox (10.1.1.1) and everything seems ok. It has all settings as per XP (Why wouldn't it).
But if I try to view a web page or download mail it just times out. ?
Anyone got any idea's ?
I'm connected to a wireless modem/router (Dlink DSL-G604T/AU) via an eithernet cable. When I look in the Network Configeration Panel both show up and say thay are active.
Do I have to turn something else on.

Hope someone can point me in the right direction.

Thanks
  • 0

Advertisements


#2
silverbeard

silverbeard

    Trusted Tech

  • Member
  • PipPipPip
  • 791 posts
Hi there,

Try surfing by direct IP. 216.239.51.99 is one I use to test for DNS problems. If Google pops up you know that the connection is working but the DNS look up is not going through. It could be that Port 53 is blocked or your router is not sending the right DNS. The problem could also be in the connection settings for the system connection.
  • 0

#3
Kemasa

Kemasa

    Nobody

  • Technician
  • 1,633 posts
As silverbeard said, try the direct IP and see if that works or not. You can also use the ping command to see if you can access the address (not all sites will return a ping though).

Then you can try using the command "nslookup", example "nslookup www.google.com" and it should return the IP address:

% nslookup www.google.com
Server: 192.168.9.2
Address: 192.168.9.2#53

Non-authoritative answer:
www.google.com canonical name = www.l.google.com.
Name: www.l.google.com
Address: 66.102.7.99
Name: www.l.google.com
Address: 66.102.7.104
Name: www.l.google.com
Address: 66.102.7.147

The 192.168.9.2 is my local router which is acting as a DNS server and forwarding the requests.

You can also check the file /etc/resolv.conf, which is the configuration file for DNS. It should have a line like:

nameserver 192.168.9.2

You also need to look at /etc/nsswitch.conf, specifically the line which starts with "hosts:" to see where the system is supposed to get the host information from. A common setting would be:

hosts: files dns

which says to look at /etc/hosts first, then use DNS.
  • 0

#4
fothers

fothers

    Member

  • Topic Starter
  • Member
  • PipPip
  • 24 posts
:) This worked, I can get into google and do a search (with results) but links time out....

As silverbeard said, try the direct IP and see if that works or not. You can also use the ping command to see if you can access the address (not all sites will return a ping though).

:help: Sorry dumb question but what App do I use to enter nslookup www.google.com ?

Then you can try using the command "nslookup", example "nslookup www.google.com" and it should return the IP address:

:whistling:
it says
nameserver 10.1.1.1 (Which is my Dlink router)

You can also check the file /etc/resolv.conf, which is the configuration file for DNS. It should have a line like:

nameserver 192.168.9.2

You also need to look at /etc/nsswitch.conf, specifically the line which starts with "hosts:" to see where the system is supposed to get the host information from. A common setting would be:

hosts: files dns
:blink:
Mine says
passwd: compat
group: compat
shadow: compat

hosts: files dns mdns
networks: files

protocols: db files
services: db files
ethers: db files
rpc: db files

netgroup: nis

which says to look at /etc/hosts first, then use DNS.

:rofl: :rofl: :help:
  • 0

#5
fothers

fothers

    Member

  • Topic Starter
  • Member
  • PipPip
  • 24 posts
Thanks for your help, I edited

sudo gedit /etc/resolv.conf and changed nameserver to match my IP not my modem and it now seems to work.

I appreciate your help
Fothers
  • 0

#6
fothers

fothers

    Member

  • Topic Starter
  • Member
  • PipPip
  • 24 posts

Thanks for your help, I edited

sudo gedit /etc/resolv.conf and changed nameserver to match my IP not my modem and it now seems to work.

I appreciate your help
Fothers



this worked but on reboot resets to original setting! anyone suggest how to set it perminantly

thanks
  • 0

#7
Kemasa

Kemasa

    Nobody

  • Technician
  • 1,633 posts
On my system, I can set it using the control center to set the DNS servers under Internet access. On Linux, it is often reset every time when you use DHCP since the machine does not have a fixed IP address.

I am not sure of where it is set with Ubuntu.

This is one problem when the people writing the OS utilities try to make everything automatic.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP