Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Annoying IE7 problem


  • Please log in to reply

#1
TrueAnubis

TrueAnubis

    Member

  • Member
  • PipPip
  • 26 posts
Every time I start my IE7 browser, I get the following message:

"Your security setting level puts your computer at risk

We recommend that you do not browse the web with your current security settings.
To fix this, click on the Information Bar above, and choose Fix Settings for Me.

To continue browsing in the current state, click the Home button (not recommended)."

In addition, at the top of every single page I attempt to browse, I get the yellow alert bar, giving me the following message:

"Your current security settings put your computer at risk. Click here to change your security settings..."

Now while I understand this is safer, those higher security settings also make browsing certain web sites that I know are safe unbearable because those higher security settings don't discriminate between good content and bad content. I need to know how to get rid of both the opening page warning (about:SecurityRisk) and the yollow alert bar. This makes using IE7 a completely unbearable experience. Can someone help?

Please don't be like the annoying pieces of garbage on the Microsoft Newsgroup and ask what settings I want to keep lowered or why. I only want to know how to get rid of these messages without altering my current security settings.

So far, I must say that IE7 gets a big fat "F". Worst browser I've seen since Netscape 3. Help!
  • 0

Advertisements


#2
jaxisland

jaxisland

    Member 1K

  • Member
  • PipPipPipPip
  • 1,703 posts
Dont know how to get rid of it, but how bout adding the sites to your trusted sites list?
  • 0

#3
TrueAnubis

TrueAnubis

    Member

  • Topic Starter
  • Member
  • PipPip
  • 26 posts
It's every single site. All of them. So that's not an option.

What the... was Microsoft thinking when they made this nonsense?

So can anyone else help out? You guys can fix all sorts of spyware and hacking problems, so this should be a piece of cake for you all.
  • 0

#4
Neil Jones

Neil Jones

    Member 5k

  • Member
  • PipPipPipPipPipPipPipPip
  • 8,476 posts
In Internet Explorer 7, go to Tools -> Internet Options -> Security.

Click on "reset all zones to default level" and click OK.

Internet Explorer 7 will now no longer let you run in what was previously regarded as "Low" security settings in the Internet Zone without making a song and dance about it, therefore leave the setting as Medium or Medium-High.
  • 0

#5
TrueAnubis

TrueAnubis

    Member

  • Topic Starter
  • Member
  • PipPip
  • 26 posts
Like I said, I need to know how to do this without changing my security settings. I said it in my first post, the security settings they want screw up some web sites (that I know can be trusted even), so I want to keep my security settings.

Certainly there must be a way to turn off the message? If not, is there a way to hack it to get it to shut up? This is obnoxious. I can not figure out why they would do something so freaking stupid to customers. So can anyone help me?

EDIT: By the way, my security is set to Medium-High. This thing apparently wants it set to High, and sorry, but I am not doing that crap, it disables half the internet. Internet is Medium-High, Intranet is Custom, Trusted Sites is Medium, and Restricted Sites is Custom (very high security, though).

Edited by TrueAnubis, 15 November 2006 - 04:49 PM.

  • 0

#6
zenrei

zenrei

    New Member

  • Member
  • Pip
  • 1 posts
If you haven't found a solution yet, I think I found one...

add this registry key:

HKCU\Software\Microsoft\Internet Explorer\Security\DisableSecuritySettingsCheck DWORD 0x1

I just did this and it seems to have fixed the issue
  • 0

#7
Dianna1949

Dianna1949

    New Member

  • Member
  • Pip
  • 1 posts

Hi True,
Boy do i know what you mean. With every new operating system that comes out we give up more and more control of OUR computers.

I have figured out how to get rid of the about:securityrisk redirect page. I bought a new computer and Vista was forced on me...i much prefer XP prof. I am assuming that you also have Vista.

click:
start....all programs....accessories.....run and type in regedit then click okay

at the top of your registry window click:
edit....find...and type in about:securityrisk then click find next

that will take you to the about:securityrisk entry.....delete it

I only found one incidence of that entry but just to make sure you have them all....repeat the edit...find next sequence until you get the message "finished searching through the registry"

close your registry.

I still haven't figured out how to get rid of the yellow security settings bar but will let you know when i figure it out.
  • 0

#8
winnP

winnP

    New Member

  • Member
  • Pip
  • 2 posts

If you haven't found a solution yet, I think I found one...

add this registry key:

HKCU\Software\Microsoft\Internet Explorer\Security\DisableSecuritySettingsCheck DWORD 0x1

I just did this and it seems to have fixed the issue


I was also having this problem, and I just wanted to confirm that zenrei's solution works, in case people are uncomfortable editing their registry on one person's word -- now you have two.
  • 0

#9
Onaipian

Onaipian

    Notepad warrior

  • Retired Staff
  • 2,130 posts
If you are uncomfortable editing the registry, I would recommend using an alternative browser such as Firefox. Firefox is faster, more secure, and has an awesome pop-up blocker.

Of course, you would still need to occasionally use Internet Explorer for things such as Windows Update, and Kaspersky Online Scans...
  • 0

#10
winnP

winnP

    New Member

  • Member
  • Pip
  • 2 posts
(1) I am completely comfortable editing my registry -- like I said, I tried that and it worked. I just wanted to make sure other people (those who might be wary of editing their registry based on one anonymous person's advice) knew that at least one other person had used that fix successfully.

(2) I do use Firefox for most things, but some people have to use IE (for example, web developers -- and yeah, Windows update).

(3) The purpose of this thread was to fix an annoying "feature" of IE -- it's not very constructive to offer "try other software" as a solution. Only advanced users would want to reduce their security settings in IE anyhow, and I'm quite sure advanced users all realize there are other browser options.
  • 0

#11
sari

sari

    GeekU Admin

  • Administrator
  • 21,000 posts
  • MVP
First, this was an old thread you dug up. Second, we never ever advise editing the registry without first creating a backup - there's too much risk to make that worth it. While you may be comfortable doing it, an inexperienced user could come along, attempt to follow the instructions, and delete the wrong thing. We suggest using a utility such as ERUNT: http://www.larsheder...nline.de/erunt/
  • 0

#12
Purecrysm

Purecrysm

    New Member

  • Member
  • Pip
  • 1 posts
Thanks a lot guys. This had me so pissed :) . They really need to make windows easier for advanced users again. It's good to focus on newb users but don't make it difficult for advanced users in the same right!!
  • 0

#13
Blueblazes

Blueblazes

    New Member

  • Member
  • Pip
  • 1 posts
I know this post is old, but I just had the same problem with IE 8.
It only affected my User Account and desktop, not that of my kids.
Couldn't get email. (couldn't even find the link)

I ran System Restore in Safe Mode (wouldn't work in regular mode), and it worked.
Messed up my Norton Internet Security, though. Had to remove and reinstall it.
Still don't know what caused the problem, but this managed to fix it.

Instructions for going into Safe Mode can be found in Windows Help.
  • 0

#14
Adillo303

Adillo303

    New Member

  • Member
  • Pip
  • 1 posts

If you haven't found a solution yet, I think I found one...

add this registry key:

HKCU\Software\Microsoft\Internet Explorer\Security\DisableSecuritySettingsCheck DWORD 0x1

I just did this and it seems to have fixed the issue


Thank you so much - I had tried other solutions with no avail. This one did it.

Andy
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP