Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

C++: Can build the dll file, but cannot register


  • Please log in to reply

#1
girish_hk

girish_hk

    New Member

  • Member
  • Pip
  • 2 posts
I'm converting a VC++6.0 project from MBCS to Unicode. I was able to succeed in building it in Win32 Debug mode and also run it. The dll files were able to register using Regsvr32.
_________________________________________________________________________________________

Now when I build them in Win32 Release mode I'm getting problem with the dll files registration. It compiles, links and builds the dll files. But when i try to register them using Regsvr32 it'll fail giving error like The instruction at "0x72842565" referenced memory at "0x00000000". The memory could not be "read"._________________________________________________________________________________________


So I tried to use Dependency walker and its results are below (I've pasted only the errors given by it):

LoadLibraryA("C:\WINDOWS\system32\MFC42LOC.DLL") returned NULL. Error: The specified module could not be found (126).

LoadLibraryExW("X:\Generation\Release\swfcinit.dll", 0x00000000, LOAD_WITH_ALTERED_SEARCH_PATH) returned NULL. Error: Invalid access to memory location (998).

GetProcAddress(0x755C0000 [c:\windows\system32\MSCTFIME.IME], "ImeGetImeMenuItems") called from "c:\windows\system32\IMM32.DLL" at address 0x76397374 and returned NULL. Error: The specified procedure could not be found (127).
_________________________________________________________________________________________


Also I tried to open the dll file built in Debug mode in Dependency Walker. That file will be successfully loaded in. And one more thing i noticed is that it never depends on "MSCTFIME.IME" in the Debug mode.
_________________________________________________________________________________________

So anyone can plz help me... I would be grateful to the members with solution...
  • 0

Advertisements







Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP