Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Laptop won't start up


  • Please log in to reply

#1
Calvin and Hobbes

Calvin and Hobbes

    Member

  • Member
  • PipPip
  • 91 posts
I accidentally dropped my laptop while taking it out of it's bag. And now, I have been having problems with it. At first, it started up just fine, but after and hour or so, it froze on me. So when I restarted it by holding the power button until it turned off and turning it back on, it starts up to the first screen, which is a screen that just says toshiba in red on it and has press F2 to SETUP or F12 for boot device selection menu. When, I go to SETUP, it opens to the PheoenixBIOS Setup Utility and on the Main tab there is a part that says "Hard Disk: None", so that's why I think it's a problem with the hard disk. When I press F10 to "Save and Exit" the PheonixBIOS, it goes back to the black Toshiba screen.
The computer has started up several times though. The first time, not including the first startup after I dropped it, happened around 8 hours later. I took it home after work, didn't work at all there, and tried it again. To my surprise, it started. Quickly, I tried to transfer my files to USB memory stick. As I was compacting my e-mail's, the computer froze on me. So I tried to restart it again, but it went back to the Black Toshiba screen and reverted back to the loop of me going to the PhenoixBIOS, restarting, and then coming back to the black Toshiba screen. The second time happended when I pressed F12 instead of F2 and went to the boot device selection menu. It comes to a Boot Menu and gives me a selction between 1. HDD, 2.CD/DVD, 3. FDD, and 4. LAN. I chose HDD (hard disk drive) and it went to black screen that something had errors with something, I think it was important, but I wasn't paying attention. Then, I pressed the power button and it turned off. I restarted it and my computer started.
So I was wondering if anyone had any similar problems, or knows what my problem is and how to fix it. Any advice would be much appreciated.


My laptop specs:
Toshiba Satellite M55-S3262
Intel Pentium M Processor 750, 1.86Ghz, 512MB DDR SDRAM
100GB HDD, Microsoft Windows XP Professional SP2
  • 0

Advertisements


#2
b1caez01

b1caez01

    Banned

  • Banned
  • PipPipPip
  • 445 posts
Before suggesting anything, get some hardware checking ideas from the hardware forum ...

Edited by b1caez01, 22 November 2006 - 12:43 AM.

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP