Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

DVD verry slow to burn...

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 3 posts
My system:

Dell Dimension 9200 w/ Core 2 Duo 1.8's
Windows XP SP2 Pro
Built in SATA controllers no IDE whatsoever.

I installed a Promise 133TX2 IDE controller.

My main HD is under the 1st SATA built in port.

My 2nd HD is Primary/Master on the installed IDE controller card. My Nec 3520 dvd burner is on the Primary/Slave.

The problem:

Cannot burn (using any burner program) at speeds higher than 1.8x (using 16x media and 16x dvdr drive)

Normally I figure this is a windows xp issue where the DMA is defaulting to PIO mode... however... when I go to change to DMA... there is no option to do that when all of my controllers (both the SATA and the IDE) are under SCSI Devices in Windows<Control Panel<Systems<Device Manager

Things I've tried:

1. Removed/Deleted the drivers and reinstalled the drivers to the controller card
2. Changed the drive configurations around
3. Tried different burnign software... deleted and reinstalled burning softwares
4. updated the firmware to the drive (Nec 3520)

I still think its a DMA issue... but I don't know of any other ways to force windows to do DMA/UDMA on all drives.

Please help me because it is quite frusterating to burn full dvd's in 28-35 minutes. Thanks in advance!

  • 0




    motto - Just get-er-done

  • Technician
  • 4,345 posts
Getting back to DMA mode in Windows XP

CD-ROM and DVD-ROM drives can revert to using PIO mode, despite being set to

use “DMA if Available.” Here’s how to make Windows XP redetect the DMA

capabilities of the drives.

This behaviour occurs with the following conditions:

* Windows XP is the operating system
* A CD-ROM or DVD-ROM drive, which is known to support DMA mode now works only in PIO mode.
* The drive controller is set to use “DMA if available” but reports to be only in PIO mode.

Following is the mechanism that has worked for me, please try it at your own

risk, it involves hacking the registry:

1. Open RegEdit
2. Find the following KEY:

3. The last four digits will be 0000, 0001, 0002, 0003, and so on.
4. Under each key, delete all occurences of the following values:


5. Reboot the computer. Windows will now redetect DMA settings.

To enable DMA mode using the Device Manager

1. Open Device Manager.

2. Double-click IDE ATA/ATAPI Controllers to display the list of controllers

and channels.

3. Right-click the icon for the channel to which the device is connected,

select Properties, and then click the Advanced Settings tab.

4. In the Current Transfer Mode drop-down box, select DMA if Available if the

current setting is “PIO Only.”
If the drop-down box already shows “DMA if Available” but the current transfer

mode is PIO, then the user must toggle the settings. That is:

• Change the selection from “DMA if available” to PIO only, and click OK.

• Then repeat the steps above to change the selection to DMA if Available.

I got this from the Microsoft website. I also couldn’t enable DMA on my hard disk

controller after upgrading from WinME to WinXP SP2, but that DID work.

  • 0



    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts
Thanks for the response I've tried both of those already... maybe I wasn't clear on my first post but here's the big issue:

When there are IDE controllers built in, the add-on IDE controller (pci card) and the built in SATA controller, fall under SCSI in device manager... when it does this there is no option to go change DMA/PIO modes... non whatsoever... there is not even in the settings tab for the properties.

As far as going for the Regkey... these values

"3. The last four digits will be 0000, 0001, 0002, 0003, and so on.
4. Under each key, delete all occurences of the following values:


do not exist because there are no onboard IDE controllers....

I went as far as to find both the SATA and the IDE regkeys to see if there were values for :

but none of the Sata/ide regkeys had them.

I even swapped the controller to a diff PCI slot... really i dunno if this is a dell issue or if this is a chipset issue.

  • 0



    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts

anyone? :whistling:
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP