Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Error Message in phpMyAdmin


  • Please log in to reply

#1
wendy k. walker

wendy k. walker

    Member

  • Banned
  • PipPipPip
  • 354 posts
Hi Everyone,

I just got through installing [I think] phpMyAdmin and now when I try to access phpMyAdmin through my browser I'm getting the following message:


Welcome to phpMyAdmin 2.9.2
Error
#1045 - Access denied for user 'pmausr'@'localhost' (using password: YES)
Language English (utf-8)
Log in
Username:
Password:

That has me kind of puzzled as I don't remember having had to enter a user name or password for phpMyAdmin at any point during its installation.

I did, however, add a password to 'blowfish_secret' in the config.inc.php file. But thinking that that might have been the source of my problem I removed it and tried to access phpMyAdmin with my browser again but all I got was another error message saying that blowfish_secret had to have a password so I stuck one back in it.

Who do I get around this problem? Do I need to change the $cfg['Servers'][$i]['controluser'] = 'pmausr'; line by replacing 'pmausr' with an actual user name on my PC?

Thanks for any help.

Wendy
  • 0

Advertisements


#2
Michael

Michael

    Retired Staff

  • Retired Staff
  • 1,869 posts
You need to put in the user name and password you use to connect to the MySql databases that your site uses. Do you know what they are?
  • 0

#3
wendy k. walker

wendy k. walker

    Member

  • Topic Starter
  • Banned
  • PipPipPip
  • 354 posts
Hi Michael,

um... not really. I just installed PHP, MySQL, and phpMyAdmin yesterday but I don't remember setting any user names anywhere. Where would I look to find my user name in MySQL? I remember setting a password in that but I really don't remember a user name.

Thanks for your help.

Wendy
  • 0

#4
Michael

Michael

    Retired Staff

  • Retired Staff
  • 1,869 posts
I would guess the user name will need to be left blank or it will be admin. Try both.

It is a while since I did this so my memory is a bit blurry.
  • 0

#5
wendy k. walker

wendy k. walker

    Member

  • Topic Starter
  • Banned
  • PipPipPip
  • 354 posts
Hi Michael,

Thanks for the reply. I'm rushing off to see if that works. RATS! Nope that doesn't work either. I just did a reconfiguration and it didn't ask for a user name anywhere. It did ask for a 'root password' so I reset that.

Any other ideas?

Wendy
  • 0

#6
Michael

Michael

    Retired Staff

  • Retired Staff
  • 1,869 posts
Have you installed MySql as a service?
  • 0

#7
-=blaster=-

-=blaster=-

    Member

  • Member
  • PipPipPip
  • 181 posts
Hi again,

I see you have Apache up and running. Hooray!!!

In config.inc.php, remove anything in the blowfish_secret. And set $cfg['Servers'][$i]['auth_type'] = 'http'

Use the default mysql username, in linux, 'root', without a password, to login the first time.

When you get into phpmyadmin, it will remind you to add passwords to the 'root' account. This is done under the 'priviledges' section.

:whistling:
  • 0

#8
wendy k. walker

wendy k. walker

    Member

  • Topic Starter
  • Banned
  • PipPipPip
  • 354 posts
Hi Michael,

Thanks for the reply. Yes I installed MySQL as a service. *hope that was the right thing to do*

Hi -=blaster=-

Thanks for the reply. RATS! That didn't work I got an error thing saying wrong username and password Access Denied!

This is how I'm trying to get to phpMyAdmin just in case it makes a difference, and I'm on Windows XP SP2 also. http://localhost:8080/phpMyAdmin

Thanks for trying, anything else to try?

Wendy
  • 0

#9
Michael

Michael

    Retired Staff

  • Retired Staff
  • 1,869 posts
Yes that was the right thing to do.

Have you tried to run it from the command line. Does it work then?

Yeah I should have remembered that the default password as "root". Thanks for that -=blaster=- :whistling:
  • 0

#10
wendy k. walker

wendy k. walker

    Member

  • Topic Starter
  • Banned
  • PipPipPip
  • 354 posts
Hi Michael,

Thanks for the reply. Well that 'root' thing didn't work either. When you say --> Have you tried to run it from the command line <-- Do you mean command line as in --> Start>run>cmd>enter? <-- I tried that but it won't work at all that way.

*taking huge aspirin* I'm wondering if I need to un-install everything and start over again. That brings me to another possible source of my problem which is --> I have installed\uninstalled MySQL several times and this last time around I just happened to see a notice that said if I had un-installed a previous copy of MySQL that the un-install didn't automatically remove the previous password which is squirreled away somewhere in the windows directory and that I would need to do that manually.

Where the heck do I look for it? What does it look like? "I'm Doomed Charlie Brown!"

Thanks for your help.

Wendy
  • 0

Advertisements


#11
Michael

Michael

    Retired Staff

  • Retired Staff
  • 1,869 posts
Try this http://www.tech-faq....-password.shtml
  • 0

#12
wendy k. walker

wendy k. walker

    Member

  • Topic Starter
  • Banned
  • PipPipPip
  • 354 posts
Hi Michael,

Thanks for that link = now I know you hate me :whistling: !

I almost went insane just looking at that stuff. Did I forget to tell you that I' blond? Well not really but I'm about as dumb as a rock when it comes to this PC stuff.

I checked out that site and when I saw;
--> 1.) Stop the mysqld daemon process.
2.) Start the mysqld daemon process with the --skip-grant-tables option.
3.) Start the mysql client with the -u root option.
4.) Execute the UPDATE mysql.user SET Password=PASSWORD('password') WHERE User='root';
5.)Execute the FLUSH PRIVILEGES; command. <-- I almost fainted!

How the heck do you do that?

So then I googled "How do I reset a MySQL password in windows?" and found "This" so I breathed a sigh of relief and gave it a go.

I couldn't find a my.cnf file anywhere so I went on with the instructions. Step 1 & 2 weren't too hard to figure out but step 3 didn't work. When I tried it it kicked back an error message saying;

--> 'mysqld.exe' is not recognized as an internal or external command operable program or batch file. <--

Then I just gave steps 4,5, & 6 a go just for the heck of it. They didn't work either but gave me an ERROR 2003 (HY000): can't connect to MySQL server on 'localhost' when I hit enter.

You have any idea what might cause that?

Thanks for your time and help Boo.

Wendy
  • 0

#13
Michael

Michael

    Retired Staff

  • Retired Staff
  • 1,869 posts
When in the command console (Start>run>cmd>enter). Type the path to the mysql.exe

Example

C:\Path\to\mysql.exe UPDATE mysql.user SET Password=PASSWORD('password') WHERE User='root'

or

C:\Path\to\mysql.exe FLUSH PRIVILEGES
  • 0

#14
wendy k. walker

wendy k. walker

    Member

  • Topic Starter
  • Banned
  • PipPipPip
  • 354 posts
Hi Michael,

OK I used both of your examples and did it both ways but all I get is a message saying that that is not a command operable function or batch file.

Alright I've pulled out so much of my hair now that the top of my head is starting to look like Homer Simpson's. I think I might still have four strands of hair left.

I did some more Googling and found "This" . It mentions the MySQL Reference Manual [which I can't seem to find] and lays out the procedure for resetting the root password.

BUTT!!! Don't you know it just flat refuses to work for me. I got through steps 1 through 4 with no problem but got totally stuck in step 5.

I followed the first part of the instructions and didn't get anywhere. Then I did it with the -default file settings from the properties and got the same results --> NOTHING!

*why me lord?*

All I can get is 'Fatal Error' or the 'is not a command function or batch file' notice. I've tried rearranging the syntax until I went cross-eyed and that didn't help either.

So... you got any other ideas?

Wendy
  • 0

#15
Michael

Michael

    Retired Staff

  • Retired Staff
  • 1,869 posts
Where have you installed MySql to? What folder?
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP