Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Partitioning a 160 GB Hard Disk


  • Please log in to reply

#1
Diego8

Diego8

    Member

  • Member
  • PipPipPip
  • 189 posts
I bought a new Maxtor 160 GB HD a few days ago. Today i installed it (removed my old hard disk, and set the new as Master) and then ran the Windows XP SP2 instalation program with the CD. I decied to split the hard disk into two partitions, the primary (C:) with 100 GB and the rest assigned to the second partition. Then chose to install Windows in the primary partition and formatted it as NTFS (normal formatting), formatting ended succesfully and Windows copied the files needed to start the instalation process.
After 15 seconds the computer rebooted automaticallty and then, here's where the problem comes. At this point Windows should start the installation from the hard drive but it doesn't, it starts all over again from the CD. I tryed removing the CD from the CD drive and forcing the computer to boot from the hard disk but it says something like "SYSTEM BOOT FAILURE, PLEASE INSERT A BOOT DISK AND PRESS ENTER".

After all this i tryed formatting the hard disk with Partition Magic Pro 7.0 (connecting both the old and new hard disks and setting the new as slave). I erased both partitions and then when i want to create the 100 GB primary partition (NFTS system) a label saying "This partition crosses the 1024 cylinder boundary and may not be bootable" appears.
Why is all this happening? Can't i make a 100 GB partition?.

Thanks in advance.
  • 0

Advertisements


#2
Samm

Samm

    Trusted Tech

  • Member
  • PipPipPipPipPipPip
  • 3,476 posts
I suspect the problem is this :

Your drive requires 48bit LBA support (because it is over 137GB in size). However, Windows 2000 does not support 48bit LBA unless you have SP3 or higher.

In theory, you should be able to install Windows 2000 SP2 so long as you don't partition the drive beyond about 120GB, so a 100GB primary partition should be fine but don't partition the remainder of the drive.
Once Win2000 is installed you can then install SP3 or preferably SP4, then use disk management to partition the remaining 60GB.

The fact that you say you can't even create 100GB partition now, suggests that the partition table has got confused. Your best bet is probably to zero fill the drive and start again.

I've attached a DOS utility that will zero fill the drive for you. If you use it, please follow these instructions very carefully :

Attached File  slate10.zip   16.37KB   45 downloads

***CAUTION - THESE INSTRUCTIONS WILL WIPE EVERYTHING ON THE HARD DRIVE, INCLUDING DATA & PARTITIONS***

1) If you don't already have a bootable floppy disk, then download one from here :
http://www.bootdisk.com/bootdisk.htm
Select the Windows98se custom, no ram drive option & download it. Insert a blank floppy & run the downloaded file. his will create a bootable disk for you.

2) Once you have a boot disk, extract the files from slate.zip (attached) & copy then to the bootable floppy. Do not write protect the floppy disk.

3) Before using the boot disk, I recommend you disconnect the second hard drive so that only the 160GB drive is connected.

4) Insert the floppy disk, power the system & go straight into the bios. In the bios make sure that the 160gB drive is correctly detected. Also make sure the boot order is set so that floppy is first in the list. Save any changes in the bios & exit.

5) The system will then boot from the floppy disk. If it asks whether you want to load CDROM drivers, you can say no.

6) Once the disk has loaded, at the A:> prompt, type the following :
slate 1 /sa

This will zero fill the drive & create a backup of the pre-zero'd MBR on the floppy. Afterwards the system will reboot. On reboot, eject the floppy & shut the system down.

7) Next, you can boot from the Windows 2000 CD & install windows to the blank drive. Remember, only partition the first 100GB of the drive
  • 0

#3
pip22

pip22

    Trusted Tech

  • Banned
  • PipPipPipPipPip
  • 2,663 posts
It takes more than 15 seconds for Windows to copy setup files to the hard disk. You should have let the process continue when it started to read from the cd a second time after formatting.

Ignore the message you got from Partition magic. it only applies to very old computers.

Run Windows setup again. Leave the CD in the drive until Windows is actually up and running. Windows setup is designed to allow you to do that. That's why the "press any key to boot from CD" is provided.
  • 0

#4
Diego8

Diego8

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 189 posts
I misexplained myslef. The 15 seconds of wait are the ones that came after copying all the files, when the system is waiting for reboot.
Turns out the problem had to do with the jumper setting. The label on top of the disk that explains which setting correspond to master,slave,etc is quite confusing.
After setting the jumper to cable select (according to picture on the label) the bios detected it as master and it could boot.
Although all this i still have some confusion. At this moment i have connected the hard disk (as master) and a CD drive as salve, in the same IDE. If i connect my old hard disk (as salve) instead of the CD drive the bios detects only the new hard disk as slave. So, to be able to use both hard disks i have to switch the jumper to the position that at first was not bootable. ¿¿??
  • 0

#5
Tyger

Tyger

    Member 2k

  • Member
  • PipPipPipPipPip
  • 2,896 posts
If you hve an 80 wire UDMA IDE cable with a blue, grey and black connectors both drives should be set to cable select. You shouldn't place an optical drive on the same cable as a hard drive, it will greatly slow down the operation of your machine.
  • 0

#6
Samm

Samm

    Trusted Tech

  • Member
  • PipPipPipPipPipPip
  • 3,476 posts
A couple of things to bear in mind re. cable select & drive positioning....

Firstly, if you use the cable select jumper, then both drives on that cable should be set to CS.

Secondly, regardless of whether you use CS or not, the master drive must be placed at the end of the IDE cable (i.e last connector) and the slave drive in the middle. The blue IDE connector on the other end of the cable must be the one hat connects to the motherboard.

BTW - Tyger's right about the optical drive - you should place it one the secondary IDE controller & have the hard drives on the primary controller.
  • 0

#7
Diego8

Diego8

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 189 posts
Thanks to all for the help. I folowed Tyger's and Samm's advice and now it's working right. The HD is connected alone to IDE 0 and both optical drives (CD and DVD) are connected to IDE 1 using Cable Select jumper setting.
  • 0

#8
Samm

Samm

    Trusted Tech

  • Member
  • PipPipPipPipPipPip
  • 3,476 posts
Great. Thanks for letting us know :whistling:
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP