Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Internet Exlorer running slow


  • Please log in to reply

#1
liabub

liabub

    New Member

  • Member
  • Pip
  • 4 posts
Hello...I am new here and in need of some help.

My Internet Explorer is running VERY slow. It takes forever to load a page. I am using Windows XP and Netscape for my internet connection. I have scanned with Ad Aware and Spybot. I also use Norton Antivirus and update regularly. I also download Windows updates regularly. I have downloaded HiJackThis and have not ran it yet. Any suggestions on what I can try to improve my speed? Thank you.
  • 0

Advertisements


#2
SuperSam

SuperSam

    Member

  • Member
  • PipPipPip
  • 693 posts
Hi there, and welcome to geeks to go.

Try giving CCleaner a download and run that to clean up any stuff thats un-needed and just laying around: www.ccleaner.com

Edited by SuperSam, 15 March 2007 - 09:09 AM.

  • 0

#3
liabub

liabub

    New Member

  • Topic Starter
  • Member
  • Pip
  • 4 posts
That seems to have done the trick. I am running much faster now. Thank you so much!!!
  • 0

#4
liabub

liabub

    New Member

  • Topic Starter
  • Member
  • Pip
  • 4 posts
That seems to have done the trick. I am running much faster now. Thank you so much!!!
  • 0

#5
liabub

liabub

    New Member

  • Topic Starter
  • Member
  • Pip
  • 4 posts
Sorry for the duplicate entry. Having trouble with my internet connection!

Edited by liabub, 15 March 2007 - 05:46 PM.

  • 0

#6
SuperSam

SuperSam

    Member

  • Member
  • PipPipPip
  • 693 posts
No problem, glad to help. Hope its all working for you.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP