Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

NEED FOR SPEED CARBON WONT RUN


  • Please log in to reply

#1
==SpuD==

==SpuD==

    Member

  • Banned
  • PipPipPip
  • 691 posts
i have installed nfs carbon and tried to ply it but it comes up with loadind screen tht disapeers then nothing happens
it works fine on my m8s laptop but wont wrk on mine
i have pretty good system specs and xp pro
does any1 no why it will not run
please help
these are my system specs
i have also downloaded and installed the patch 1.3 and it still doesnt work

Attached Files


Edited by ==SpuD==, 01 April 2007 - 09:25 AM.

  • 0

Advertisements


#2
HPDV8315LOVER

HPDV8315LOVER

    Member

  • Member
  • PipPipPip
  • 224 posts
Do you have your video driver and DirectX up to date?
  • 0

#3
==SpuD==

==SpuD==

    Member

  • Topic Starter
  • Banned
  • PipPipPip
  • 691 posts
yer i have got direct x9c i think is the latest 1
il try and update video card
  • 0

#4
==SpuD==

==SpuD==

    Member

  • Topic Starter
  • Banned
  • PipPipPip
  • 691 posts
have updated the video driver still wont run
  • 0

#5
Fragman52

Fragman52

    Member

  • Member
  • PipPip
  • 23 posts
Patch the game to its latest version. EA always leaves critical problems in games upon release, so the first patch usually fixes a ton of stuff.
  • 0

#6
==SpuD==

==SpuD==

    Member

  • Topic Starter
  • Banned
  • PipPipPip
  • 691 posts
have updated it 2 the 1.3 patch is that the latest?
  • 0

#7
Fragman52

Fragman52

    Member

  • Member
  • PipPip
  • 23 posts
Hmmm, I've only heard of this happening with Vista. Try *cringe* running the game in compatibility mode. 98 or something might work.

If not, another solution is to temporarily remove the "movies" folder from the game directory. Remove this folder, test the game, and see if it works. You won't get to view any cutscenes, but it might fix the problem.
  • 0

#8
==SpuD==

==SpuD==

    Member

  • Topic Starter
  • Banned
  • PipPipPip
  • 691 posts
k il tryit
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP