Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Can anyone figure out this Rosetta Stone Farsi problem?

  • Please log in to reply




  • Member
  • PipPip
  • 13 posts
Ok, I have attempted to backup my Rosetta Stone Farsi discs 640 times. I cannot get them to back up. I have back ups of Arabic level one and two discs that DO work.

I have the Farsi set (levels one and two, lessons 1-19). I cannot get the RS program to read the Farsi.

I have the disc (or mounted ISO image) set up like this:

Root directory: All the FAR and PCT folders, and the three TRS files (CDID, credits, and CATMPC). The disc is named FAR_LEV1+2.iso (or the disc).

I mount the disc in D-Tools and start up Rosetta Stone (I have tried just about every version of the application, but currently I am using v2.1.3.0.a). If I don't include the CATMPC file it simply doesn't find the language. If I include it, it says "ERROR PARSING CATMPC.TRS: Cannot recognize 'Farsi' ". I have also tried to set up the CATMPC file to say Farsi Set but it gives the same error (cannot recognize "Farsi Set" instead though).

Below I have included images of what my ISO directory looks like, and links to all of my TRS files. I think the problem lies within the TRS setup. I know I am missing something simple or something.

If anyone can help or provide suggestions I am all ears.

Lastly, does anyone have a working backup of Rosetta Stone Farsi, or is it the elusive language that simply won't back up???

Here are the links to all the information I talked about:

TRS files:

Screen shots (not that I am not trying to show EVERY folder in these screen shots, just the way it is set up and the basic naming conventions. Basically there are three things in the ISO: the FAR folders, the PCT folders, and the TRS files):


PS - If I include the Autorun files on the ISO or disc, when I put in the disc or mount it, it says Rosetta Stone is not installed on this computer (it clearly is).
  • 0





  • Topic Starter
  • Member
  • PipPip
  • 13 posts
bump :whistling:
  • 0



    Global Moderator

  • Global Moderator
  • 6,588 posts
I suspect that your fighting a copy protection issue.
btw, even though your trying to do a legitimate action, your tools and process's can be/are used by pirates and therefore we can not help with your issue. Please see our Terms of Service for more information.

Feel free to pm me if you have any questions.
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP