Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

After XP Re-install- PC does not recogize PCI 2.0 card


  • Please log in to reply

#1
ELECTRIC WIZARD

ELECTRIC WIZARD

    Member

  • Member
  • PipPip
  • 46 posts
I installed a Koutech PCI to USB2.0 Card Model IO-PU520 last year in my PC. It worked fine. I lost the install cd since then. I had to re-install XP and updated everything. I can use the USB 2.0 card but my pc says it is the 1.1 USB. I down loaded the driver. I tried updating the driver but the wizard says that it could not find a better match. The date of the driver I am using says 7-1-2001. New updated driver should be newer. Why is the new driver not installing. Do I have to uninstall the old driver?

any help would be appreciated.
  • 0

Advertisements


#2
Titan8990

Titan8990

    Member

  • Member
  • PipPipPipPipPip
  • 2,189 posts
You can find the latest drivers for that card here: http://www.koutech.com/downloads.asp.
  • 0

#3
ELECTRIC WIZARD

ELECTRIC WIZARD

    Member

  • Topic Starter
  • Member
  • PipPip
  • 46 posts
Hi

I down loaded the driver and try the install. But the wizard advised that it did not find a better match. DoI have to uninstall the old driver then install the new driver?
  • 0

#4
Titan8990

Titan8990

    Member

  • Member
  • PipPipPipPipPip
  • 2,189 posts
Yes, that would be the safest way to go about it. Sometimes its alright to just install over the old drivers but theres no reason not to go ahead and uninstall the old ones.
  • 0

#5
ELECTRIC WIZARD

ELECTRIC WIZARD

    Member

  • Topic Starter
  • Member
  • PipPip
  • 46 posts
I downloaded the driver from a different site and it installed correctly. The driver from manufactors website did not work.

thanks for helping.
  • 0

#6
Titan8990

Titan8990

    Member

  • Member
  • PipPipPipPipPip
  • 2,189 posts
Glad you got it worked out :whistling:.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP