Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

StarCraft: Brood War Latency Issue


  • Please log in to reply

#1
Tibatron

Tibatron

    Member

  • Member
  • PipPip
  • 17 posts
I recently started playing StarCraft again, and having been getting really bad lag on Battle Net.

Everything works fine when there is only 2 people in a game, but if there are 3 or more players, Everyone gets really bad lag, and it is almost like you are watching a slideshow.

Does anyone else have this problem, or have a solution?

Thanks.

System Specs:
AMD Athlon 64
X2 Dual Core Processor, 3800+
2.00GHz
1.00GB RAM

Edited by Tibatron, 20 May 2007 - 07:53 PM.

  • 0

Advertisements


#2
HPDV8315LOVER

HPDV8315LOVER

    Member

  • Member
  • PipPipPip
  • 224 posts
did you update StarCraft?
  • 0

#3
Tibatron

Tibatron

    Member

  • Topic Starter
  • Member
  • PipPip
  • 17 posts
Yes. I got the 1.15 update.
  • 0

#4
Chopin

Chopin

    Member 2k

  • Member
  • PipPipPipPipPip
  • 2,639 posts
Yes, Patch v1.15 comes with a lot of bugs, including being unable to use Oblivion and unable to stack Zerg units.

Uhh... what I meant to say...

Patch v1.15 comes with a lot of bugs, including reduced download speed, not downloading maps at all, random drops, maphacks not working, lag, and many complaining users.

Just wait for Blizzard to fix it up.. oh, wait they're working on SCII! What's the point if you can't keep the normal SC up and running :whistling:
  • 0

#5
Capt Crappy

Capt Crappy

    New Member

  • Member
  • Pip
  • 4 posts
I also have this problem as I lag everytime I join a game and then get disconnected. But I dont understand why it still works for some people. I used to be able to play and havin been trying for about the past month. Prior to this I hadnt played since december, but it had worked fine then.
  • 0

#6
Max50

Max50

    Member

  • Member
  • PipPip
  • 10 posts
My only latency problem is that when I create a game nobody can join because my latency is so high. So I can't make any of the awesome RPGs that I have and play with people :whistling:
  • 0

#7
MAD 4 Brood War

MAD 4 Brood War

    New Member

  • Member
  • Pip
  • 3 posts

My only latency problem is that when I create a game nobody can join because my latency is so high. So I can't make any of the awesome RPGs that I have and play with people :)

You have the same problem as me....when ever i try to create on Brood War no one join cause of latecy. :)
:) so i cant make any mad games i have downloaded


Plz Help :) :)

Edited by MAD 4 Brood War, 08 June 2008 - 09:55 PM.

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP