Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Boot.ini


  • Please log in to reply

#1
Steve Soleimani

Steve Soleimani

    Member

  • Member
  • PipPipPip
  • 272 posts
When I restarted my computer I got a message saying "invalid boot.ini loading from c:\windows". The machine then proceeds to boot normally. Is there anything to worry about? What should I do?
  • 0

Advertisements


#2
happyrock

happyrock

    Tech Moderator

  • Retired Staff
  • 9,285 posts
Try this ... go to start...run ...and type in MSCONFIG...press OK Then click on the "Boot.ini" tab. First, make sure if using XP Pro that the following is listed:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect


- this is the boot.ini information from XP, straight from the Microsoft Web Site. [operating systems] should be on one line!

If you have a blank boot.ini file, copy and paste this information - if all information is already there, then don't change anything.
Next, click the button that says "check all boot paths". You should get back a message stating that everything is good (the computer checks to make sure the boot.ini file is compatible with Microsoft Operating Systems).
Next, assuming your computer likes the boot.ini file that is in there (and it should), then click the button that says "set as default". By doing this, you have now created a new (modified) boot.ini file that is a carbon copy of the original.
Click apply. You will be prompted to restart. Before doing so, go back to MSCONFIG and in the general tab you will see that "use modified boot.ini" should now be checked.
During reboot, you should not get the invalid boot.ini message (at least I didn't). What you will get is a message ,after reaching the desktop, stating that you are not using the defaults or something like that and do you wish to go back into MSCONFIG to restore the default settings. Since your new boot.ini file is exactly the same as your original, click no and check the box to hide that message.

Edited by happyrck, 23 June 2007 - 07:57 AM.

  • 0

#3
Steve Soleimani

Steve Soleimani

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 272 posts
I don't have a "Boot.ini" tab, probably because i have Home Edition, and not Pro.
  • 0

#4
Troy

Troy

    Tech Staff

  • Technician
  • 8,839 posts
XP Home Edition has the Boot.ini tab, I just checked (I use Home Edition). This is exactly what mine says, and I don't have any problems.

[boot loader]
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
timeout=30
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /fastdetect /NoExecute=OptIn

What do you see when you Start > Run > MSCONFIG?
  • 0

#5
Steve Soleimani

Steve Soleimani

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 272 posts
When I type in MSCONFIG it brings up the System Configuration Utility, and the tabs I currently see are:

General
System.ini
Win.ini
Services
Startup

Edited by Steve Soleimani, 24 June 2007 - 09:39 AM.

  • 0

#6
happyrock

happyrock

    Tech Moderator

  • Retired Staff
  • 9,285 posts
are you sure what version of windows are you using...
xp should look like this

get a screenshot and post it for me

Edited by happyrck, 24 June 2007 - 10:28 AM.

  • 0

#7
Steve Soleimani

Steve Soleimani

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 272 posts
Posted Image
  • 0

#8
The Skeptic

The Skeptic

    Trusted Tech

  • Technician
  • 4,075 posts
Read this.
  • 0

#9
Steve Soleimani

Steve Soleimani

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 272 posts
When I typed in "C:\Boot.ini" into run, it gave me this error message:

Posted Image
  • 0

#10
The Skeptic

The Skeptic

    Trusted Tech

  • Technician
  • 4,075 posts
There is another part in the link I gave you, changing a value in the registry. If you go for that please don't forget to backup the key or the entire registry beforhand.
  • 0

Advertisements


#11
evovove

evovove

    Member

  • Member
  • PipPip
  • 23 posts
Looks like you're completely missing the boot.ini file from your C: drive.
Goto C:\WINDOWS\pss and copy 'boot.ini.backup' to your C: drive and rename it to 'boot.ini'. Reboot your machine and this problem should be gone.

Edited by evovove, 25 June 2007 - 10:42 AM.

  • 0

#12
Steve Soleimani

Steve Soleimani

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 272 posts
Thank you it worked, and the boot.ini tab is back in the msconfig.
  • 0

#13
evovove

evovove

    Member

  • Member
  • PipPip
  • 23 posts
no worries.
  • 0

#14
Steve Soleimani

Steve Soleimani

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 272 posts
Now that the boot.ini tab is back does that mean everything is OK now?
  • 0

#15
Troy

Troy

    Tech Staff

  • Technician
  • 8,839 posts
Um, you tell us? As long as it doesn't give you the error messages you were enquiring about, then I guess so!

Cheers :whistling:
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP