Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Check Disk continually cancels on reboot


  • Please log in to reply

#1
Jaitan

Jaitan

    Member

  • Member
  • PipPip
  • 23 posts
Greetings;

It has just come to my attention that i need to perform a chkdsk and repair action as
many files i am using on yahoo messenger, C-Mud and Zmud is corrupted.

But when runnning on cmd chkdsk /c/r
It says "Cannot lock current drive. Chkdsk cannot run because the volume is in use by another process. Would you like to schedule this volume to be checked the nest time the system restarts?

I select yes..and perform a reboot. Most times it reboots and says (it flashes and disappears quite fast) something about
NTFS being the file and ...it just cancels to operation. ..Sometimes it just sits there with the cursor blinking and nothing happens so cold boot it and then it starts..and i get the same thing..it cancels and mentions the NTFS.

I have tried the kill all untility program and ended many processes and tried the cmd chkdsk again..same thing..it cannot lock.
I have run spybot search and destroy...and cleared abou 6 items..tried again and same thing. Cannot lock.

I tried booting into safe mode and using the cmd prompt and same thing...cannot lock

I ran the RegCure program and found a quiet a few errors and this software said it could correct it..however, only after payment for registration. Can this program really clear the NTFS issue without the lock as i dont mind paying for it ..if it works...

What sort of thing is running b4 it boots that inable chkdsk to work? or is chkdsk corrupted itself?

Edited by Jaitan, 24 August 2007 - 01:43 AM.

  • 0

Advertisements


#2
wannabe1

wannabe1

    Tech Staff

  • Technician
  • 16,645 posts
Hi Jaitan...

There are several things that come to mind. The first thing I'd check is the partition type. Right click on "My Computer" and choose "Manage". In the left pane, expand (click +) "Storage", and click on "Disk Management". After the information displays, look in the right pane. Is the C: partition listed as NTFS or FAT?

wannabe1
  • 0

#3
Jaitan

Jaitan

    Member

  • Topic Starter
  • Member
  • PipPip
  • 23 posts
Thank you Wannabe1 for your response.

When doing what you asked...it (Drive C)says NTFS...as well as (Healthy)

Jaitan

Edited by Jaitan, 18 August 2007 - 09:05 PM.

  • 0

#4
Jaitan

Jaitan

    Member

  • Topic Starter
  • Member
  • PipPip
  • 23 posts
I just updated to win service pack 2....tried it all again ..still chkdsk cancels on reboot.

Can anyone help?
  • 0

#5
wannabe1

wannabe1

    Tech Staff

  • Technician
  • 16,645 posts
Try starting the check from the Properties window. Open My Computer, right click on Local Disk C:, and choose "Properties". Under the "Tools" tab, in the Error Checking section, click on the "Check Now" button. Select both check boxes in the next window. When you are told the drive is in use, tell it "Yes"...run it on the next restart.

Reboot.

In a command session, you might also try the command: chkdsk /r c:
  • 0

#6
jaxisland

jaxisland

    Member 1K

  • Member
  • PipPipPipPip
  • 1,703 posts
For me I open a command prompt and run: chkdsk /f /r
Then yes to run on reboot
then reboot.
  • 0

#7
Jaitan

Jaitan

    Member

  • Topic Starter
  • Member
  • PipPip
  • 23 posts
Thanks....

I have performed both from the properties window and selected both and did chkdsk /c/r at
the command and still...it cancells on reboot for both.

Jaitan
  • 0

#8
Metahuman

Metahuman

    Member

  • Member
  • PipPip
  • 17 posts
Please use "chkntfs /d" to clear the volume dirty bit.

It is always advisable to run chkdsk on volumes that have been improperly shutdown. However, there may be some situations in which running chkdsk after every improper shutdown is not possible or practical.

Also, check HKEY_LOCAL_MACHINE\SYSTEM\CURRENTCONTROLSET\CONTROL\Session Manager,

The default value is:
BootExecute:REG_MULTI_SZ:autocheck autochk *

If the autochk is not pointing to the correct location of chkdsk then you may also get this error.
  • 0

#9
Jaitan

Jaitan

    Member

  • Topic Starter
  • Member
  • PipPip
  • 23 posts
Thanks... I ran a chkntfs /d and on /c and nothing came up.

How do i run a chkdsk HKEY_LOCAL_MACHINE\SYSTEM\CURRENTCONTROLSET\CONTROL\Session Manager just as typed? If so i get invalid parameter for both manager and owner.

If i run the above with check ...i get that check is an invalid command...

I am more than a bit of a newbie... :whistling:

Thanks
Jaitan
  • 0

#10
Metahuman

Metahuman

    Member

  • Member
  • PipPip
  • 17 posts
Erm, you need to click on Start > Run > Regedit.

On your left side, you might see 5 - 6 folder-like registry hives. You need to double click on HKEY_LOCAL_MACHINE first, then SYSTEM, then CURRENTCONTROLSET, untill, you reach the Session Manager key. Here, you need to look at your right side & check for the entry I have specified. (:
  • 0

Advertisements


#11
don77

don77

    Malware Expert

  • Retired Staff
  • 18,526 posts

I am more than a bit of a newbie..


I would suggest a back up of the registry before you go making any changes
  • 0

#12
Jaitan

Jaitan

    Member

  • Topic Starter
  • Member
  • PipPip
  • 23 posts
Thanks..when I go there...on currentcontrolset on the right is ---- "default" "REG _SZ" and then "value" not set"

Edited by Jaitan, 26 August 2007 - 07:35 AM.

  • 0

#13
Jaitan

Jaitan

    Member

  • Topic Starter
  • Member
  • PipPip
  • 23 posts
Sorry, what changes at this spot should i make?
  • 0

#14
wannabe1

wannabe1

    Tech Staff

  • Technician
  • 16,645 posts
Don't change anything at that key.

You need to keep going in the left pane by expanding (click the +) CurrentControlSet, then Control, then click on Session Manager.

Then look in the right pane and locate the BootExecute string...the value of this should be autocheck autochk *

If you find this key has the correct value...
  • If you have Spyware Doctor installed, uninstall it.
  • If you have ZoneAlarm installed, open it, click the "Overview" tab, then select "Preferences", and UNcheck the "Protect ZA Client" check box.
Click Start, then Run, type cmd in the Open box and click "Ok". At the prompt in the Command window, type the following commands, pressing "Enter" after each one: (Please note the spaces in the following commands.)
  • chkntfs /d ..... (This will reset autocheck options to default)
  • chkntfs /c C: ..... (This will allow checking drive C:)
  • fsutil dirty query c: ..... (This queries the drive and will most likely tell you that it is dirty)
  • chkntfs /x c: ..... (The x switch tells Windows to NOT check the specified drive on the next boot)
At this point, restart your computer, it will not do a chkdsk and will boot directly to Windows.

This next step is important as this is where the Dirty Bit will be unset.
Click Start, then Run, type cmd in the Open box and click "Ok". At the command prompt, type the following, pressing "Enter" after each one: (Again, note the spaces.)
  • chkdsk /f /r c: ..... (To manually run a full chkdsk operation)
  • Y ..... (To accept having it run on the next boot)
This should take you through 5 stages of the scan and will unset that Dirty Bit. Be patient...this is a very thorough check and will take quite a while.

Finally, when the chkdsk operation has completed, type fsutil dirty query c:, press "Enter", and Windows will confirm that the Dirty Bit is not set on that drive.

Now reboot again and see if chkdsk still runs on bootup.
  • 0

#15
Jaitan

Jaitan

    Member

  • Topic Starter
  • Member
  • PipPip
  • 23 posts
Ah yes sorry for the spaz out...

On session manager on the right it says Boot execute Reg Multi_SZ autocheck autocheck /r/c\??C:PD reboot.exe autocheck...
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP