Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Disk Defragmenter


  • Please log in to reply

#1
friedpooodle

friedpooodle

    Member

  • Member
  • PipPipPip
  • 162 posts
Whevnever I try to run Disk Defragmenter, I get an error message. A pop-up notification shows up. In the title it says "Microsoft Management Console." The actual message looks like this:

Name:<unknown>
CLSID:{43668E21-2636-1101-AICE-0080C88593A5}
After I click on "OK," Disk Defragmenter opens up and in the window the only that to be seen is a message that says "Snap-in Creation Failed."

If anyone knows how I can solve this problem please let me know.
  • 0

Advertisements


#2
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
right click on My Computer, choose Properties, choose Advanced, choose environments variables and under "System Variables" what do you see?
  • 0

#3
friedpooodle

friedpooodle

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 162 posts
Alright, here is a list of what I saw.

Variables:

Com Spec
FP_NO_HOST_CHECK
NUMBER_OF_PROCESSORS
OS
Path
PATHTEXT
PROCESSOR_ARCHITECTURE
PROCESSOR_IDENTIFIER
PROCESSOR_LEVEL
PROCESSOR_REVISIORY
TEMP
TMP
windir

If you need to see the value of any of these please ask and thank you very much for you help so far.
  • 0

#4
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
I'm sorry, I should have been more specific....

after PATH, do you see:

%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;
  • 0

#5
friedpooodle

friedpooodle

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 162 posts
After PATH, I see: C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem
  • 0

#6
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
Really, yours should work, but try changing it to what mine said (they are the same thing, basically)
  • 0

#7
friedpooodle

friedpooodle

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 162 posts
I tried it and my Defragmenter still has the same error.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP