Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

SFC Scannow - Problem with XP Files Location


  • Please log in to reply

#1
Slider92

Slider92

    Member

  • Member
  • PipPip
  • 91 posts
My computer has been actinga bit weird lately. For example. sometimes when I try to hibernate it hangs when on the blue shutdown screen which says: "Hibernating".

SO I decided to use the SFC Scannow. Then I got the common problem: It wants me to insert the XP Home Edition Disc which I dont have. I however do have a XP Professional Disc, but that won't help me right. I have a DELL PC and did not get a XP CD with it, but I do have a folder in my C:\ disc: C:\i386.
I found out that it is the backup of XP. I also found out that I had to go to the registry and find "Sourcepath" and make it go to C:\. I did that, but the insert XP disc still pops up while scanning.

So my question is: NOW WHAT?!
  • 0

Advertisements


#2
Kniht

Kniht

    Member

  • Member
  • PipPipPip
  • 236 posts
There is another setting in the registry that may be causing the problem. Navigate to:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SourcePath

Make sure the entry here is the same path to the I386 folder as used with HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\
CurrentVersion\Setup\SourcePath

Reboot for the changes to take affect.

Edited by Kniht, 10 September 2007 - 05:26 AM.

  • 0

#3
Slider92

Slider92

    Member

  • Topic Starter
  • Member
  • PipPip
  • 91 posts

There is another setting in the registry that may be causing the problem. Navigate to:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SourcePath

Make sure the entry here is the same path to the I386 folder as used with HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\
CurrentVersion\Setup\SourcePath

Reboot for the changes to take affect.


yes I read that somewhere and checked, but it was as it was supposed to be: Both my Sourcepaths point to C:\
  • 0

#4
The Skeptic

The Skeptic

    Trusted Tech

  • Technician
  • 4,075 posts
If you operate i386 I think that you will end up formatting the hard disk, which you don't want, I believe. Try to borrow xp home edition and run the process.
  • 0

#5
Slider92

Slider92

    Member

  • Topic Starter
  • Member
  • PipPip
  • 91 posts
I was planning on formatting my PC already.. or not format, but use the DELL PC Restore. Do you think that would solve the problem?
Note that I'm not restoring my DELL PC to the day I got it because of this problem. I've got some other problems which I would rather not use time on solving when I could use 2 min on the restore.
  • 0

#6
The Skeptic

The Skeptic

    Trusted Tech

  • Technician
  • 4,075 posts
If you backed up your data and you are aware that formatting will lead to reinstallation of all your applications then go ahead with it. As a matter of policy G2G do not recommend formatting but at the end of the day formatting is, very often, the best and fastest solution for a million software problems.
  • 0

#7
Slider92

Slider92

    Member

  • Topic Starter
  • Member
  • PipPip
  • 91 posts
I went on with formatting, but something happend again while installing norton antivirus. The "you are missing some XP files....insert XP disc" message appeared again. But I'm not noticing anything special which can be critical so I think I'm just gonna let it be unless I somehow get the Home Edition Disc from somewhere

I got another problem though:

I can't run some video files properly. In Windows Media Player I get this security warning:

"Windows has blocked this software because the publisher can not be verified.
Name: ocget.dll
Publisher: Unknown Publisher"


I can only hear the sound but no picture.

I can however play the video file with VLC Player, but I don't like these kind of problems.

Edited by Slider92, 15 September 2007 - 02:20 PM.

  • 0

#8
Kniht

Kniht

    Member

  • Member
  • PipPipPip
  • 236 posts
Open regedit (Start>>Run. In Run type regedit and click OK)

Change the following registry key so that it does not query ocget.dll:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\CodeBaseSearchPath

You may want to backup this key before you make any changes. To do this, click on the Internet Settings key. Go to file>>export. Give the file a name and save to the folder of your choice. This way if something goes amiss you can always merge the exported .reg key back into the registry.

In the right hand pane, double click CodeBaseSearchPath. Then delete the Value data (backspace) so you are left with a blank. Click OK, then close the registry editor.
  • 0

#9
Slider92

Slider92

    Member

  • Topic Starter
  • Member
  • PipPip
  • 91 posts
Ok thanks! The stupid ocget thing disappeared, I installed the codec I needed and everythings fine!
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP