Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

"Access Denied"


  • Please log in to reply

#1
paulsiam

paulsiam

    Member

  • Member
  • PipPipPip
  • 118 posts
I have just reformatted my hard drive; Windows XP pro (same as before). I have a secondinternal hard drive [D] and and external hard drive [E]. Never had any problems with them before.

Now, if I open Windows Explorer or My computer, I can see both drives, and even the contents (listing of all folder names). But each time I click on a folder, I get the message :Access Denied." The firewall (both Windows & McAfee) is turned off. permisssions give me as Administrator full access (when i look under Drive-Sharing & Security-Security. I see administrator there with every checked for permission.

Can you help? All my data is on the two drives!

Paul
  • 0

Advertisements


#2
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
How to take ownership of a folder

Note You must be logged on to the computer with an account that has administrative credentials. If you are running Microsoft Windows XP Home Edition, you must start the computer in safe mode, and then log on with an account that has Administrative rights to have access to the Security tab.
If you are using Windows XP Professional, you must disable Simple File Sharing. By default, Windows XP Professional uses Simple File sharing when it is not joined to a domain.
For additional information about how to do this, click the following article number to view the article in the Microsoft Knowledge Base:
307874 How to disable simplified sharing and set permissions on a shared folder in Windows XP


To take ownership of a folder, follow these steps:
  • Right-click the folder that you want to take ownership of, and then click Properties.
  • Click the Security tab, and then click OK on the Security message (if one appears).
  • Click Advanced, and then click the Owner tab.
  • In the Name list, click your user name, or click Administrator if you are logged in as Administrator, or click the Administrators group. If you want to take ownership of the contents of that folder, select the Replace owner on subcontainers and objects check box.
  • Click OK, and then click Yes when you receive the following message:

    You do not have permission to read the contents of directory <folder name>. Do you want to replace the directory permissions with permissions granting you Full Control?.

    All permissions will be replaced if you press Yes.[/code]
    Note <folder name> is the name of the folder that you want to take ownership of.

  • Click OK, and then reapply the permissions and security settings that you want for the folder and its contents.
How to take ownership of a file

Note You must be logged on to the computer with an account that has administrative credentials.

To take ownership of a file, follow these steps:
  • Right-click the file that you want to take ownership of, and then click Properties.
  • Click the Security tab, and then click OK on the Security message (if one appears).
  • Click Advanced, and then click the Owner tab.
  • In the Name list, click Administrator, or click the Administrators group, and then click OK.

    The administrator or the Administrators group now owns the file. To change the permissions on the files and folders under this folder, go to step 5.

  • Click Add.
  • In the Enter the object names to select (examples) list, type the user or group account that you want to give access to the file. For example, type Administrator.
  • Click OK.
  • In the Group or user names list, click the account that you want, and then select the check boxes of the permissions that you want to assign that user.
  • When you are finished assigning permissions, click OK.

  • 0

#3
The Admiral

The Admiral

    Trusted Tech

  • Technician
  • 1,067 posts
Hi Paul,
Good to see that you know your advanced file sharing/security. Are you on the Administrator account, or do you have a seperate account set up that you use (although it may have Admin rights)? If you use a seperate account, e.g. Paul, you need to make sure that your account, e.g. Paul's Computer/Paul has access rights as well, not just Paul's Computer/Administrator.

*hi fives dsenette for beating me to it*

Edited by The Admiral, 10 September 2007 - 09:58 AM.

  • 0

#4
paulsiam

paulsiam

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 118 posts
it worked! what a joy!
I followed the steps to take ownership, and it took some time to go through all the folders on the two dirves, but now it is truly mine.

Thanks!
  • 0

#5
paulsiam

paulsiam

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 118 posts
May I re-open this problem, since it has happened again. Once the external drive was given permssion and ownership, I could access it both from my PC (where I did the security>ownership as suggested above. I then opened the external drive using my laptop, and it also worked ok.

After having used it for several days again on the PC, I tried today to put the external drive on the laptop and open it. I can see all the folders and all the files; but if I try to open anything, I get the error message "Access denied." And....if I follow the steps above to try to take ownership, there is no security tab at all! I see only "Sharing" as an option.

Can you advise, how can I get the security option in order to reset ownership again?
Or...what has happened?
Thanks a lot
Paul

Edited by paulsiam, 18 September 2007 - 06:52 PM.

  • 0

#6
piper

piper

    Retired Staff

  • Retired Staff
  • 2,459 posts
Hi paulsiam.

Is the laptop Windows XP Home or Pro? If Home, did you log in under Safe Mode?
  • 0

#7
paulsiam

paulsiam

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 118 posts
hello again Linda
The PC & laptop both have XP Pro.
I tried to get into the external hard drive when logged on as both Adminsitraotr and as my user Paul (who has adminstrator priviielges).
Please advise!
Thanks
Paul
  • 0

#8
piper

piper

    Retired Staff

  • Retired Staff
  • 2,459 posts
Have you shut everything down and brought it all back up?
  • 0

#9
paulsiam

paulsiam

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 118 posts
Yes, I shut down and rebooted into Administrator; no security tab is seen when I go to properties for the external hard drive.

I then rebooted into Paul (who has adminstrator privileges) and same.

Really lost!
Paul
  • 0

#10
paulsiam

paulsiam

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 118 posts
if worse come to worst, if I refomat the entire external hard drive, and then copy everything back onto it it (from PC second internal hard drive), will this overwrite and erase all the "bad" security variables that I now encounter in the external hard drive?
  • 0

#11
piper

piper

    Retired Staff

  • Retired Staff
  • 2,459 posts
Sorry for the delayed response, paulsiam.

If you format the drive and start over, you won't have any of those security issues. Those issues stemmed from the reformat of the OS drive.

If you have any other issues or questions, please post back.

Good luck!
  • 0

#12
paulsiam

paulsiam

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 118 posts
Problem solved (again!). I discovered that under folder options, I had "simple file sharing" checked -- I think this is the default on Windows XP installation. But in order to see the security tab and to give permissions etc, this option has to be unchecked. As soon as I unchecked it, the security tab now appears when I go to Drive > Properties. And then under security I can set all the permissions for the external hard drive, and it works fine.

Thanks for the continued interest.
Paul
  • 0

#13
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP

Problem solved (again!). I discovered that under folder options, I had "simple file sharing" checked -- I think this is the default on Windows XP installation. But in order to see the security tab and to give permissions etc, this option has to be unchecked. As soon as I unchecked it, the security tab now appears when I go to Drive > Properties. And then under security I can set all the permissions for the external hard drive, and it works fine.

Thanks for the continued interest.
Paul

in the words of the immortal homer simpson "DOH!!!!"....it's always the easy things that get you....sorry we didn't think of that
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP