Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Age Of Empires 2 Problem


  • Please log in to reply

#16
ande3295

ande3295

    Member

  • Topic Starter
  • Member
  • PipPip
  • 11 posts
i found this deal called port detective. i checked two ports 6073 and 47624 that are required for online play. port detective said they were both blocked. if this is accurate...how can i unblock them?
  • 0

Advertisements


#17
ande3295

ande3295

    Member

  • Topic Starter
  • Member
  • PipPip
  • 11 posts
:tazz:

Edited by ande3295, 15 April 2005 - 05:57 PM.

  • 0

#18
Manhorn

Manhorn

    New Member

  • Member
  • Pip
  • 2 posts
This is a common problem in P2P gaming.

Since you've just changed ISPs, my guess is that your provider has quietly put you (and many of its subscribers) behind some NAT (Network Address Translator) infrastructure on their end. NATs are put into place to functionally increase the network address space (your IP address) when the range of allocated IPs is narrower than their actual customer base.

This is fairly common and can be a real pain, because getting your ISP to set up port forward on your behalf is more than a pain. Most don't care, or their Tech Support won't understand the problem as well as you do.

To "fix" this, it may be as simple as asking the person you want to play with to host the game instead. They may NOT be behind any funny hardware your ISP is using, and therefore their IP address might be valid. Try this to see if works when you join instead of host (even if it helps only with some people). If that's the case, then your ISP has you behind a NAT and you'll need to start yelling at them to open the ports for you on their end.

Another option... Try Gamespy's (free) online matchmaking product. Their matchmaking layer works a little differently than the Zone, and you may find it more reliable for the situations your in.

Eventually, as IPv6 adoption increases, NATs won't be necessary and p2p connection problems like this will fade into memory. Don't hold your breath, however.

Hope this helps.
  • 0

#19
ande3295

ande3295

    Member

  • Topic Starter
  • Member
  • PipPip
  • 11 posts
thanks for the thoughts, however, i haven't been trying to host. i've just been trying to join games. isn't the DSL line that we have "our own" or would those NATs that you mentioned still apply?
  • 0

#20
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
Given your reverse trace, assuming it is complete, you are not on a NAT.

But, let's test that....

Start > run, type

ipconfig /all

Look for ip address and post only the first two octets (looks like this) xxx.xxx.xxx.xxx

Now, you noted earlier that 6073 and 47624 ports are blocked....

You said you disabled the windows firewall...

humor me....start > run, type

netsh firewall set opmode mode = disable

You say you do not have any other software firewall
do me a favor and post a hijackthis log
  • 0

#21
r011ingthunder

r011ingthunder

    New Member

  • Member
  • Pip
  • 6 posts
This is all a bit above my head guys, but I'm watching with great interest as I'm having an identical problem, same game, same symptoms. ;) Have opened the required ports in Zonealarm, and also forwarded the required ports in my Linksys ADSL Gateway with 4-port switch.
As I said, I'll watch for a positive outcome.
Good luck!! :tazz:
Dave.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP