Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Computer is Running Slower and Hotter After Installing New, Bigger HD


  • Please log in to reply

#1
mstlelc

mstlelc

    Member

  • Member
  • PipPip
  • 48 posts
Please help!!! :)

The following forum is where this starts:

http://www.geekstogo...73#entry1062573
  • 0

Advertisements


#2
Troy

Troy

    Tech Staff

  • Technician
  • 8,839 posts
Hi mstlelc! Interesting read, that Malware thread... I'm glad you didn't permanently lose your data! I strongly suggest you make "extra" backups right now as well, burn everything to DVD's... You can never have too many copies of the important things in life...

Okay I'm going to take a quick stab in the dark, as your system appears to be giving the following symptoms:

Starting from your desktop, right-click on My Computer, select Manage. Once the window opens, from the tree-view on the left select Device Manager. Expand the [+] next to IDE ATA/ATAPI Controllers, then right-click on the channel to which your hard drive is connected and select Properties. Under the Advanced Settings tab, if "PIO mode" is selected, this is your problem as it will greatly reduce the transfer speeds on your computer.

If this is the case, a simple fix is to uninstall your hard drive. Don't worry - it won't ruin anything! I've done this before... Close the [-] next to IDE ATA/ATAPI Controllers and expand the [+] next to Disk Drives. Right-click on the hard drive on which your OS is installed - this would be the C: (80GB) - and select uninstall. Next you should restart your computer, and it will restart and once it has finished logging in, you should see the small "Found New Hardware" bubble in the bottom-right corner and it will "install" your hard drive again.

If this is not the case, just let me know and we can look at some other troubleshooting options for you.

Cheers :)
  • 0

#3
mstlelc

mstlelc

    Member

  • Topic Starter
  • Member
  • PipPip
  • 48 posts
Thanks for the info FPVDriF6. :)

Under Device Manger/IDE ATA/ATAPI controllers/Primary IDE Channel/Primary IDE Channel Properties/Advanced Settings, the Device 0 was correct but the Device 1 was not. The Transfer Mode was listed as POI Only. Question: Why couldn't I just change the Transfer Mode to DMA if Available from this screen; it gives me the option? If I'm correct, my main HD is hooked up to the Primary IDE, Device 0, so this wouldn't be the issue anyway.

Regardless, I uninstalled and reinstalled my main 400 GB HD and its still slooooow.

Any help is really appreciated. :)
  • 0

#4
Troy

Troy

    Tech Staff

  • Technician
  • 8,839 posts
Maybe your C: (80GB) is hooked up to the Device 1 section. Try changing (uninstalling) it too.
  • 0

#5
mstlelc

mstlelc

    Member

  • Topic Starter
  • Member
  • PipPip
  • 48 posts
My main HD (400 GB) is actually hooked up to the Secondary IDE Channel, Device 0. See attached screen prints...

Should my hard drives be on the Primary IDE? They never were before. I used to have a 20 GB as the main and a 8 GB as a backup. Now I have a 400 GB as the main and the 20 GB as the backup. The Primary IDE Device 0 and 1 are the CD-R and CD-RW.

The Primary IDE Current Trasfer Mode is Ultra DMA Mode 2 for Device 0 and 1; CD's.
The Secondard IDE Current Trasfer Mode is PIO Mode for Device 0 and 1; HD's.

Attached Files


  • 0

#6
Troy

Troy

    Tech Staff

  • Technician
  • 8,839 posts
Okay the top picture you sent me is your optical drives (CD's, DVD's), UDMA 2 is the fastest for them, so that's good.

As for your hard drives (bottom picture), both of them are in PIO mode, which is the slowest and is your problem. See where it says "Current Transfer Mode". You need to uninstall both your hard drives and reboot (one at a time). If after this they still settle themselves back into PIO mode (which they shouldn't), then you need to read my thread found here. Two wonderful pages of reading, with answers at the end (obviously).

Let me know what happens. :)
  • 0

#7
mstlelc

mstlelc

    Member

  • Topic Starter
  • Member
  • PipPip
  • 48 posts
I uninstalled both HD's & reinstalled and I have uninstalled the Secondary IDE driver, rebooted and the system reinstalled it but no such luck, the Current Transfer Mode is still PIO Mode for both drives. :)
  • 0

#8
Troy

Troy

    Tech Staff

  • Technician
  • 8,839 posts
I would like you to follow the information in that thread. Run a HD Tune test on them (just a quick one is sufficient), and if they both bring back no bad blocks, try changing the data cables, then try the registry edit listed toward the end.
  • 0

#9
mstlelc

mstlelc

    Member

  • Topic Starter
  • Member
  • PipPip
  • 48 posts
I did run the HD Tune test on them (the quick one) yesterday with no bad blocks found. I will change the data cables now and report back in a few minutes.
  • 0

#10
mstlelc

mstlelc

    Member

  • Topic Starter
  • Member
  • PipPip
  • 48 posts
Nope, it didn't work. In fact, I unplugged the Primary IDE from the 2 CD drives and used that cable to plug into the HD's so now the HD's are on the Primary IDE. The Primary is now in PIO mode and the Secondard IDE is Ultra DMA Mode 2. I will now try the registry edit. :)
  • 0

Advertisements


#11
mstlelc

mstlelc

    Member

  • Topic Starter
  • Member
  • PipPip
  • 48 posts
It still does not work. In fact regedit deleted the line ResetErrorCountersOnSuccess in the 0001 Primary IDE properties; see attachment. What do you make of this? :)

Attached Files


Edited by mstlelc, 09 October 2007 - 08:57 PM.

  • 0

#12
mstlelc

mstlelc

    Member

  • Topic Starter
  • Member
  • PipPip
  • 48 posts
I believe I figured out why it deleted the ResetErrorCountersOnSuccess line. When I uninstalled the IDE driver it will remove this line when it reinstalls upon booting.

PIO is haunting me!!! :)

Edited by mstlelc, 09 October 2007 - 09:55 PM.

  • 0

#13
Troy

Troy

    Tech Staff

  • Technician
  • 8,839 posts
Yes, you would need to keep everything connected. I suggest you reset all the cables to how they were when you began this thread. Don't cross over with the optical drives or anything. Then add the ResetErrorCountersOnSuccess line, save and close Regedit, uninstall your hard drives and reboot.

How does that go?
  • 0

#14
mstlelc

mstlelc

    Member

  • Topic Starter
  • Member
  • PipPip
  • 48 posts
Nope, still doesn't work. I hate PIO. :)

Edited by mstlelc, 09 October 2007 - 10:00 PM.

  • 0

#15
Troy

Troy

    Tech Staff

  • Technician
  • 8,839 posts
Are you able to test your hard drive(s) in a different computer? I'm beginning to think your problem is a faulty motherboard...
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP