Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

External Hard Drive Not Showing up


  • Please log in to reply

#1
cashandbro

cashandbro

    Member

  • Member
  • PipPip
  • 17 posts
Hello, I have a Dell XPS 400 running Windows Vista Home Premium 32bit. I've been using a Western Digital 500gb My Book, as an external Hard Drive. I unplugged the drive from the USB port and when I plugged it back in the drive (g) is no longer there. I've unplugged the power chord, usb chord, tried a different USB chord, updated drivers, uninstalled and plugged it back in. And still nothing.

The Light on the hardrive works, and I can hear it spin. When I plug it in it makes the noise that a device has been plugged in.
I can see it in Device Manager and it says it's working properly.

Under Disk Management it Shows it as Disk 2 with a little red arrow pointing down and lists it as unknown, unreadable. The Western Digital site offers no help. I really hope I haven't lost this info. Any help would be great. I know lots of people have had similiar problems but I can't seem to find any real support.

p.s. It was working fine for about a year until I uplugged it.
  • 0

Advertisements


#2
The Skeptic

The Skeptic

    Trusted Tech

  • Technician
  • 4,075 posts
In disk managment right click the "missing" disk, click properties > tools > error checking > check now. Check the two boxes and click start. This will perform chkdsk command and hopefully will fix the problem. It's a large disk and the process may take a long time to complete.
  • 0

#3
cashandbro

cashandbro

    Member

  • Topic Starter
  • Member
  • PipPip
  • 17 posts
Thank You for the quick reply.

I don't have that option, I get General/Policies/Volumes/Driver/Details.

Here is a snapshot.

Posted Image


I have also tried it without the H drive plugged in, in several different USB Ports. If I plug a Flash Drive in it assigns it as G, instead of I.

Edited by cashandbro, 09 November 2007 - 06:22 PM.

  • 0

#4
The Skeptic

The Skeptic

    Trusted Tech

  • Technician
  • 4,075 posts
Are we looking in the same place? What version of XP are you using (mine is XP pro sp2).

Please go to: control panel > adminstrative tools > computer managment > disk management.

Now, in a previous post you mentioned (quote): "Under Disk Management it Shows it as Disk 2 with a little red arrow pointing down and lists it as unknown, unreadable". If the disk in shown in disk management then right click on it, go to properties > tools etc. If it doesn't work then try the same procedure on a "healthy" disk. Please report the results.
  • 0

#5
cashandbro

cashandbro

    Member

  • Topic Starter
  • Member
  • PipPip
  • 17 posts
Again thanks for the fast response. All the other disk scan just fine. From the picture i've provided you understad that Tools is not an option. A screen shot.

Posted Image
  • 0

#6
The Skeptic

The Skeptic

    Trusted Tech

  • Technician
  • 4,075 posts
I am afraid that we are still not looking at the same place or else there is a difference in our XP versions. Please write down

In my computer the picture you attached show up in: Control panel > system > hardware > device manager > disk drives. When I expand I see the disks, including the USB which is connected to my computer at this moment. When I double click on any of the shown disks I get the window which you pictured, in which "tools" is absent.

Like I wrote before I would like you to look in an entirely different place. Please follow the instructions of my previous post. If you did, and still got the "wrong" window, that's probably related to a difference in our XP versions. That's why I would like you to write down the version which is in your computer.

To find out which xp version you have go to control panel > system. In the window that opens up you will see what version of xp is installed.
  • 0

#7
Neil Jones

Neil Jones

    Member 5k

  • Member
  • PipPipPipPipPipPipPipPip
  • 8,476 posts
The OP is not using XP, see the first post. This is a Vista machine.

This may be a problem with the USB caddy itself. If its possible, are you able to take the caddy apart and temporarily hang the drive off an IDE connector inside the computer to see if it can see it then (on Dells you have to go into the BIOS and set it up ready to find a new drive otherwise it won't see it at all). If it can see it inside the computer, that suggests an issue with your caddy.
  • 0

#8
cashandbro

cashandbro

    Member

  • Topic Starter
  • Member
  • PipPip
  • 17 posts
This is a Vista Home Premium 32bit system. Is there some other steps I could try without taking anything apart?
  • 0

#9
wannabe1

wannabe1

    Tech Staff

  • Technician
  • 16,645 posts
To get the tools option in Vista, go into Disk Management, right click on the drive, and choose "Properties". You should see the "Tools" tab in the properties window.

Try this....Unplug the external drive from the USB port. Open Device Manager, expand "Universal Serial Bus controllers", right click on the USB Root Hubs (there should be two), and choose "Uninstall"....accept the change. Reboot.

When Windows has restarted and the USB Hubs have been reinstalled automatically, plug in the external drive and see if it detects and shows your data.
  • 0

#10
cashandbro

cashandbro

    Member

  • Topic Starter
  • Member
  • PipPip
  • 17 posts
Thanks For the reply.

I don't have a tools option. The Following picture is my Disk Management window. The disk in question is Disk 2 that is listed as Unknown / Unreadable.
Posted Image

If I right click that disk and go to properties I get the following window. There is no tools tab.
Posted Image

I tried uninstalling the USB Root Hubs, rebooted and plugged the drive back in. It still would not work.

Under diskpart, list disk it shows the drive as.... Disk 2 Unreadable 0b 0b. If I select disk 2 and type online, it tells me that the disk is not initialized.

Hopefully that helps some.

Edited by cashandbro, 13 November 2007 - 01:10 AM.

  • 0

#11
pip22

pip22

    Trusted Tech

  • Banned
  • PipPipPipPipPip
  • 2,663 posts
Has it ever worked on Vista? If the answer is 'no' I would say it's a Vista problem and I'd like to bet the drive will work flawlessly on XP. Put my theory to the test. It shouldn't be too difficult to find a friend or relative who's running XP. If I'm proved wrong well at least you know for sure.
  • 0

#12
cashandbro

cashandbro

    Member

  • Topic Starter
  • Member
  • PipPip
  • 17 posts
It was working fine in Vista untill I unplugged it the other day. I tried it in an XP machine and the Machine found new hardware and installed it. But the WD drive did not show up in disk management or My Computer.

Something that may be helpful. If I rescan the disk in diskpart, it shows up in Disk Management as not initialized. However when I right-click on it and select initialize I get an unexpected error. Is there a way to initialize the disk using command prompt?
  • 0

#13
The Skeptic

The Skeptic

    Trusted Tech

  • Technician
  • 4,075 posts
I think that whatever you do with the disk it would be better off to take it out of the enclosure and rig it as an ide device. This will take out the usb and enclosure factor and will put us on more solid ground.

There are many recovery programs in the market and I could offer you some free tools like: Undelete Plus, ADRC Data Recovery, NTFilerecovery, pci filerecovery. I hope this will help you. If not, you may purchase some other tools. It all depends how much money and effort you are willing to spend to save the data.

When the disk is connected as ide, and if by good chance it will be recognised, then you can run check-disk like I suggested before.

If nothing works then I suggest that you reformat the disk while connected as ide device.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP