Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Trouble with drivers.

  • Please log in to reply




  • Member
  • PipPip
  • 98 posts
Hi all. I have recently purchased a new PC. It wasn't up to the task of running Vista, so I installed XP on it. Afer the fresh installation, there were a couple of drivers missing, and I managed to find the video card and sound card online. They are now working fine. However, after looking in device manager, there a couple which still don't have drivers, one being the ethernet port, and the other I'm not sure what it is, here is a pic of it...

Posted Image

Here is the Belarc report and the name of the board......

Operating System
Windows XP Professional Service Pack 2 (build 2600)
System Model : Acer Aspire T180 R01-B3
Enclosure Type: Desktop
Processor a Main Circuit Board b
2.00 gigahertz AMD Sempron
256 kilobyte primary memory cache
256 kilobyte secondary memory cache Board: Acer EM61SM/EM61PM
Bus Clock: 201 megahertz
BIOS: Phoenix Technologies, LTD R01-B3 02/07/2007

Does anyone know how I can resolve this? I think all these things are integrated into my motherboard, if that helps. Could anyone tell me what to do or point in the way of some drivers or something to fix the two problems above? Thank you for reading and for any help, in advance. Let me know if you need further information.
  • 0




    Trusted Tech

  • Banned
  • PipPipPipPipPip
  • 2,663 posts
"SM Bus Controller" means "System Motherboard Bus Controller" (essentially the motherboard chipset), and 'Ethernet Controller' is the Network Card.
Both driver packages are here: http://support.acer-...180.html#driver

For SM Bus driver, select "chipset" from the Windows XP driver list (drop-down list)

For Ethernet Controller driver:
Unfortunately the list is very vague (apart from 'chipset'), as, unlike most other support websites, it doesn,t state what type of device each driver is for. Some are self-explanatory, others are not.
So for your 'Ethernet Controller', after some quick googling, I'm guessing you need "pronet gbe" from the same list, since that's a network card.
But there's also a "Marvel Lan driver" in the same list, and I know that Marvel also make ethernet controller cards. So you made need both these drivers but i doubt it.
More likely Acer have fitted one or the other to the same model at various times depending on what was available at the time. Install the "pronet gbe" driver first and then check Device Manager as well as your network card's functionality. If it still hows an error in Device Manager, remove the pronet driver and download/install the 'LAN_Driver_Marvel_Ver." instead.

Edited by pip22, 14 November 2007 - 06:08 PM.

  • 0




  • Topic Starter
  • Member
  • PipPip
  • 98 posts
Thanks a massive bunch Pip22, your advice was perfect. Works fine, and all drivers installed...thanks again.
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP