Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

DVD Subtitles


  • Please log in to reply

#1
Carlos007

Carlos007

    New Member

  • Member
  • Pip
  • 5 posts
1.8GHz CPU, Win XP Pro machine.
I want to replace English subtitles with Maltese ones. I have extracted an English DVD subtitle via SubRip in the .srt file type. Then I opened the .srt file in Word 2003 and translated it to Maltese.
Maltese uses all the keys of the English (UK) keyboard plus 4 extra characters, c,g,h,z, each with a dot on top, which can be accessed by shortcuts ALT+C, ALT+G, ALT+ H, and ALT+Z. These show correctly in Word 2003 .doc file but NOT when saved as a Plain Text .txt, file as required by programs Subtitle Creator and Subtitle Workshop to recreate the .srt file,for their further processing.
Any ideas ideas as to how to save these 4 characters as a plain text file.
  • 0

Advertisements


#2
Ax238

Ax238

    Tech Staff

  • Technician
  • 1,323 posts
Hello Carlos007,

Wow, what a project! I've tested and found the same situation that you are reporting. This is happening because Word is saving the text file as ANSI encoded, whereas the characters you are using are Unicode. You will have to copy the text from Word to notepad first. Then, when you are saving the text file, choose "Unicode" for Encoding.

Regards,

Ax
  • 0

#3
Carlos007

Carlos007

    New Member

  • Topic Starter
  • Member
  • Pip
  • 5 posts
Hello AX238
I did as you suggested and saved text subtitles to unicode and that’s excellent, however, when I try to import the unicode file in Subtitle Creator or Subtitle workshop both report –“ Error in reading subtitle No1, input string is not in correct format –“. Am I doing something wrong ?
Any further help is appreciated.
Regards

Edited by Carlos007, 12 December 2007 - 08:42 AM.

  • 0

#4
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
http://forum.videohe...opic245188.html <---that's actually got some info on how to do this with unicode text...you've got to make sure your computer is set to use the proper unicode settings etc..
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP