Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Radeon 9800 Pro question

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
MSI K7N2 Delta L motherboard
Athalon 3200xp processor
1 Gig Corsair RAM
Antech 500 Watt Powersupply
and Radeon 9800 pro 128mb.
The problem is that when the powersupply is connected everything turns on, the fan on the card even spins but it blankscreens, but if the powersupply is not connected it goes straight to windows. A power supply incompatability is the only thing I can think of does anyone know what is the problem and how can I fix it?
  • 0





  • Member
  • PipPipPip
  • 169 posts

The problem is that when the powersupply is connected everything turns on

View Post

when the powersupply is connected to what? the gfx card?

are you getting blank screen upon powering on your pc?

its funny that yours boots to windows without it being connected. i get gfx distortion when i forget to plug in the 4prong power connector to the card from the power supply.

it sounds like a defective card.

how long have you had the card? did you buy it new?

check the bios settings for the motherboard in regards to the gfx card. i keep mine at default. (not a fan and never tried to overclock any of my hardware). set them to default if you dont know how it should be.

make sure your card is installed properly, and that your monitor is connected securely.

if your card is a 9800pro, then that power connector is definitely crucial. if i were you i wouldnt try to play any advanced accelerated games until you have hardware setup configuration straight.

check and see if all 4 prongs on the power socket of the card are in good shape. (you may need to replace it)

other than that i dont know.
im assuming that your problem is occuring prior to windows loading.

please be more detailed with your situation
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP