Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

HD does not show in BIOS, but boots

  • Please log in to reply




  • Member
  • PipPip
  • 27 posts
I started in OS Forum, but now I think it might be a hardware issue. I tried adding an SATA HD to my system. During the install, while it was copying my files from my other HD, I quit the installation (very stupid). After that, XP would not boot, my XP install did not show up in XP Repair--I was stuck.

I removed the SATA drive, no change.

I tried unplugging the HD from IDE 3 and moving it to IDE 1 on my mobo. The HD now showed up in BIOS and XP Repair, so I ran XP repair successfully. Now, however, the drive is labeled F:, so I can't update XP (I am in SP1--ugh) or use my software, so I still need HELP.

To try to get my drive called C: again, I unplugged my (now working) HD and plugged it into IDE 3 (the original slot). It does not show up in BIOS there and Repair shows there is no disk present (my original problem). I moved it back to IDE 1, ran repair again, but it is still called F:.

Looking in the manual for my mobo (Soyo Dragon 2 V 1.0), I have four IDE channels (supports 8 drives) and support for 4 SATA drives (12 devices total).

IDE 1, 2 are controlled by the ICH5R chip (southbridge), as are SATA 1, 2.

IDE 3,4 are controlled by the ALi M5281 Serial/Parallel ATA RAID chip, as are SATA 3,4.

My original setup was two DVD drives in IDE 2 and my HD in IDE 3. The SATA HD I was trying to add, I plugged into SATA 3 (same controller chip as my now damaged HD). When I quit the SATA HD setup, I am wondering if I damaged the ALi M5281 chip. Could it be the mobo?

I also tried moving it to IDE 4 last night (same controller chip) and it does not show up in BIOS or Repair, I so I think it is the chip, but I am no expert. Could it be the BIOS? Should I flash the BIOS, or is that not the problem?

I managed to backup my data from my original drive, so my primary concern now is getting my system working again. I still have the SATA HD (which I hope is not damaged). Should I install that?

Thanks for reading this, I really appreciate this site!!
  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP