Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Home Networking and File Sharing problem


  • Please log in to reply

#1
hockey2112

hockey2112

    New Member

  • Member
  • Pip
  • 7 posts
I am having major difficulties setting up a home network through which I would like to share a few folders between my PC and my two laptops.

Here is a diagram of my equipment:

INTERNET===[Cable Modem]---[router]---[Wireless access point] ~~~ (2 laptops)
..............................................||.......................
..............................................||.......................
..................................Home PC (hardwired).......



Home PC: Windows XP Pro SP2
Laptop 1: Windows XP Pro SP2
Laptop 2: Windows Vista Home Premium


Cable Modem: Linksys BEFCMU10
Router: Netgear ProSafe VPN Firewall FVS318
Wireless-G Access Point: Linksys WAP54G

IP Addresses are all as such: 192.168.0.?
Default Gateway: 192.168.0.1
I can ping the default gateway.
I CANNOT ping each individual computer's IP addresses from any of the three computers.




On the Home PC, I used the Network Setup Wizard. I selected the following options:

"This computer connects to the internet through a residential gateway or through another computer on my network."

Computer description: GPM-PC
Computer name: GPM-PC

Workgroup name: GPM-HOME

Turn On file and printer sharing


I then used the same settings on Laptop 1 and Laptop 2.


I then clicked Start> My Network Places on Home PC. I then clicked "View workgroup computers", expecting to see the two laptops listed therein (I confirmed that they were both given the same Workgroup name, GPM-HOME). To my surprise, I was greeted with the following error message after 10-15 seconds of hang: "Gpm-home is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions. The list of servers for this workgroup is not currently available". I checked my permissions; I am logged in as "Peter", which is a member of the Administators group. Why would I "not have permissions"?

I next navigated to a folder that I wish to share. I right-clicked it, selected "Sharing and Security", and checked off the box labeled "Share this folder on the network". I then revisited "My Network Places", where the folder is now listed. I can click into it, etc.

I then tried accessing My Network Places on Laptop 1. It does not list this shared folder from Home PC. I then clicked "View workgroup computers" on Laptop 1, and it gave me the same error message that I listed above. Again, I confirmed that Laptop 1 has the same exact Workgroup name as Home PC.

I next tried accessing "Network" on Laptop 2 (Vista). It now correctly displays itself in that view, listing it as a member of the Workgroup "GPM-HOME", which is correct. I can click on its icon and browse the shared folders with ease, but only from that very laptop; again, I cannot access any Workgroup computers from Laptop 1 or Home PC.

I tried many different things to get this to work, to no avail. Can anyone here point me in the right direction? I am a networking idiot, so hopefully I am just missing something somewhere, doing something out of order, etc. I am open to trying most anything to get this feature to work correctly.

Thanks for your time.

Peter

Edited by hockey2112, 08 February 2008 - 04:28 PM.

  • 0

Advertisements


#2
peterm

peterm

    Trusted Tech

  • Technician
  • 3,173 posts
Hi Hockey2112
You have not listed if they all have the same subnet mask.
You seem to have a lot of modem router equipment for something that should be basic !
Ok the 1st step I would look at is go to the modem and make sure it is set to be a dhcp server.
Then check on the other 2 pieces and see if they are set to dhcp servers if so I would turn dhcpserver off on them both but allow the to receive the address via dhcp.
they should then pick up an address from the modem. This is accessed via the web page, you type in the address of the equipment eg 192.168.0.1.
then do an ipconfig on all 3 computers have they the same ip,subnet and gateway.

Cheers
Peterm
ps
is there a reason for having so many bits of equpiment?
  • 0

#3
hockey2112

hockey2112

    New Member

  • Topic Starter
  • Member
  • Pip
  • 7 posts
I was actually ale to get it working this morning...

I disabled the Windows firewall on Home PC and Laptop 1, leaving the AVG firewalls on. I was able to ping Laptop 1 from the C prompt on Home PC, but I could not ping Home PC from the prompt on Laptop 1. I disabled Home PC's AVG firewall (i.e., no firewall turned on at all), and was able to successfully ping it from Laptop 1. I then reactivated the Windows firewall on Home PC, and was still able to ping it from Laptop 1. I checked the firewall settings on both Home PC and Laptop 1 for AVG, and they both seem to be identical. Therefore, I now have the following settings enabled, and am successfully pinging away happily:

Home PC: Windows XP firewall
Laptop 1: Windows XP firewall
Laptop 2 (Vista): Windows Vista firewall (I disabled Norton's firewall; it was not allowing pinging to occur)

So I can now ping successfully between all three computers!

I decided to try to get sharing working since I could now ping. Long story short, it works now, and extremely well at that! I am very excited! Thanks for your help... I can't believe it was just a firewall issue!
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP