Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

D:\1386\asms. Error

  • Please log in to reply




  • Member
  • PipPip
  • 13 posts
D:\1386\asms. Error i try to install a win xp on my pavillon 9795c and got stuck at that point
any help please
  • 0




    motto - Just get-er-done

  • Technician
  • 4,345 posts
With no other information that you give it could be a number of problems. A dirty CD or a bad spot on the CD can cause this. A dirty lens on the cdrom drive can also cause it. I have read where a bad stick of memory caused this problem. This can be caused by using a burned copy of a Microsoft XP CD. A USB mouse can cause this problem.

Can you use another computer to copy the 'i386' folder to a cd, then manually point the setup program to the files on the cd. You can switch CD's and point to the files on the cd and then switch back to the XP CD.

From another forum, a fix that has worked.

Follow the Microsoft instructions fron the "support/microsoft" link above, but do the things that microsoft DID NOT tell you.

Forget disconnecting drives or trying 'older' CD-ROMS.

When the "File 'asms'... " problem occurs, press 'SHIFT F10' for DOS

Type regedit.exe then 'Enter' key

Scroll down and click to highlight HKEY_LOCAL_MACHINE (must be highlighted!)

Up top L/H side click 'File', then click 'Load Hive'

A window box will appear and, in there, type

%Windir%\System32\Config\System.sav click 'Enter'

When prompted for a name, type Test

Locate and then click the following key:

Delete the UPPERFILTERS and LOWERFILTERS registry keys by left click highlight, right click 'delete' + (are you sure) buttons.

You may have to do this again if there are any "..\Test\Controlxxx\control\Class" entries apart from ..ControlSet001\

Either way, up top left click 'File' , then click 'Exit'

The Microsoft site says the following:................................

If the path in the error message is the correct drive letter for the CD-ROM drive, click OK to continue the Setup program. ..................................................

I did not find that this worked, so I just "Cancel" 'd out and the system restarted in the setup as before "" DO NOT PRESS ANY KEYS "" Wait until Setup does it's work: it gets to the same point, but now, with the registry key changes, it will recognise the CD/DVD ROM drive.

  • 0



    New Member

  • Member
  • Pip
  • 1 posts
I just tried the fix posted by SRX 660, and it worked perfectly for me. I was worried at first because I didn't have the registry value HKEY_LOCAL_MACHINE\Test\ControlSet1\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}

I didn't have Test\ControlSet1\
but I did have set 003 and 004 so I skipped down to those and I deleted upper and lower filters, exited the regedit and canceled out on the install and let it start over on its own and everything went swimmingly.

Thank you soooo much for the helpful information, and I'm sure the hair I was pulling out will be able to start growing back in!!
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP