Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Autostart and Msconfig


  • Please log in to reply

#1
Rickles

Rickles

    Member

  • Member
  • PipPipPip
  • 481 posts
Hi,

Two problems here:
Autostart
Although CDs and DVDs are not autorunning there is a lot more activity than before. Cursor flahes and green light on DVD drive flickering but doesn't quite make it into autostart. All the settings are correct.

Msconfig
After typing in Msconfig a message comes up saying that Windows cannot find it.
I have tried Search but no joy there either... :)

Regards.
  • 0

Advertisements


#2
The Skeptic

The Skeptic

    Trusted Tech

  • Technician
  • 4,075 posts
Use this link to download msconfig.exe. Run and install it to repair your present msconfig installation.

Regarding the cd drives: You cannot disable autoplay from the user interface. This can only be done by changing values in the registry. Have a look at this Microsoft article for details.
  • 0

#3
Rickles

Rickles

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 481 posts
Hi,

Thank you for your reply.

I have downloaded the msconfig program and the info on autostart.
I will try them tomorrow as it is now 22.57hrs here in Australia

Regards
  • 0

#4
Rickles

Rickles

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 481 posts
Hi,

Downloaded the msconfig and all is well on that problem.

Regarding the autostart I followed the instructions from Microsoft but no go as yet.

Photos attached
[attachment=19054:Windows_1.jpg]

[attachment=19055:Windows_2.jpg] in Item 2 the value was on 1

Regards
  • 0

#5
happyrock

happyrock

    Tech Moderator

  • Retired Staff
  • 9,285 posts
that screenshot shows you went to the wrong part of the registry...read the very bottom line
if/when you follow the right path the bottom line will match the path in the instructions...
you have got to extremely careful playing in the registry or you can crash your system to the point of having to do a complete reinstall...get yourself up to speed on backing up the registry BEFORE doing anything else would be my advice
  • 0

#6
Rickles

Rickles

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 481 posts
Hi,

To start again this is the registry setting for the cd rom as per the instructions from Microsoft.
1/ [attachment=19073:1.jpg].

In the instructions it states:
Additional Information
There are two other registry keys that can affect this functionality:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
NoDriveTypeAutoRun = 0x00000095

-and-
HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
NoDriveTypeAutoRun = 0x00000095
The correct value for each is 0x00000095.
This is what shows on my computer.
[attachment=19074:Windows_1_1_.jpg].

Every time I go near the Registry I always back up first.

Regards
  • 0

#7
Ztruker

Ztruker

    Member 5k

  • Technician
  • 7,065 posts
Try the MS Autoplay Repair Wizard.
  • 0

#8
Rickles

Rickles

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 481 posts
Hi,
I downloaded and tried the Autostart Wizard.

It got the USB autostarting but when I tried the same program with the CD and DVD drives I got this at the end of the log


Result: This AutoPlay setting cannot be fixed. Either the device is malfunctioning, or the wizard cannot determine the problem.

>> Required action: The wizard found problems but cannot fix them -> None

Regards
  • 0

#9
Ztruker

Ztruker

    Member 5k

  • Technician
  • 7,065 posts
Open Device Manager, expand the CD/DVD section. Right click on each drive and uninstall it.
Shutdown and reboot. XP will find the drives and reload the drivers. That may fix it.

If not, Google gets lots of hits searching for Required action: The wizard found problems but cannot fix them -> None.

Some people had success uninstalling Alcohol 120%, SPTD and even Daemon Tools. Do you have any of these installed?
  • 0

#10
Rickles

Rickles

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 481 posts
Hi,

I uninstalled both CD and DVD according to your instructions but although the drives seem to be making more of an effort to start they just don't make it into full autorun.

I followed the link to the Google search and I am slowly working my way through the checklist. I will be a bit slow on this as I hate going near the registry.

But I do back up the registry so I will have something to fall back on if I make a major stuff up.

Regards
  • 0

Advertisements


#11
Rickles

Rickles

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 481 posts
Hi,
Back again.
I've tried all that I can find on Google but nothing helps.

But at least the USB drives will autostart.

Regards
  • 0

#12
Ztruker

Ztruker

    Member 5k

  • Technician
  • 7,065 posts
Look here: http://www.soniacole...Qs/FAQ00158.htm
  • 0

#13
Rickles

Rickles

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 481 posts
Hi,

I had a look at the site and tried the 'fix' but no go. I am trying to follow Microsofts fixes but have struck a problem.

It says.... Look at the value of the NoDriveTypeAutorun entry (in the registery) Right Click NoDriveTypeAutorun, Click Modify, type 91 in the Value data box, select Hexadecimal and OK.

However what I got was:
[attachment=19399:1.jpg] is the NoDriveTypeAutorun entry
[attachment=19400:2.jpg] is the 'box' that popped up
That does not look like the right box.

I always backup the registery before going into it but I stop when I cannot figure out what to do.
Regards
  • 0

#14
Ztruker

Ztruker

    Member 5k

  • Technician
  • 7,065 posts
The key is defined wrong. it should be REG_DWORD ...

[attachment=19407:NoDriveTypeAutoRun.gif]

Delete the key, create a new REG_DWORD with the exact spelling shown and set the value to 91.
  • 0

#15
Rickles

Rickles

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 481 posts
Hi,

Ok I did that.

Still won't autoplay BUT the little cd comes on with the cursor and it's just shy of starting.

You are on the right track.

Regards
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP