Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Why Does IE 7 Always Open With A Microsoft Home Page?


  • Please log in to reply

#1
superstar

superstar

    Member

  • Member
  • PipPipPip
  • 716 posts
Every now and than when I use internet explorer 7 it shows the following microsoft update page telling me that IE 7 is available when I already have it and am using it when it shoes this:

Posted Image

My homepage is www.google.com not that thing. Whenever that page shows up and I click the home button it goes to google. But like I said every other day it comes back and shows that above as my home page. Why is this happening and how can I fix it? I'm using IE 7 so why keep bothering me about updating to IE 7? I don't get it microsoft... & yes google.com is set as my default homepage in my tools/options. The page above is coming from this address: http://www.microsoft...e/getitnow.mspx
  • 0

Advertisements


#2
natkay2603

natkay2603

    New Member

  • Member
  • Pip
  • 3 posts
Have you tried running the update? or reinstalling IE7?
  • 0

#3
superstar

superstar

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 716 posts
No I haven't, and I shouldn't have to. Someone said this to me through an msn conversation:

Strange. If you have IE7 already that should not be happening. It is possible that some other security program (and you could check in SpyBot's Tools > 'Browser Pages' and 'IE Tweak' to see if you have a setting there that has locked that in.
Likewise with Spybot's 'TeaTimer' *if* you use it, that could be the culprit too.

However, other users have fixed it as has been reported with this registry fix:

"I changed the registry. [HKEY_CURRENT_USER\Software\Microsoft
\Internet Explorer\Main]
"First Home Page"="http://www.google.com/"

If the above does *not* stick after a reboot then it is almost certain you have some security program overriding it.

Of course you could just stop using IE altogether.


But I just don't feel comfortable with registry tweaks...
  • 0

#4
Ztruker

Ztruker

    Member 5k

  • Technician
  • 7,065 posts
If you export the key before you change it then it's safe to do this. Import it back if you have a problem.

Or install ERUNT. Let it add an entry to startup then each time you boot it makes a full registry backup. Only takes a few seconds and has no visible impact on boot performance. If you make a registry change that causes problems, you can fix it from Safe Mode or the Recovery Console by running the appropriate erdnt.exe from C:\Windows\ERDNT. Makes registry hacking pretty bullet proof.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP