Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Dell laptop thinks all USB flash drives are unformatted

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
My Dell Latitude D620 (XP SP2) seems to think all USB flash drives are unformatted -- started after I began hibernate process, and pulled out flash drive before hibernation was complete.

I get the classic "Drive E: is unformatted; do you want to Format now?" but every time I say "yes" and try to format, XP tells me formatting didn't work.

Figuring that I'd killed the flash drive, I went and bought a new one (after having read lots of stuff on-line about folks having trouble formatting USB flash drives -- but all seem to focus on the flash drive being the problem) -- same problem with the new flash drive.

Silly me, before buying a new drive, I should've tried the old one in other computers -- sure enough, have tried BOTH flash drives on three or more computers (desktops running XP, one running Vista) and they work fine in all three.

Plus, I've tried every other type of USB device I own (external hard drives, printers, digital cameras, etc.) and they all work fine in all four USB ports. Also, all my other drives and devices still work fine. Windows recognizes that I've plugged in a USB flash drive, and even gives it a drive letter -- but it thinks the format is RAW and the drive needs to be formatted before use....

Pseudo-Geek's conclusion: It's clearly NOT the flash drives, and it's clearly NOT the USB ports, so it's gotta be something in WINDOWS that is hosed up -- am I right, or is there something I'm missing?

Have found nothing on Windows support sites to help...

Anyone have any ideas?

Thanks in advance.
  • 0




    motto - Just get-er-done

  • Technician
  • 4,345 posts
First, have you tried updating the USB drivers in device manager? Do not auto update but see if you can manually reinstall the original USB drivers.

You might also look into this website, about 3/4 down, at the "USB Drive not working stable"


Microsoft also has a USB Flash driveManager software that may help.


Micorsoft suggests removing USB drivers and reinstalling.

Remove and reinstall all USB controllers
To remove and reinstall all USB controllers, follow these steps:
1. Click Start, click Run, type sysdm.cpl in the Open box, and then click OK.
2. Click the Hardware tab.
3. Click the Device Manager button.
4. Expand Universal Serial Bus controllers.
5. Right-click every device under the Universal Serial Bus controllers node, and then click Uninstall to remove them one at a time.
6. Restart the computer, and then reinstall the USB controllers.
7. Plug in the removable USB storage device, and then test to make sure that the issue is resolved.


Now i tried the above on a similar problem with the IDE/ata atapi drivers on a compaq computer. It did fix the original problem, but for a monthi was getting a error on startup about the IDE drives. One day it just fixed itself( i don't know how).

  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP