Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Windows XP Pro Won't Boot, Blinking _

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 3 posts
Yesterday, after resizing my NTFS partition to take up the whole disk, I couldn't boot windows. Here is the full story...

Wanting to free up some space for DVD editing, I decided to temporarily remove Ubuntu (it was the old version anyway so I was planning to do this to upgrade later). First, I tried to copy all of my documents/pictures that I had in the linux partition over to my NTFS partition. Unfortunately, there wasn't enough space. So I enlarged the NTFS partition to accommodate the extra files and copied them over. No problems.

Next, I opened up GParted (I have been doing all of this from a verified Ubuntu 8.04 LTS cd from Cannonical) and set it to delete the "extended" and "logical" partition of the linux swap (which I deactivated prior to deleting, via GParted) as well as the main linux partition with Ubuntu in it. Then I set the NTFS partition to grow and fill up all the space in the drive.

The deletes went without errors, and so did the read-only grow for the NTFS partition AND the "real" grow. Errors appeared when it ran what I presumed to be a linux version of CHKDSK. I thought that it was odd, since this has never happened before. Some of the information it provided was that the drive was "Busy" and any modifications would "not be recognized by linux."

I left the live CD and tried to boot XP. I got a GRUB Error 22. I have gotten this before, and it didn't bother me. I brought out my trusty Super GRUB disk and reverted the bootloader to the default Microsoft one. I restarted and got only a blinking _ that never went away, and nothing else on the screen.

Puzzled, I pulled out my XP Pro disk, fired up the recovery console, and ran CHKDSK. It found errors. Rebooted... same thing.

Getting worried, I tried fixmbr... then fixboot... then tried booting using the GRUB disk... same thing. I tried activating the partition using the GRUB disk (I couldn't find the option in the recovery console) still no luck. All through this I have run CHKDSK several times- all forced even though it "seemed in good condition". At some point in time, during a reboot, I made some progress... there is now a message (Error booting operating system) before the blinking _.

I just checked the diskpart utility in the recovery console and have found that there is suddenly 40 GB of free space! That can't be good... (the quick-check said the partition was still "fine").

As of before the new 40 GB of free space, I could still access all of the files without a hitch in Ubuntu- though I dared not touch them. I am going to verify that and see what GParted has to say about this...

But after this I am totally out of ideas. I have run into many a boot problem before, but this is far stranger than anything I have encountered before.

I am getting desperate have an awful feeling that I will have to salvage my data and reformat. *groan* What a way to start summer vacation...

If anybody has any idea of what I can do.. PLEASE post. I have tried posting in the ubuntu forums, but nobody has responeded in 24 hours. (Which is really weird for that forum.) Seeing as you guys have resolved problems like this before, I was hoping someone with more experience would be able to help me here. (However, all suggested that I make a new thread, so here I am.)


UPDATE: GParted has just confirmed that I now have 39.68GiB of free space... that wasn't there an hour ago. The other partition seems okay- but I am terrified of doing anything as I am afraid I will screw the whole thing up now... I haven't even mounted it. But I have just noticed something... the option to mount it calls it a "117GB" drive, when it is really a 150 GB drive... and what survived of the partition is only 109.37GB! :) :)

Edited by Ian505, 08 June 2008 - 06:44 PM.

  • 0




    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts
Found a project called TestDisk which was on the "Ultimate Boot CD" (version 4.1.1, latest) and ran that. I ran a "deep analysis" of the disk and it came up with 3 partitions:

1. NTFS - started at 0 - Current Status: Deleted
2. NTFS - started at ### - Current Status: Deleted
3. Linux SWAP - Started at ### - current status: logical

I wanted to have the first one the primary boot, which was basically the expanded 2nd one. And I didn't want the SWAP at all. So I deleted the SWAP, left the 2nd NTFS, and changed the first one to primary boot. No luck... not even "Error Booting Operating System" this time. Just the blinking _.

I am wondering... since the SWAP semi-survived... is there some sort of rhyme or reason to how you are supposed to handle SWAP logical/extended partitions?


EDIT- Reply in other forum stated that you can simply remove SWAP. Everyone in the other forum has been saying to do a repair install, but that is NOT what I want to do as I am pretty sure that will overwrite the registry (if I am not mistaken) and all of the software keys in there will be lost- which isn't much better than reformatting and reinstalling!

EDIT2: Someone in another forum suggested that I use Knoppix to try and (backup and) recover the bootsector, though I haven't gotten around to it. Here is the link: http://codeidol.com/...er-Boot-Record/

Edited by Ian505, 15 July 2008 - 10:01 AM.

  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP