Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Vista and iTunes store not working

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
My other laptop crashed and had to be replaced...iTunes and the store worked great there. Now, I cannot access the iTunes store at all...I get a message that states "could not connect, timed out". I have literally spent over 18 hours either troubleshooting on the net, deleting applications and programs, and another 7 hours on the phone with Apple and my ISP. NOTHING is working...I mean nothing. I no longer have a firewall, no longer have Norton. Can someone please help me before I put the computer in the trash!! Thanks!
  • 0




    BSOD Warrior/Computer Surgeon

  • Technician
  • 2,854 posts
Hello and welcome to geekstogo.

What have you done to fix this issue?
  • 0



    New Member

  • Member
  • Pip
  • 3 posts
Hi I'm having the same issues. I've tried:

-turning off the windows firewall
-uninstalling AVG
-uninstalling itunes
-re-installing itunes
-changed the "host" drive to "backup-host"
-Go to itunes. By default, it installs to c:\program files\itunes. (the shortcut link will not work).
Right click on the file, and go to properties.
Click on the compatiblity tab.
Click on the checkbox for run this program in compatiblity mode for:. By default it will go to Windows XP (Service Pack 2). That is fine.
Click ok, and then run Itunes. That allowed us to access the Itunes store.
-Open up the "Internet Options" control panel
Click on the "Connections" tab
Click "LAN Settings"
Uncheck all of the boxes

I'm stuck please help!!!!!
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP