Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Firefox not viewing correctly


  • Please log in to reply

#1
Pianoman16

Pianoman16

    Member

  • Member
  • PipPipPip
  • 183 posts
The other day, out of nowhere, Firefox started to show me the websites that I routinely visit, in a new light. I go to Google, and the words are missing from the buttons. This isn't the only site, there were a few others. More annoying, drop down boxes are shown as a long list taking up the entire page and I'm not able to click on the text or anything. This is fine, I can deal til Firefox updates or it fixes itself so I use Internet Explorer in the mean time (which by the way works completely fine, Opera too). I got to check Firefox the next day, my homepage is missing all images and content except for text. I try reinstalling flash thinking that's it, I tried reinstalling Firefox, got nothing. I honestly have no idea what the cause is and how to fix it, I included some pictures as an aide. If anyone has the slightest idea could you please help. Thank you.

Attached Thumbnails

  • Comcast.jpg
  • facebook.jpg
  • focus.jpg

  • 0

Advertisements


#2
coachwife6

coachwife6

    SuperStar

  • Retired Staff
  • 11,413 posts
Try clearing out your cache. Shutting down firefox and opening it up again. This happens to me periodically.

Go to tools, options, clear private data. Make sure cache is checked.
  • 0

#3
==SpuD==

==SpuD==

    Member

  • Banned
  • PipPipPip
  • 691 posts
At the top go to View, then scroll down to page style,

Then select Basic page style from the list

Hope this helps!

SpuD

Edited by ==SpuD==, 29 July 2008 - 08:04 AM.

  • 0

#4
Pianoman16

Pianoman16

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 183 posts
Unfortunately neither suggestion worked. Thank you both for the input though, I greatly appreciate it. The odd thing is that my homepage (comcast.net) works fine now, but the other site I mentioned are still the same. It's odd how only one is now fixed.
  • 0

#5
==SpuD==

==SpuD==

    Member

  • Banned
  • PipPipPip
  • 691 posts
Try the websites on a different browser to see if its the website or FF,
  • 0

#6
Pianoman16

Pianoman16

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 183 posts
I have done this. Everything views correctly in Internet Explorer and Opera, it's only Firefox thats affected. This is killing me because I prefer to use Firefox because it's so much better but Im forced to use IE for now.
  • 0

#7
Major Payne

Major Payne

    Retired Staff

  • Retired Staff
  • 5,307 posts
Try creating a new Profile for Firefox or for a total repair:

Closing Firefox:
* Press Ctrl + Shift + Esc (or ctrl + alt + delete) to view Windows's Task Manager.
* On the "applications" tab, make sure Mozilla Firefox isn't open. (Note: The name of the website will precede "Mozilla Firefox.")
* If you find any instances open, right-click it and select "end task."
* Click on the "processes" tab and look for "firefox.exe."
* If it is present, right-click it and select "end process." It will pop up with a notice/warning...click "yes."
* Click the "X" to close Windows Task Manager.
--------------------------------------------------------------------------------------------------------------
Uninstalling Firefox:
* Go start->control panel->add/remove programs.
* Select Firefox, and remove/uninstall it.
* Click the "X" to exit add/remove programs.
--------------------------------------------------------------------------------------------------------------
Removing the Remnents of Firefox:
* Double-click "My Computer" and go to "C:\Program Files". From there, delete the Firefox (or "Mozilla") folder.
--------------------------------------------------------------------------------------------------------------
Firefox Profile folder:
* The location of this folder varies based on your operating system.
* Note that "username" is your Windows username.
* Note that "random characters" is actually a series of random characters.
* The Application Data/AppData folder is hidden by default. To view it, you must go Tools->Folder Options, select the View tab, and select "show hidden files and folders" before proceeding. (Vista users can press the Alt key to temporarily display the File menu.)

Windows Vista:
C:\Users\username\AppData\Roaming\Mozilla\Firefox\Profiles\random characters.default

Windows 2000/XP:
C:\Documents and Settings\username\Application Data\Mozilla\Firefox\Profiles\random characters.default

Windows 95/98:
C:\WINDOWS\Application Data\Mozilla\Firefox\Profiles\random characters.default

Linux:
~/.mozilla/firefox/random characters.default

Mac OS X:
~/Library/Application Support/Firefox/Profiles/random characters.default
--------------------------------------------------------------------------------------------------------------
Backing up your bookmarks/favorites:
* Go to your Firefox Profile folder.
* Right-click bookmarks.html (displayed as just "bookmarks") and select "copy."
* Go to your desktop, right-click it, and select "paste."
* Repeat for "bookmarks.bak".
--------------------------------------------------------------------------------------------------------------
Deleting your old profile:
* Go back to your Firefox Profile folder.
* Delete the folder "random characters.default".
--------------------------------------------------------------------------------------------------------------
Reinstalling Firefox:
* Launch the Firefox installer and proceed to install the latest version of Firefox.
* A new profile folder will be automatically created for you. (It will be a different series of random characters.)
--------------------------------------------------------------------------------------------------------------
Restoring your favorites/bookmarks:
* Go to Firefox Profile folder and open the new folder.
* Delete the bookmarks.html and bookmarks.bak files you find there. (**Make sure Firefox is not running at this point.**)
* Copy and paste the old bookmarks.html and bookmarks.bak files from your desktop into that folder.
* The default favorites have now been deleted.
--------------------------------------------------------------------------------------------------------------
Verification:
* Launch Firefox.
* Verify that your bookmarks are in tact.
* Verify that there is no lingering corruption.
--------------------------------------------------------------------------------------------------------------
Finishing Touches:
* Redownload the desired themes/extensions again, one at a time.
* After installing one, close and relaunch Firefox to make sure it is not responsible for corruption. If everything's OK, continue on.
* Modify your settings (tools->options) any way you like to customize your browsing experience.

Ron
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP