Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Firefox is running slow


  • Please log in to reply

#1
MVV

MVV

    Member

  • Member
  • PipPip
  • 87 posts
Like the topic title says, Firefox is running slow for me. I could use some help, in fixing this problem.
  • 0

Advertisements


#2
starjax

starjax

    Global Moderator

  • Global Moderator
  • 6,591 posts
what version of firefox are you running? have you tried launching firefox in safe mode (start menu, mozilla firefox, firefox safe mode).
  • 0

#3
vorybory

vorybory

    Member

  • Member
  • PipPip
  • 58 posts
How many add ons do you have running in the background? If you disable some does the speed increase?
  • 0

#4
MVV

MVV

    Member

  • Topic Starter
  • Member
  • PipPip
  • 87 posts

what version of firefox are you running? have you tried launching firefox in safe mode (start menu, mozilla firefox, firefox safe mode).


I guess I have the last version of it before 3 became available. And in safe it's a lot faster.

How many add ons do you have running in the background? If you disable some does the speed increase?


Honestly I don't know.

Edited by MVV, 05 August 2008 - 02:26 PM.

  • 0

#5
vorybory

vorybory

    Member

  • Member
  • PipPip
  • 58 posts
Then the likely hood is slim to none but let's try just in case.

Okay, I'm running 2.0.0.16 so the keyboard shortcuts may be different but hit (Ctrl+shift+A) when Firefox is opened and see if there are any add ons running in the background.

I'm also wondering if your cache needs to be cleaned out. That may be the real cause.

Edited by vorybory, 05 August 2008 - 02:59 PM.

  • 0

#6
MVV

MVV

    Member

  • Topic Starter
  • Member
  • PipPip
  • 87 posts
The only add-ons I have are AVG Safe Search, AVG Security Toolbar and Talkback.

To clear the cache, you go to Tools and clear private data right? I've already done that and it did nothing.
  • 0

#7
vorybory

vorybory

    Member

  • Member
  • PipPip
  • 58 posts
Try disabling just AVG Safe Search and AVG Security. These two add ons may be causing Firefox to fuss. You'll only know unless you try.
  • 0

#8
MVV

MVV

    Member

  • Topic Starter
  • Member
  • PipPip
  • 87 posts
That appears to have done the trick. Thanks a lot.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP