Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Logitech X-240 Buzzing Noise


  • Please log in to reply

#1
dudefromjapan

dudefromjapan

    Member

  • Member
  • PipPip
  • 39 posts
Hey I just bought a Logitech X-240 speaker system and I'm getting a buzzing noise when I plug it into my laptop. I also plugged it into my zune and get the same buzzing noise from the speakers. Even with the volume on low the buzzing noise can still be heard clearly. It's not much of a problem when there's music playing, but when nothing's playing it's quite a nuisance. Help is very much appreciated. Thanks :)

Edit: Oh btw I'm on 64bit Vista. I got a new laptop which I'm using now so don't mind the left info bar XD
Another Edit: I located the source of the buzzing. When i disconnected my power adapter for my laptop, the buzzing went away. So how can I make it so that the buzzing won't persist when charging my laptop battery? Thanks again.

Edited by dudefromjapan, 03 January 2009 - 09:18 PM.

  • 0

Advertisements







Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP