Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Word 2007; How to disable date suggestion


  • Please log in to reply

#1
Webslinger

Webslinger

    Member

  • Member
  • PipPip
  • 36 posts
Hi,

Firstly a happy and healthy new year to all.

Secondly a question about Word 2007;
I have a standard lay-out for some ducument, in one of those lay-outs I end a sentence with a number.
Depending on the number, Word sometimes 'thinks' I'm trying to type a date and it suggests a way to complete that date.
That wouldn't be a problem where it not that I have to press enter to go to the next line...result: I get the suggested date at the end of the line and have to go back and correct it.

I can't find a way to switch this off, who knows how to do this?

TIA

Webslinger
  • 0

Advertisements


#2
Vino Rosso

Vino Rosso

    Visiting Staff

  • Visiting Consultant
  • 235 posts
All the best for 2009.

I think things are different in Word 2007 in that there is no option to turn off AutoComplete via the menus.

This should solve the problem.

On the Developer tab, in the Code group, click Record Macro
In the Macro name box, type a name for the macro e.g. TurnOffAutoComplete
In the Store macro in box, click the template or document in which you want to store the macro
Important: To make your macro available in all documents, be sure to click Normal.dotm
Click Create to open the Visual Basic Editor
Copy and paste the following:

Application.DisplayAutoCompleteTips = False

Click File > Close

Back in Word, on the Developer tab, in the Code group, click Macros
In the list under Macro name, click the macro TurnOffAutoComplete
Click Run

Any good?
  • 0

#3
Webslinger

Webslinger

    Member

  • Topic Starter
  • Member
  • PipPip
  • 36 posts
Thanx

It looks like this solves my problem.

Have a nice day.
Webslinger

Edited by Webslinger, 07 January 2009 - 06:36 AM.

  • 0

#4
Vino Rosso

Vino Rosso

    Visiting Staff

  • Visiting Consultant
  • 235 posts
:) You're welcome.
  • 0

#5
Southeaststanger

Southeaststanger

    New Member

  • Member
  • Pip
  • 1 posts
Nice fix.
One question I have are about the old documents that the automatic date was used when they were created.
Is there any way to stop the date from updating on these documents when opened? The problem I have is when I need to print out old documents showing dates they were created I can't with this wonderful option. I really can't use the last date the document was saved because someone may have went into the document and saved it by accident when closing it, see my dilemma. PLEASE:help:
  • 0

#6
rivardau

rivardau

    New Member

  • Member
  • Pip
  • 1 posts
Hi
there is a much more simpler way to accomplish this task to disable automatic date suggestion and insertion.

you do not need to create macros or nothing complex - just points, clicks, and pastes functions.

but you must follow the directions - there is NO way you will really find this on your own.

Please follow these steps:

1. Open Word 2007

2. Look for the Developer tab on the menu bar - if you see it, skip down to step 4.

3. (if you do not see developer tab, you need to turn it on. it is off by default)
3a. Click on the Office Button on the upper left corner
3b. Click on the Word Button at bottom of dialogue box
3c. The top tab, "Popular" probably is highlighted - or else click on it if needed
3d. Put a checkmark in the 3rd item, "Show Developer Tab in the Ribbon"
3e. Click "ok" button at bottom of dialogue box

4. Click on the Developer tab

5. On the ribbon, look for the "code" section (probably at the left-most side) and see icon for "Visual Basic"

6. Click on Visual Basic icon

7. In the MSVB frame, look at menu bar, click on "View", then "Code" on the dropdown menu.

8. A dialogue box opens.

9. Copy this text:
Application.DisplayAutoCompleteTips = False

10. Click inside the white "document1" box in MSVB frame, and paste the copied command.

11. Close this box. It is saved, there is no extra buttons, no macros, no nothing else to do.

12. Close MS Word 2007 to finalise the changes. This will automatically close MS Visual Basic frame as well.

13. Reopen MS Word 2007.

14. Voilà, no more auto-date
  • 0

#7
Benjazen

Benjazen

    New Member

  • Member
  • Pip
  • 1 posts
So I think I followed exactly but the autodate remains. No viola. :(

I may have put the command [step 9] in the wrong place; so I may need help with step 10. To be clear, the command is to be pasted into the dialog box which appears in step 8?

I've attempted this with existing documents as well as opening Word via the start menu, in a new document. In the latter case, I was prompted to save Document1, which I did to the desktop. Then when I open an existing document again, it still autodates.

I even tried it again and added saving [Ctrl+S] after pasting the command into the step 8 box, then closing the document- but that didn't do it either.

If anyone still has their ears on, I'd appreciate some help on this. The last entry to this thread is 2 1/2 years old now.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP