Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Remote Desktop help needed


  • Please log in to reply

#1
whoelseisbored

whoelseisbored

    New Member

  • Member
  • Pip
  • 3 posts
Hi. :)

I've been having some incredibly annoying problems with using my PC as a server/host for remote desktop. It simply wont connect.

This is my system/hardware...
- Netgear DG834GT Super ADSL Wireless Router
- Windows Vista Business 32bit
- Standard Windows Firewall
- AVG Anti-Virus 2008

Network Map
http://s5.tinypic.com/2yuit06.jpg

What I have tried already....
- I have enabled the ability to use remote desktop on my machine.
- Port forwarded 3389 to my internal ip.
- Set up a DMZ on my internal ip.
- Disabled all software firewalls (only had Windows Default).
- Created a DynDNS.org account and installed the updater.
- Tried disabling NAT (lost me all connection to internet).
- Changed the listening port of Remote Desktop in the registry.
- Tried connecting with multiple computers from different networks.

I did manage to connect and control someone else's PC from MY PC (they were using a SKY Router), tried someone else's and it didn't work (they were using a Netgear router like mine).

ANY help on this would be greatly appreciated! I do not have much hope at the moment for it. :)
  • 0

Advertisements


#2
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
Hey bud,

What do you mean by "connect"? i.e. you can't see the host, or you cant log on, or you can see the host, but when you try to connect you get an error message? If it's an error message, can you please post this message.

Also, which level of remote desktop do you have turned on? The "... any version ..." option or the "... Network Level Authentication..." option?

And when you say you turned off your firewall, do you mean you just turned it off via the firewalls options, or did you go into your services, disable it, stop it, and then restart the computer? Because the Windows Firewall has an annoying habit of not wanting to be shut down completely -- even when you tell it to.

- Dan
  • 0

#3
whoelseisbored

whoelseisbored

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts

Hey bud,

What do you mean by "connect"? i.e. you can't see the host, or you cant log on, or you can see the host, but when you try to connect you get an error message? If it's an error message, can you please post this message.

Also, which level of remote desktop do you have turned on? The "... any version ..." option or the "... Network Level Authentication..." option?

And when you say you turned off your firewall, do you mean you just turned it off via the firewalls options, or did you go into your services, disable it, stop it, and then restart the computer? Because the Windows Firewall has an annoying habit of not wanting to be shut down completely -- even when you tell it to.

- Dan

Hi :)

Sorry, buy connect I mean, from another pc (external to my network) when i try to connect to this pc (home) it says something along the lines of "Could not establish a connection".

I can actually remotely access this pc from another computer on my network using my internal ip address. Just can't get to it from an external pc.

How do i check which level i have on? Bare in mind im on Vista here. :)

Thanks for the response :)
  • 0

#4
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
If you can connect from within your network fine, then this kind of suggests it's a port forwarding issue. On the host computer, can you please do the following:
  • Go to Start
  • Type cmd and press the Enter key
  • In the new command prompt window, type netstat -a
In the list of ports, look for the TCP port 3389 (or the port number that you changed to) -- is it's state listed as Listening?

Also, on the host computer, goto http://www.canyouseeme.org/ -- beside What port? type 3389 (or the port number that you changed to) and press Check. Towards the bottom of the page it should tell you whether or not it could see you; if not, it should display an error. Please post the error message.

- Dan
  • 0

#5
whoelseisbored

whoelseisbored

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts
Ok well on www.canyouseeme.org I typed in the 3389 port and it returned with:

"Error: I could not see your service on 88.***.***.** on port (3389).

Reason: Connection Refused
"

On CMD it came back with...
(see attachment)

Cheers for the help so far :)

Attached Thumbnails

  • netstat.JPG

  • 0

#6
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
Okay, so you were right; your router isn't forwarding the ports correctly. Did you follow these steps to setup your port forwarding?

And just to make sure; you are using port 3389 aren't you? You said you changed it, just want to make sure we're on the same page here.

- Dan
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP