Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Can't Get File & Print Sharing To Work


  • Please log in to reply

#1
Webslinger64

Webslinger64

    Member

  • Member
  • PipPipPip
  • 555 posts
OK, so I've connected two home computers to a router and have been able to access the Internet on both computers for a couple of weeks now. However, I have been unable to get the 'file and print sharing' activated on my network.

I reviewed the thread titled, "Home Networking & Printer/File Sharing (What you NEED to know)" under the "Important Topics" heading under "Networking", (link to thread is):

http://www.geekstogo...ng-t102163.html

and at post #5, step #7 ran into a problem.

Step #7 has an illustration (picture) for the "Select Network Service" window. In that step it shows two options to select from:

1. File and Print Sharing for Microsoft Networks

2. Service Advertising Protocol

I'm supposed to select the "File and Print Sharing for Microsoft Networks" option, but when I look at my "Select Network Service" window, I only have one option to choose from and that is"Service Advertising Protocol".

So, where is my option to choose "File and Print Sharing for Microsoft Networks"? Why doesn't my "Select Network Service" window look that same?

Thanks,

Greg
  • 0

Advertisements


#2
Mark D

Mark D

    Member

  • Member
  • PipPipPip
  • 341 posts
Howszit?

The Service Advertising Protocol is the File and Print sharing. Install that.

Other pointers... I make sure that I share at least one folder to the network, usually in My Docs, by right mouse clicking and choosing "Sharing and Security". It will ask you if you know what your doing but choose, "just enable file and printer sharing". NEVER share your C:\ directory unless you have software that requires it, (like some accounting programs I know of). You will then get a window where you can change its share name and whether other systems can change files. Do this on all systems and whatever printers that you'd like, (go to the Share tab in the printer properties).

Also make sure that all your systems are part of the same workgroup, (go to the System control panel and then the "Computer name" tab). Some versions of XP have WORKGROUP, some MSHOME. Once you have done this your network neighborhood should start filling up.

BUT... :) I have seen cases where Norton AV has blocked all networking unless it was allowed by tweaking its settings to trust your TCP/IP address ranges, (so check your AV), AND there was a version of XP issued that did not allow ANY local networking but could get out to the internet, (odd.. but true. It was a special cheap version that I think may have been only sold down here).

Good luck...

Edited by Mark D, 22 January 2009 - 11:31 PM.

  • 0

#3
Webslinger64

Webslinger64

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 555 posts

Howszit?

The Service Advertising Protocol is the File and Print sharing. Install that.

Other pointers... I make sure that I share at least one folder to the network, usually in My Docs, by right mouse clicking and choosing "Sharing and Security". It will ask you if you know what your doing but choose, "just enable file and printer sharing". NEVER share your C:\ directory unless you have software that requires it, (like some accounting programs I know of). You will then get a window where you can change its share name and whether other systems can change files. Do this on all systems and whatever printers that you'd like, (go to the Share tab in the printer properties).

Also make sure that all your systems are part of the same workgroup, (go to the System control panel and then the "Computer name" tab). Some versions of XP have WORKGROUP, some MSHOME. Once you have done this your network neighborhood should start filling up.

BUT... :) I have seen cases where Norton AV has blocked all networking unless it was allowed by tweaking its settings to trust your TCP/IP address ranges, (so check your AV), AND there was a version of XP issued that did not allow ANY local networking but could get out to the internet, (odd.. but true. It was a special cheap version that I think may have been only sold down here).

Good luck...


Heya,

Thanks for the reply. I still can't get this working properly. I followed your instructions and no go. Let me explain a bit more and hopefully I won't make it that much more confusing for you or me.

Both my desktop computers are connected to a Linksys router. Both can access the Internet to browse, send/receive e-mail, etc. My wife's computer is directly connected to our printer. I am unable to print or even see the printer on my computer. Neither of us is able to access shared folders on the other's computer.

Prior to the recent hard drive reformat and installation of Windows XP, this was all set just fine. I wasn't the one who did it, so I wasn't here to watch how it was done. I've spent hours reading through the thread on GTG explaining how to network computers, share files and a printer, and still haven't gotten it working.

When it was working before, I could open up the My Computer window and see an icon on the left side pane that said something like "Network Connections" or "Workgroup (computers near me)". Neither of those options are seen on my current My Computer window. I used to be able to select the 'computers near me' option, put in my wife's password and have access to any shared file on her computer. I've read so much about this now I think I've blown a fuse. As far as I'm concerned, this should be one of the simplest things to set up. Maybe it is and I'm just totally seeing it wrong.

Other than what I've done to get it working via Windows XP, is it possible my router is configured wrong and not allowing any sharing to go on between the two computers?
  • 0

#4
Mark D

Mark D

    Member

  • Member
  • PipPipPip
  • 341 posts
Open a command prompt on both systems. Type IPCONFIG /ALL on both. Then type PING and the IP address of the other system on each. This should tell you if both systems can see each other.

Then click on Add/remove Programs in the control panel on your system. Once its opened click on Windows Components on the left hand side scroll down to Network services, by sure there is a check in that box... It would be very odd to re-load Windows and not have this active though...

net.JPG
  • 0

#5
Webslinger64

Webslinger64

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 555 posts

Open a command prompt on both systems. Type IPCONFIG /ALL on both. Then type PING and the IP address of the other system on each. This should tell you if both systems can see each other.

Then click on Add/remove Programs in the control panel on your system. Once its opened click on Windows Components on the left hand side scroll down to Network services, by sure there is a check in that box... It would be very odd to re-load Windows and not have this active though...

net.JPG


Opened command prompt on both computers and typed out IPCONFIG /ALL on both. In each case a DOS window flashed briefly on the screen and then disappeared so I was unable to type PING and the IP address of the other system on each.

I also went to control panel, add/remove programs and clicked on Windows Components. I did find Networking Services and it was checked.
  • 0

#6
peterm

peterm

    Trusted Tech

  • Technician
  • 3,173 posts
Hi konakula29er

In each case a DOS window flashed briefly on the screen and then disappeared


How did you open the dos prompt ?
Are both machines running xp home or xp pro or a mix?. Which computer was reformatted ?
on your computer click on Start>all programs>accessories>cmd prompt.
Type in ipconfig press enter. You should get 3 number list
Ip address, Subnet mask, Default gateway.
eg 192.168.0.100
255.255.255.0
192.168.0.1
Do the same on the other computer.
The ip address should be similar, the subnet and the gateway should be the same.
On both computers click on Start right click on my network places click on properties right click on Local area connection
click on properties. Under the general tab do you have listed File and printer sharing for microsoft networks? If yes is it ticked.
Cheers
Peterm
  • 0

#7
Webslinger64

Webslinger64

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 555 posts

Hi konakula29er

In each case a DOS window flashed briefly on the screen and then disappeared


How did you open the dos prompt ?
Are both machines running xp home or xp pro or a mix?. Which computer was reformatted ?
on your computer click on Start>all programs>accessories>cmd prompt.
Type in ipconfig press enter. You should get 3 number list
Ip address, Subnet mask, Default gateway.
eg 192.168.0.100
255.255.255.0
192.168.0.1
Do the same on the other computer.
The ip address should be similar, the subnet and the gateway should be the same.
On both computers click on Start right click on my network places click on properties right click on Local area connection
click on properties. Under the general tab do you have listed File and printer sharing for microsoft networks? If yes is it ticked.
Cheers
Peterm


I used Start>Run and typed in ipconfig /all
I thought the Run window brought up the DOS window just like Start>All Programs>Accessories>cmd prompt did. Is that not right?

Both machines are running Microsoft Windows XP Professional and both computers have been reformatted now within the past 4 weeks (mine just this weekend).

Went to Start>All Programs>Accessories>cmd prompt and typed in ipconfig, pressed enter and found that the IP addresses of both computers are similar and the Subnet and Gateway are both the same.

On my computer I clicked on Start>right clicked on my network places>clicked properties>right clicked on local area connection>clicked on properties and found under the general tab there was a listing for File and Printer Sharing for Microsoft Networks. It is checked.
However, on the other computer I tried doing the same thing, but did not see any indication of a My Network Places. It's not there. So is that why I'm unable to share files and a printer between the two computers? How do I get My Network Places to appear on the Start menu?

Thanks.
  • 0

#8
peterm

peterm

    Trusted Tech

  • Technician
  • 3,173 posts
On other computer. Click on Start > Control panel >double click on network connections.
right click on Local area connection
click on properties. Under the general tab do you have listed File and printer sharing for microsoft networks? If yes is it ticked.
Cheers
Peterm
  • 0

#9
Webslinger64

Webslinger64

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 555 posts

On other computer. Click on Start > Control panel >double click on network connections.
right click on Local area connection
click on properties. Under the general tab do you have listed File and printer sharing for microsoft networks? If yes is it ticked.
Cheers
Peterm


Yes I do and it is ticked.
  • 0

#10
peterm

peterm

    Trusted Tech

  • Technician
  • 3,173 posts
Lets try printer sharing 1st
Click on Start click on printer & faxes (if not listed then go to control panel and click on printers)
Does the printer have a picture of a hand holding it ? If not
Right click on the printer then click on sharing click on share this printer.
You can give the share name you like or use the default name. Click ok. This should now put a hand under the printer.

Click on Start > my computer Is there a hand under the C drive. If not right click on c drive.
Click on sharing and security click on the blue line that starts with if you understand the risk etc etc.
Under Network sharing and security click on share this folder on the network.
You can give it a share name or you can accept the default. Click ok.
You should now have a hand under the C drive.

On your computer click on Start > printers and faxes( or go to control panel if not listed)
Go to here and follow from STEP 15 only.
Click on me
Cheers
peterm

Edited by peterm, 25 January 2009 - 08:44 PM.

  • 0

#11
Webslinger64

Webslinger64

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 555 posts

Lets try printer sharing 1st
Click on Start click on printer & faxes (if not listed then go to control panel and click on printers)
Does the printer have a picture of a hand holding it ? If not
Right click on the printer then click on sharing click on share this printer.
You can give the share name you like or use the default name. Click ok. This should now put a hand under the printer.

Click on Start > my computer Is there a hand under the C drive. If not right click on c drive.
Click on sharing and security click on the blue line that starts with if you understand the risk etc etc.
Under Network sharing and security click on share this folder on the network.
You can give it a share name or you can accept the default. Click ok.
You should now have a hand under the C drive.

On your computer click on Start > printers and faxes( or go to control panel if not listed)
Go to here and follow from STEP 15 only.
Click on me
Cheers
peterm


Is there an emoticon somewhere that would show a gigantic foot kicking me in the butt? If not, there should be. I figured out the problem and I'm embarrassed to say it was a simple explanation. The workgroup name I gave both computers was off by one 'space'. They're supposed to be the same name, but I somehow added a 'space' into the workgroup name on my wife's computer. Once I corrected that, everything showed up in My Network Places.

Thank you for your attention to my thread. Despite my foolishness, I learned a lot digging around.

Greg
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP