Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

RAM not running at proper frequency?


  • Please log in to reply

#1
actnj88

actnj88

    Member

  • Member
  • PipPip
  • 13 posts
Hey everyone,

Got my new build up and running smoothly after finding out that my RAM wasn't getting enough voltage. Now running at about 1.9v and everything seems to be working fine. However, I downloaded CPUID today and after looking at the specs it gives me for my RAM, I'm not sure that it's performing the way it should. Based on the screenshot of CPUID that I've included, does it look like I'm getting the right performance or is there something wrong that I should look into? My current system setup is using an Asus M3A78-CM motherboard with an Athlon 64 X2 6400+ CPU, GeForce 8800GT, and G.skill 2x2GB DDR2. Thanks for your time!

Justin

ram_cpuid.jpg
  • 0

Advertisements


#2
Neil Jones

Neil Jones

    Member 5k

  • Member
  • PipPipPipPipPipPipPipPip
  • 8,476 posts
It's fine.

DDR stands for Double Data Rate on it's own. Therefore the core speed is 200Mhz. Doubled is 400Mhz, and it's DDR2 so it's twice as fast again, hence DDR2 800.
  • 0

#3
Nicolet

Nicolet

    Member

  • Member
  • PipPip
  • 44 posts

It's fine.

DDR stands for Double Data Rate on it's own. Therefore the core speed is 200Mhz. Doubled is 400Mhz, and it's DDR2 so it's twice as fast again, hence DDR2 800.

Nope, thatís not right, itís double data rate, not double double data rate, 200Mhz would be 400 not 800. DDR2 is still double but with lower voltages and better efficiency over DDR, but not doubling its data rates.

The reason your motherboard is lowering the frequency of the memory is maybe that itís set that way on the BIOS settings, or that the other RAM stick can only run at 200, it will run at the slowest frequency of the sticks it has in it. So check the other RAM stick's SPD's and see if it's over 200, if it is, go into the BIOS and see if you can get it to run according to SPD's if it's not doing so already, if it is, get it up to 400 if both sticks support it.
  • 0

#4
actnj88

actnj88

    Member

  • Topic Starter
  • Member
  • PipPip
  • 13 posts

It's fine.

DDR stands for Double Data Rate on it's own. Therefore the core speed is 200Mhz. Doubled is 400Mhz, and it's DDR2 so it's twice as fast again, hence DDR2 800.

Nope, thatís not right, itís double data rate, not double double data rate, 200Mhz would be 400 not 800. DDR2 is still double but with lower voltages and better efficiency over DDR, but not doubling its data rates.

The reason your motherboard is lowering the frequency of the memory is maybe that itís set that way on the BIOS settings, or that the other RAM stick can only run at 200, it will run at the slowest frequency of the sticks it has in it. So check the other RAM stick's SPD's and see if it's over 200, if it is, go into the BIOS and see if you can get it to run according to SPD's if it's not doing so already, if it is, get it up to 400 if both sticks support it.


Thanks for the responses! Both sticks of RAM are identical, could it be that one of them is bad, or could one of the slots on the motherboard be screwy? I haven't yet checked the BIOS, but I'll do that when I get back home to see if I can change anything.
  • 0

#5
Nicolet

Nicolet

    Member

  • Member
  • PipPip
  • 44 posts
Yes, it is very possible that one of the sticks is not working at the right frequency, itís pretty simple to rule it out, just put one each time and check the frequency it runs at. But for that you would need to check the BIOS first.
  • 0

#6
actnj88

actnj88

    Member

  • Topic Starter
  • Member
  • PipPip
  • 13 posts
Sorry for the infrequent replies, been busy lately with work and school. Checked the BIOS just a little bit ago and the speed was set to 200MHz. Upped it to 400MHz (what it should be able to run at, correct?) and would no longer boot. Tried a multitude of different settings but the only thing that would make it work was setting it back to 200Mhz. Would have tried one stick at a time, but I'm currently at a friend's house doing some gaming so it'll do for now. Plus my CPU cooler is so large that it requires removal before I can take the RAM out, haha. Too much work for right now, but as soon as I get my system back home today I'll check it out. Hopefully it's just an issue with one of the sticks of RAM...Thanks again for your help!

Edit: Forgot to mention...Not sure if it matters but when I would try to run the RAM at 400MHz and it wouldn't boot, I couldn't even get into the BIOS. I had to clear the CMOS every time before I could change settings again.

Edited by actnj88, 21 February 2009 - 04:46 AM.

  • 0

#7
Nicolet

Nicolet

    Member

  • Member
  • PipPip
  • 44 posts

Edit: Forgot to mention...Not sure if it matters but when I would try to run the RAM at 400MHz and it wouldn't boot, I couldn't even get into the BIOS. I had to clear the CMOS every time before I could change settings again.

That is normal, since your RAM is not working, your BIOS is unable to do much since one of the firsts tasks it performs is detect the RAM amount and set it up to work. Iím guessing you do have a bad stick of RAM, maybe even both of them. Try to run RAM Diagnosis Tools to make sure they at least work well at 200Mhz.
  • 0

#8
stettybet0

stettybet0

    Trusted Tech

  • Technician
  • 2,579 posts
The majority of motherboards tie RAM speed with CPU speed. So, by doubling your RAM speed from 200mhz to 400mhz, you would also be doubling your CPU speed from 3.2ghz to 6.4ghz, which it certainly couldn't handle. Thus, it did not boot.

As for why your RAM was set to 200mhz in the first place, it is most likely again due to your motherboard linking your RAM speed to your CPU speed. You could try looking in your motherboard for a FSB:RAM ratio setting and changing that so that the RAM speed is in greater proportion to the FSB speed. (Though on an AMD system, it might be called something else, as it technically doesn't have an FSB.)
  • 0

#9
Nicolet

Nicolet

    Member

  • Member
  • PipPip
  • 44 posts

The majority of motherboards tie RAM speed with CPU speed. So, by doubling your RAM speed from 200mhz to 400mhz, you would also be doubling your CPU speed from 3.2ghz to 6.4ghz, which it certainly couldn't handle. Thus, it did not boot.


Where did you get that? That is not right at all, what you may be thinking about is the FSB speed, which in fact determines the CPU speed multiplied by a factor determined by the chipset. But if your RAM speed is lower than the rated FSB for the chipset, it just gets set to a lower frequency to match the current setup.
The FSB term for AMD is HyperTransport, the main difference with Intel's FSB is that intel uses one BUS for communication with RAM and all the other devices while AMD uses two, one only for the RAM and another for the rest of the devices.
  • 0

#10
stettybet0

stettybet0

    Trusted Tech

  • Technician
  • 2,579 posts
I got that from years of overclocking experience. Every motherboard I've ever used has had an FSB:RAM ratio that links FSB speed (which, as you mentioned, in turn controls CPU speed) to RAM speed. This is why overclockers tend to get faster RAM, as slow RAM can often limit how high you can overclock your CPU. The only motherboards I've used that allow this ratio to be disabled are those using an nForce chipset. But don't take my word for it, ask Google (and receive 75,000+ hits).

As the Athlon 64 X2 6400+ has a bus speed of 200mhz (source), and the user's RAM is running at 200mhz, we can deduce that the FSB:RAM ratio is 1:1. Thus, if the user tried doubling the RAM's speed without changing the FSB:RAM ratio, he would also end up inadvertently doubling the CPU's speed.

Ideally, to solve their problem, the user could change the FSB:RAM ratio to 1:2, thus keeping the CPU at stock speeds, but doubling the speed of the RAM to 400mhz.

Edited by stettybet0, 28 February 2009 - 11:30 AM.

  • 0

#11
actnj88

actnj88

    Member

  • Topic Starter
  • Member
  • PipPip
  • 13 posts
Wow, would have never thought to even look into that. Thanks a ton! I'm going to give that a try now, I'll post my results as soon as I can. :)
  • 0

#12
actnj88

actnj88

    Member

  • Topic Starter
  • Member
  • PipPip
  • 13 posts
Awesome! Went into the BIOS and changed the Hyper Transport speed to 800MHz and she booted up just fine! Thank you so much, I was pulling my hair out trying to figure out why my computer was refusing to work the way I wanted it to! Thaaaaaaaank yooooooooou! :)
  • 0

#13
actnj88

actnj88

    Member

  • Topic Starter
  • Member
  • PipPip
  • 13 posts
Well after getting everything to work with the RAM clock at 800MHz, now I'm getting lockups on a rather regular basis. It seems to be perfectly fine when playing games, I played the F.E.A.R 2 demo for a couple hours with no issues whatsoever, and a few other games just fine, but it seems like when I'm doing something miniscule, or nearly nothing at all, it'll freeze just out of the blue. Yesterday, I had to restart my computer several times due to this, and while telling somebody about the problem over MSN, it actually blue screened. Restarted before I could see what it said, and I can't find anything in the event viewer about it either. Also, I should mention that sometimes when booting it hangs at "Checking NVRAM.." My motherboard is supposed to be fully capable of running RAM at frequencies up to 1000MHz, and both sticks are the same. Any ideas?
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP