Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Problems caused by advpack.dll during software install

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 3 posts
Edit: Upon further googling, it seems that there's some sort of weird conflict between Microsoft Installer and advpack.dll. I don't really understand the whys and hows of it, or how to fix it... here's hoping someone out there does! :)

Hello all!

My name is Jessica. I am really hoping someone can help me with this error message I'm getting -- I'm at my wits' end and have tried everything I know how to do!

I'm on a small office network whose computers connect to the internet through the SonicWall Global VPN client. We just got an Asus EeePC 1000HA laptop (Windows XP Home Edition, Version 2002, SP3). I successfully connected through our wireless guest access (you can only be online for 1 hour at a time with this, so not a permanent option) and downloaded the VPN setup, but when I try to run it, I get the following error message:

Error creating process <c:\Temp\IXP000.TMP\RunMSI.exe>. Reason: C:\WINDOWS\system32\advpack.dll

These are the things I have tried without success:
- Changed environment variables from original temporary folder to C:\Temp
- Downloaded all available updates from Microsoft
- Downloaded and updated .NET Framework from Microsoft
- Ran registry cleaner
- Tried to see if I could temporarily delete or disable advpack.dll (no luck; plus, I know it really shouldn't be deleted... I was getting desperate)

Any other options fall outside of my range of knowledge and Googling skills. :)

I'm attaching a screenshot. In it, right below the error box, you can see the thing I'm trying to run -- it's the little cardboard box icon with the highlighted text next to it. I hope it helps.

Please let me know if you need any additional information.


Best regards,

Attached Thumbnails

  • errorscreenshot1.gif

Edited by jn94, 03 April 2009 - 06:04 PM.

  • 0


JR Lewis

JR Lewis

    New Member

  • Member
  • Pip
  • 1 posts
I noticed in your Picture that you're trying to install the 64bit version of the SonicWall VPN package. I would make sure that you indeed have a 64 bit OS. As on my 32bit version of XP, I saw the same error when attempting that install. Downloaded the 32bit zipped version off of the website, and install was no problem.

Hope that helps.

JR Lewis
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP